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Introduction to MarvinSketch

 MarvinSketch is an advanced chemical editor for drawing chemical structures, queries and reactions. It has a rich
 (and growing) list of editing features, is chemically aware and is able to call ChemAxon's structure based
 calculation plugins for structures on the canvas.

Rich editing:

wide range of file types supported: MOL, MOL2, SDF, RXN, RDF (V2000/V3000), SMILES, SMARTS/SMIRKS
 (recursive), MRV, InChi, CML, PDB, etc.
Copy and paste between different editors
Abbreviated groups
Pre-loaded structure templates and "My Templates"
Fog effect in 3D viewing mode
3D editing
3D geometry and conformer generation
2D cleaning and conformer generation
Advanced query features (generic atoms and bonds, atom lists/not lists, query properties, pseudo atoms,
 multiple groups, Link nodes, etc.)
Creating and editing molecule sets (without a database)
Multipage documents and printing support
Drawing and formatting shapes, arrows and text boxes
Structure annotation
User definable customisable styles (colours, structure representations, etc.)

Chemically aware

Structure based calculations can be called directly from MarvinSketch. For a complete listing of functions
 please see the Calculator Plugins section
Error checking (valence and reaction error checking)
Structure query design (R-logic, SMARTS properties, etc.)
Isotopes, charges radicals, lone pairs and aliases are supported
Manual and automapping for reaction drawing
Advanced stereochemistry functions (E/Z double bonds, R/S chirality, ABS/OR/AND enhanced stereo, etc.)

Cross platorm delivery

Marvin can run on all major operating systems, it is available in the following distributions:
Java Applets can easily be implemented into Java enabled web pages without the need for the user
 to install software or plugins
Java Beans can be directly installed to give standalone desktop applications and can also be used to
 integrate Marvin into Java based applications
Java Web Start enables web delivery of end user applications
.NET package makes it available to integrate Marvin into .NET applications
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1. Marvin Applets or Marvin Beans?

Marvin is separated to two packages depending on how you want to use it

Marvin Applets for the web developer
Marvin Beans for the chemist's desktop and for the software developer

Marvin Applets are tools for building chemical web pages, which are compatible with most browsers (Chrome,
 Firefox, Internet Explorer, Safari, Opera, etc.). They offer access from/to JavaScript and are customizable by
 applet parameters.
 Note, that the applets are signed that allows the same feature set as the applications.

Marvin Beans are easy-to-install applications for the desktop and tools for integrating Marvin capabilities into
 any application.

2. System Requirements

2.1. Marvin Applets

Java distributed by Oracle (or Apple's Mac OS X built-in Java)
Version: Java 1.6.0_13 or higher
Java 2 enabled browser

2.2. Marvin Beans for Java

Java distributed by Oracle (or Apple's Mac OS X built-in Java)
Version: Java 1.6.0_13 or higher

2.3. Marvin Beans for .NET

.NET framework 3.5 SP1. Please note that .NET framework 4 does not include the version 3.5.

2.4. How to get Java?

http://onlinelibrarystatic.wiley.com/marvin/help/developer/applets/signing.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/applets/browsers.html
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You can download Java from Oracle's official site or contact your OS manufacturer.

If you use Mac OS X, probably Java is already installed on your machine. If not, select Java in the Software
 Update center to install or update.

Which Java do I need?

You need Java Runtime Environment (JRE) installed on your system to run applications and applets.
To develop applications and applets, you need the Java Development Kit (JDK), which includes the JRE.
Version: Java 1.6.0_13 or higher

Testing Java

If you are not sure whether Java is installed or not on Windows, you can check it the following way:

1. Select Command Prompt from the Accessories sub-menu in the Start menu.
2. Type the following commands in the opened Command Prompt window: java -version
3. You will get the following error message if Java is not available on your machine:

'java' is not recognized as internal or external command, operable program or batch file

 If Java is installed, the version number of Java will be printed:

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02, mixed mode)

You can test whether Java is working on your computer on Oracle's official testing site, too.

2.5. How to get .NET framework?

 .NET framework 3.5 SP1 is included in Windows 7 by default. For other Windows OS you can download the .NET
 framework from Microsoft's official site.

.NET framework 3.5

.NET framework 3.5 Service Pack 1

3. Installation

3.1. Marvin Applets

1. Download the Marvin Applets package according to your platform from the Marvin download page.
 (.tar.gz is recommended for Unix-like platforms, .zip for others).

2. You need a web server on the machine where you would like to install the Marvin Applets package (because
 applets work properly only through HTTP protocol). If there is no web server on the target machine, we
 suggest to use Tomcat.

3. Extract marvin-all-VERSION.tar.gz (in Unix or in Mac OS X) or marvin-all-VERSION.zip (in MS Windows) in
 the parent directory of "marvin", where VERSION is the current version number.

4. Modify the settings of the web server if the directory of Marvin is not accessible from the web server root.
 Then restart it (if it is necessary) to validate new settings. (Consult with the manual of the web server how
 to do it.)

5. Open the index.html file in a browser.

Removing any binary (jar or zip) or configuration (properties or xml) file from the applet package can cause
 unexcepted error or limitation in the usage.

3.2. Marvin Beans for Java

http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://java.com/en/download/testjava.jsp
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/en-us/download/details.aspx?id=22
http://onlinelibrarystatic.wiley.com/marvin/download-dev.html#marvinapplets
http://tomcat.apache.org/index.html
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 Download the package according to your platform from one of the links below:

Download Marvin for End Users to install desktop applications
Download Marvin for Developers to use the tools for application development

Notes:

After installation, at the first launch of MarvinSketch, a dialog asks the user to select the desired skin for
 the GUI configuration: 

 
The selected configuration can be changed later any time.

3.2.1. Windows

If you have a 64-bit Windows, you can choose both the normal (32-bit) Marvin Beans installer or its 64-bit
 version.

The following table helps you to choose which installer can you use on your platform.

Installer

32-bit
 Windows 64-bit Windows

without
 Java

with
 Java

without
 Java

 with 32-
bit Java

with 64-
bit Java

marvinbeans-VERSION-windows.exe  NO  YES  NO  YES  NO

marvinbeans-VERSION-windows_with_jre.exe
 (bundled with 32-bit Java)  YES  YES  YES  YES  YES

marvinbeans_VERSION-windows_64bit.exe  NO  NO  NO  NO  YES

If you have a 64-bit Windows, follow the instructions in the 64-bit Windows section.

1. Double-click on marvinbeans-VERSION-windows.exe or marvinbeans-VERSION-windows_with_jre.exe to install.
2. You can add the bin folder of Marvin Beans to the PATH environment variable to be able to run Marvin

 applications from any directory in the command line. Details about editing environment variables is
 described in Windows Help.

Notes:

Please make sure to close all running Marvin applications before starting the installer otherwise it
 may not be able to perform the installation correctly (overwriting certain .jar files is not possible if they
 are being used by a running application).
 Running applications may include:

Marvin desktop applications
MS-Office documents where Marvin Objects are being edited
Running applications where Marvin is embedded, like Instant JChem

 In this image, you can see an error message displayed during installation. Checking the running processes
 you can find that marvinOLEServer.exe is running, which means that an MS-Office document is just using

http://onlinelibrarystatic.wiley.com/marvin/download-user.html
http://onlinelibrarystatic.wiley.com/marvin/download-dev.html#marvinbeans
http://onlinelibrarystatic.wiley.com/marvin/help/images/install-error.png
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 Marvin.
You can run the installer in silent/non-interactive mode, which means that in case Marvin is already
 installed, it will be overwritten with the update without the need of checking the "OK" and "Next" buttons
 on the installer dialogs. To enable this mode, use the -q option (for example open the command prompt
 with cmd.exe and type "marvinbeans-5_3_0.exe -q").

64-bit Windows

System requirements: 64-bit Windows system having an installed Java for 64-bit architecture.

1. After downloading marvinbeans-VERSION-windows_64bit.exe, take a double-click on the downloaded
 file (accept running if Windows expects verification).

2. Installer is started: go through the installation wizard. The installer will setup the 64-bit version of
 JChem_NET_API automatically (that is wrapped into the installer).

Notes:

JChem_NET_API is required to be able to insert Marvin OLE (embedded object) into MS-Office document or
 transfer it between Marvin and the MS-Office applications.
Earlier versions of MS-Office suites are not available in 64-bit format. If your Office does not support 64-bit
 platform, you cannot use the OLE functionality of 64-bit version of Marvin. In this case, install 32-bit
 version of Marvin Beans and JChem_NET_API that can incorporate with 32-bit Office applications.
When you edit an embedded Marvin Object in Office, the editor can be different depending on the platform.

MS-Office 32-bit requires 32-bit JChem .NET API for Marvin embedding. It uses 32-bit .NET
 implementation of MarvinSketch unless 32-bit Marvin Beans package is installed. In this case, it
 prefers the 32-bit Java implementation.
MS-Office 64-bit requires 64-bit JChem .NET API for Marvin embedding. The 64-bit .NET implentation
 of MarvinSketch is used in all cases.

See further notes in 32-bit Windows section: here.

3.2.2. MAC OS X

1. Double-click marvinbeans-VERSION-macos.dmg to install.
2. You can add the bin folder of the Marvin Beans folder to the PATH to be able to run Marvin applications

 from any directory in command line.

Notes:

Requires Mac OS X 10.0 or later
The compressed installer should be recognized by Stuffit Expander and should automatically be expanded
 after downloading. If it is not expanded, you can expand it manually using StuffIt Expander 6.0 or later.
If you have any problems launching the installer once it has been expanded, make sure that the
 compressed installer was expanded using Stuffit Expander. If you still have problems, please contact our
 technical support.
You can run the installer in silent/non-interactive mode, which means that in case Marvin is already
 installed, it will be overwritten with the update without the need of confirmation. To enable this mode, use
 the -q option.

3.2.3. Linux / Solaris

1. Open a shell and cd to the directory where you downloaded the installer.
2. Type the following to install: sh marvinbeans-VERSION-linux.sh (or sh marvinbeans-VERSION-

linux_with_jre.sh depend on which package has been downloaded).
3. You can add the bin subdirectory of the Marvin Beans directory to the PATH to be able to run Marvin

 applications from any directory.

http://www.aladdinsys.com/expander/index.html
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Notes:

If the installer does not start, check whether JAVA_HOME/bin is in PATH (where JAVA_HOME is the
 directory of Java).
 To check it, type the "which java" command that shows the location of the Java launcher. You should get
 something like this:

/usr/java/jdk1.6/bin/java

 If Java is missing from PATH, you will see something like that:

/usr/bin/which: no java in (/usr/java/jdk1.6/bin:/opt/apache-ant-

1.6.1/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/vertset/bin)

You can run the installer in silent/non-interactive mode, which means that in case Marvin is already
 installed, it will be overwritten with the update without the need of confirmation. To enable this mode, use
 the -q option. If you are in terminal mode (GUI is not accessible), we recommend to use this option.

3.2.4. Other Platforms

1. Go to the directory where marvinbeans-VERSION.zip was downloaded then uncompress the zip file.
2. You can start applications via scripts or batch files that you can find in the marvinbeans/bin directory.

Notes:

You need an expander which can handle zip extension.

Batch files (bin/*.bat) have to be initialized before the first use. Set the MARVINBEANSHOME variable in the
 files to the full path of the directory where Marvin Beans is located.

3.2.5. How to uninstall?

 Use the uninstaller to remove Marvin Beans from your machine. If you give the -q command line parameter by
 running the uninstaller, it will run in silent mode (no GUI, non-interactive mode).

Windows: Double click on uninstall.exe in the Marvin Beans's home folder or select Marvin Beans from
 the Add / Remove programs list on Control Panel.
OS X: Double click on ChemAxon Marvin Beans Uninstaller in the Marvin Beans' home directory.

Linux / Solaris: Launch the uninstall script in the Marvin Beans' home directory.

3.2.6. Additional package

Who needs this package?

Install marvinbeans-lib-VERSION-signed.zip only if you need the signed version of the Marvin Beans
 package.
 If you would like to launch Marvin applications via Java Web Start from your server, you will need
 the signed version for security reasons.
 Please note that this archive can only be used as an extension of the already installed Marvin Beans
 package.

Installation

1. Check the product version of the Marvin Beans package you have already installed. You can
 find the product version of your installed disribution in the Help > About dialog or in the
 version.properties file located in the Marvin Beans installation directory.

2. Download the additional package for exactly the same version: marvinbeans-lib-VERSION-
signed.zip.
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3. Create a backup of the lib sub-directory of your Marvin Beans package.
4. Extract the marvinbeans-lib-VERSION-signed.zip archive file into the Marvin Beans

 directory. Your extractor tool (e.g. unzip or WinZip) may ask confirmation to update all files by
 unwrapping. In this case let it overwrite all. This operation will update the jar files (overwrite
 them with the signed versions) in the lib sub-directory of the installed Marvin Beans package.

3.3. Marvin Beans for .NET

The Marvin Beans package for .NET platform can be downloaded from this link.

4. Version Number

 From the Marvin version 5.7, in the file name of any downloadable artifacts, an identifier appears that indicates
 the internal build number of the file. This identifier begins with _b and continous with a number. It is
 automatically generated and help to identify the file in the build system of ChemAxon.

 

 
Copyright © 1998-2013 ChemAxon Ltd.    All rights reserved.

http://onlinelibrarystatic.wiley.com/marvin/download-dev-dotnet.html
http://www.chemaxon.com/
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MarvinSketch Application Options

Version 6.1.7

 The Marvin Beans package contains the MarvinSketch application.

Usage

msketch [options] [files or URLs...]

Options

-h
--help  Print command line help

- Import a structure from standard input

--debug  Verbose debugging messages for cut/copy/paste and drag & drop

--imageImportServiceURL=
[URL]

 Specifies the URL of an image import service for the Sketcher to
 use.

You can also pass options to Java VM when you run the application from command line.

Examples

1. Start MarvinSketch with an empty sketcher window:

msketch

2. Start MarvinSketch by loading two molfiles in two windows:

msketch caffeine.mol l-adrenaline.mol

MarvinSketch Parameters and Events

http://onlinelibrarystatic.wiley.com/marvin/help/applications/javaoptions.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/sketchman.html
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License Management

 This documentation contains detailed instructions about licensing ChemAxon products.

For the online version please visit this link: http://www.chemaxon.com/marvin/help/licensedoc/index.html

 Contents:

About ChemAxon Licensing
About ChemAxon Products
Requesting License
Getting Help
Installing Licenses
Frequently Asked Questions

Links:

Managing License Keys for versions prior to 5.0
Free Software
License Details

http://www.chemaxon.com/marvin/help/licensedoc/index.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/licensing.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/products.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/request.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/gethelp.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/install.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/licenseFAQ.html
http://onlinelibrarystatic.wiley.com/marvin/help/licensedoc/licensing_old.html
http://www.chemaxon.com/prices.html
http://www.chemaxon.com/License_Details.html
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MarvinSketch Graphical User Interface

Table of Contents

The default layout of the MarvinSketch user interface is shown in the following picture.

 It consists of the following primary components:

Menu Bar: It is located at the top of the main frame, containing menu titles that describe the content of
 each menu.

Canvas: This is the main area where chemical structures, queries and reactions are drawn.

General Toolbar: This toolbar contains buttons for freqently used commands.

Tools Toolbar: Contains basic elements for stucture drawing like bond, chain, reaction arrow, graphics, etc.

Atoms Toolbar: Location of the most freqent atom types and the Periodic System button.

Advanced Templates Toolbar: This special toolbar is a container of structure templates. The templates are
 rotatable by pressing and holding down the left mouse button while dragging. 

Status Bar: Shows file status, contains navigation buttons and the dimension button.
 The Status Bar appears at the bottom of the main frame, and unlike toolbars, it cannot be customized or
 moved.
 Some buttons of the Status Bar appear dynamically when you invoke the corresponding command, like
 enabling multipage molecular documents.
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Return to Top

 Copyright © 1998-2013 ChemAxon Ltd.

http://www.chemaxon.com/marvin

http://www.chemaxon.com/
http://www.chemaxon.com/marvin
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Canvas of MarvinSketch

The canvas is the main area where chemical structures, queries and reactions are drawn.

Basic Navigations

Zooming the Canvas

To zoom in or out on the canvas, you can choose the Zoom In, Zoom Out or Zoom Tool of General Toolbar. The
 View Menu has also options to change the magnification of the canvas. If you have a mouse with a wheel, you
 can also use Ctrl+Mouse Wheel to zoom in or out on the canvas. When using Ctrl+Mouse Wheel to zoom, the
 actual position of the cursor will define the center of zooming.

Scrolling the Canvas

Drawing on the canvas activates the horizontal and vertical scroll bars. To move the canvas click the Scroll Arrow
 of the scroll bar or drag the Scroll Box to scroll the canvas in the preferred direction. You can also use the
 appropriate Arrow Key of your keyboard to move the canvas. Note: Moving the Canvas with Arrow Keys works
 only when no selection is made or everything is selected on the Canvas. When an item is selected on the canvas,
 the Arrow Keys will move the marked object. Ctrl+Arrow key can be used to move the canvas in this case.
 Shift+Arrow keys will move the selected items in greater units. The undo operation recalls the former direction of
 these movements. If you have a mouse with a wheel, use the Mouse Wheel to scroll the canvas up or down and
 use Shift+Mouse Wheel to scroll the canvas left or right.



Menus of MarvinSketch

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/menubar.html[11/4/2015 9:56:54 PM]

Menus of MarvinSketch

The Menu Bar contains almost all commands that are available in MarvinSketch.
 The main menus are groups of functionally similar commands shown in the following picture: 

File Menu
The File menu contains the available file operations, such as New, Open, Save, Print, and Close. (Note that
 the unsigned Swing applets contain only a subset of these functions.)

Edit Menu
The Edit menu contains general clipboard operations like Copy and Paste, structure selecting and deleting
 commands, as well as Marvin-specific editing options.

View Menu
The View menu allows you to alter the way the molecule is displayed without modifying the structure file
 itself. You can change the molecule display type, background color, color scheme, error highlighting, etc.
 See also: Structure Display Options.
 The view menu also contains operations to change the graphical user interface.

Insert Menu
The Insert menu allows drawing structure templates, bonds, reaction arrows, graphics, text boxes, and
 more on the canvas. See also: How To Draw Graphic Objects and Text Boxes.

Atom Menu
 Contains all atom related properties such as charge, atom radicals, maps, and many more.

Bond Menu
 Allows changing the type of a bond, and makes bond properties available like bold, topology, reacting
 center, etc.

Structure Menu
 Provides chemical functions relating to structures like molecule cleaning, aromatization, reaction-handling,
 naming and more.

Calculations Menu
 Contains the available Calculator Plugins.

Tools Menu
 Contains the available Services.

Help Menu
 Provides information about using the program, technical details and license management.

Full Menu Reference

File Menu

New > Clear Desk Removes the structure being on the canvas including all fragments and graphical
 objects.

New > New Window Opens another MarvinSketch window.

Open Loads your saved molecule file into Marvin and discard any unsaved changes to the
 molecule you were previously working with.

Insert File Inserts your saved molecule file into the canvas whitout erasing its former content.

Save Saves the molecule to the same file it was opened from and in the same format. If
 you are working with a new molecule, Save will function as Save As.

Save As Saves the molecule in a different location or with a different file name or format.

Import Name Opens the Source window in IUPAC Name format, and enables you to enter directly
 a IUPAC Name and convert it to structure.
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Import Image Tries to convert an image file to a structure using OSRA.
Export to Image Exports the molecule to the required location in the required image format.
Find Structure Online >
 Find Structure in
 ChemSpider

If ChemSpider contains the structure, it opens the records in your default browser.

Find Structure Online >
 Find Structure in
 Chemicalize

If Chemicalize.org contains the structure, it opens the records in your default
 browser.

Find Structure Online >
 Find Structure in PubChem If PubChem contains the structure, it opens the records in your default browser.

Print Prints an image of the current molecule.
Document Style Changes atom and bond drawing properties in the document.

Multipage Settings Creates a multipage molecular document that helps to work with large drawings by
 dividing them into pages.

Recent Lists of recently used file names.
Close Finishes working with the currently open molecule.
Exit Saves GUI settings, preferences and My Templates before exiting the application.

Edit Menu

Undo Reverses the last command or the last entry you typed.
Redo Reverses the action of the last Undo command.
Cut Removes and copies the selection to the clipboard.
Copy Copies the selection to the clipboard.
Copy As Copies the selection to the clipboard in the specified format.
Copy As Smiles Copies the selection to the clipboard in SMILES format.

Paste Inserts the contents of the clipboard at the location of the cursor, without replacing
 selection.

Select All Selects the structure being on the canvas including all fragments and graphical
 objects.

Delete Removes the selection from the canvas.

Transform These transformations affect the molecular coordinates. Note: The structure will be
 saved with the altered coordinates.

Transform > Drag Selection Moves selection on the canvas with changing coordinates.
Transform > Rotate in 2D Rotates selection in the plane of the canvas with changing coordinates.
Transform > Rotate in 3D >
 Around arbitrary axis Rotates selection in 3D around an axis defined by two atoms selected by the user.

Transform > Rotate in 3D >
 Around X axis Rotates selection in 3D around a horizontal axis placed in the canvas.

Transform > Rotate in 3D >
 Around Y axis Rotates selection in 3D around a vertical axis placed in the canvas.

Transform > Rotate in 3D >
 Around Z axis Rotates the selection in 3D around an axis perpendicular to the canvas.

Transform > Rotate in 3D >
 Free 3D rotation

Rotates selection in 3D with changing coordinates. Compare it to the Rotate in 3D
 transformation of View Menu, which affects only the position of observation.

Transform > Rotate in 3D >
 Group rotation The selected group rotates around the bond that connects it to the molecule.

Transform > Switch
 Transformation

Changes transformation mode from Drag to Rotate in 2D, Rotate in 2D to Rotate in
 3D, while Rotate in 3D to Drag.

Transform > Flip > Flip
 Horizontally

Flips the selected object(s) horizontally, preserving the configuration of all
 enantiomers.

Transform > Flip > Flip
 Vertically

Flips the selected object(s) vertically, preserving the configuration of all
 enantiomers.

Transform > Flip > Rotate
 180° in Canvas

Rotates the selected object(s) on the canvas plane, preserving the configuration of
 all enantiomers.

Transform > Flip > Group
 Flip

Rotates the selected structure group by 180° around an axis set on the bond
 connecting the selection to the rest of the molecule. Stereocenters in the molecules
 are retained, the wedge bond styles change to keep the stereo information.

http://onlinelibrarystatic.wiley.com/marvin/help/formats/imageimport.html
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Transform > Mirror > Mirror
 Horizontally

Mirrors the selected object(s) horizontally, inverting the configuration of all
 enantiomers.

Transform > Mirror > Mirror
 Vertically

Mirrors the selected object(s) vertically, inverting the configuration of all
 enantiomers.

Transform > Mirror > Mirror
 to Canvas Plane

Mirrors the selected object(s) to the canvas plane, inverting the configuration of all
 enantiomers.

Transform > Mirror >
 Group Mirror Mirrors the selected group if it has only one connecting bond to the structure.

Transform > Invert >
 Invert to geometric center Reflects the selected fragment(s) through the geometric center point.

Transform > Invert >
 Invert to an arbitrary
 center

Reflects the selected fragment(s) through the chosen point in any fragment (an
 atom).

Transform > 3D plane Rotates the molecule to place the selected 3 atoms into the plane of the canvas.
Object > Bring to Front Brings the selected object in front of all others.
Object > Send to Back Places the selected object behind all others.
Object > Align Aligns the centers of the selected objects horizontally or vertically on the canvas.

Object > Distribute Distributes the selected objects horizontally or vertically in the space defined by the
 furthermost objects.

Object > Align and
 Distribute Performs alignment and distribution horizontally or vertically.

Template Library Organized collection of template molecules can be edited.

Source You can alter a molecule by directly editing its source in the Edit Source Window.
 You can view and edit the source in any of the supported file formats.

Preferences The Preferences dialog window allows you to change many of the MarvinSketch
 display settings, including look & feel, error highlighting, and object visibility.

View Menu

Mouse Mode > Sketch The Sketch mode allows drawing into the canvas.

Mouse Mode > Zoom Zoom the content of the canvas by dragging the mouse without modifying atom
 coordinates.

Mouse Mode > Rotate in 3D
Spin the structure around its central point in 3 dimension with the help of the mouse
 without modifying atom coordinates. Compare it to the Free 3D rotation of Edit
 Menu, which affects the molecular coordinates.

Mouse Mode > Reset View Restores the starting view as modified by rotation and zoom.

Zoom Level Allows you to select a magnification percentage from the list or to type a custom
 percentage.

Structure Display > Atom
 Symbols in 3D

Sets atom symbol visibility in 3D mode. Note that in 3D mode, atoms may become
 invisible in Wireframe and Stick mode by hiding atom symbols.

Structure Display >
 Wireframe Displays bonds as thin lines, and atoms (except Carbon) as symbols.

Structure Display >
 Wireframe with Knobs Displays bonds as thin lines, Carbon atoms as knobs, and other atoms as symbols.

Structure Display > Stick Displays bonds as thick lines, and atoms (except Carbon) as symbols.
Structure Display > Ball
 and Stick

Displays bonds as thick lines, atoms as shaded balls, and atoms (except Carbon and
 Hydrogen) as symbols on balls.

Structure Display >
 Spacefill

Displays atoms as large shaded balls, and atoms (except Carbon and Hydrogen) as
 symbols on the balls.

Structure Display > Quality
 > Low Quality Disables line anti-aliasing.

Structure Display > Quality
 > High Quality Enables line anti-aliasing.

Colors > Monochrome Displays all atoms with default drawing color.
Colors > CPK Displays all atoms with Corey-Pauling-Kultun colors.

Colors > Shapely This color scheme is based on RasMol's shapely color scheme for nucleic and amino
 acids.

Colors > Group Coloring atoms based on PDB residue numbers.
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Colors > Atom/Bond Sets Colors atoms and bonds according to the color of the pre-defined set they belong to.
Colors > Background Sets custom background color with adjusted default drawing color.
Colors > White Background Sets the background color to white and the default drawing color to black.
Colors > Black Background Sets the background color to black and the default drawing color to white.
Stereo > R/S Labels > All Always show atom chirality (R/S).
Stereo > R/S Labels >
 Absolute Stereo

Show atom chirality if chiral flag is set for the molecule or the atom's enhanced
 stereo type is absolute.

Stereo > R/S Labels >
 None Do not show atom chirality (R/S).

Stereo > E/Z Labels Toggles the display of absolute double bond stereo configuration labels. Bonds
 known to have an (E) or (Z) configuration will be marked as such.

Stereo > Absolute Labels Toggles the display of the Absolute label if the chiral flag is set on the molecule.

Implicit Hydrogens > On All View hydrogens by symbol on all atoms. This option is disabled in Spacefill and Ball
 & Stick display modes.

Implicit Hydrogens > On
 Hetero and Terminal

View hydrogens by symbol on hetero and terminal carbon atoms. This option is
 disabled in Spacefill and Ball & Stick display modes.

Implicit Hydrogens > On
 Hetero

View hydrogens by symbol on hetero atoms only. This option is disabled in Spacefill
 and Ball & Stick display modes.

Implicit Hydrogens > Off Disable hydrogens by symbol on all atoms.
Peptide Display > 1-letter View peptide sequence with 1-letter aminoacid codes.
Peptide Display > 3-letter View peptide sequence with 3-letter aminoacid codes.
Advanced > Atom
 Numbering > Off Disable the visibility of atom indices.

Advanced > Atom
 Numbering > Atom
 Number

Enable the visibility of unique internal atom indices. The indices are continuous
 starting from 1.

Advanced > Atom
 Numbering > IUPAC
 Numbering

Enable the visibility of IUPAC numbering of atoms in a molecule. It is synchronized
 with the numbering of "Structure to name" option.

Advanced > Atom
 Properties Toggles the visibility of atom properties.

Advanced > Atom Mapping Toggles the visibility of atom mapping labels.
Advanced > Graph
 Invariants Toggles the display of graph invariants (canonical labels).

Advanced > Bond Lengths Toggles the display of bond lengths in Angstroms on the middle of the bonds.
Advanced > Lone Pairs Toggles the display of lone pairs.
Advanced > R-groups Toggles the display of R-group definitions.
Advanced > R-logic Toggles the display of R-logic definitions.
Advanced > Valence Toggles the display of valence numbers. Default setting is On.
Advanced > Ligand Error Toggles the display of ligand errors. Default setting is On.
Pages > Fit Page Width Adjusts the width of the current page to the width of the canvas.
Pages > Fit Page Height Adjusts the height of the current page to the height of the canvas.

Pages > Fit Page Adjusts the current page so that the whole current page will be placed centralized
 within the canvas.

Pages > Previous Page Goes to the previous page of multipage molecular document.
Pages > Next Page Goes to the next page of multipage molecular document.
Pages > First Page Goes to the first page of multipage molecular document.
Pages > Last Page Goes to the last page of multipage molecular document.

Pages > Goto Page Goes directly to a specific page by entering a number in the appearing dialog
 window.

Open MarvinSpace Launches a MarvinSpace window containing the current molecule from the Sketcher.
Toolbars > Toolbars Sets the visibility of individual toolbars.
Menubar Sets the visibility of the main menubar.
Status Bar Sets the visibility of the status bar.
Editor Style >
 Configurations Lists the available configurations, and allows quick switch.

Editor Style > Configuration Configurations are GUI alternatives storing whole menu, toolbar and popup
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 Settings  personalizations. This makes easy to define and quickly change the GUI for various
 purposes like sketching, publishing, teaching, etc.

Editor Style > Reset
 Current Configuration

Removes all local modifications made on the active GUI configuration. Note that this
 action cannot be undone.

Editor Style > Customize Customization allows you to personalize the GUI of MarvinSketch including menus,
 toolbars and keyboard shortcuts.

Insert Menu

Template Library Organized collection of template molecules.
Groups The full list of Abbreviation Groups.

New Structure Opens a new MarvinSketch window to add new fragments to tha canvas without
 having to change e.g. the 3D view mode.

Bond > Single Places Single type bond on the canvas.
Bond > Double Places Double type bond on the canvas.
Bond > Triple Places Triple type bond on the canvas.
Bond > Aromatic Places Aromatic type bond on the canvas.
Bond > Single Up Places Single Up type wedge bond on the canvas.
Bond > Single Down Places Single Down type wedge bond on the canvas.
Bond > Single Up or Down Places Single Up or Down type wedge bond on the canvas.
Bond > Double Cis or Trans Places Double Cis or Trans query type double bond on the canvas.
Bond > Double C/T or
 Unspec Places Double C/T or Unspec query type double bond on the canvas.

Bond > Single or Double Places Single or Double type bond on the canvas.
Bond > Single or Aromatic Places Single or Aromatic type bond on the canvas.
Bond > Double or Aromatic Places Double or Aromatic type bond on the canvas.
Bond > Any Places Any type bond on the canvas.
Bond > Coordinate Places Coordinate type bond on the canvas.

Chain > Chain
Places a carbon chain on the canvas. The number of carbon atoms can be increased
 or decreased by dragging the mouse. The chain drawing direction is mirrored based
 on the direction of the mouse movements.

Chain > Curved Chain

Places a curved carbon chain on the canvas. The direction of the chain growth
 follows the mouse path. The number of carbon atoms can be increased or
 decreased by dragging the mouse. The chain drawing direction is mirrored based on
 the direction of the mouse movements.

Arrow > Single Reaction
 Arrow Places a Single Reaction Arrow object on the canvas.

Arrow > Retrosynthetic
 Arrow Places a Retrosynthetic Arrow object on the canvas.

Arrow > Equilibrium Arrow Places an Equilibirum Arrow object on the canvas.
Arrow > Two-headed Arrow Places a Two-headed Arrow object on the canvas.
Arrow > Single Arrow Places a Single Arrow graphical object on the canvas.
Arrow > Graph.
 Retrosynthetic Arrow Places a Retrosynthetic Arrow graphical object on the canvas.

Arrow > Graph. Equilibrium
 Arrow Places an Equilibrium Arrow graphical object on the canvas.

Arrow > Resonance Arrow Places a Resonance Arrow graphical object on the canvas.
Arrow > Curved Arrow Places a Curved Arrow graphical object on the canvas.
Arrow > Dashed Arrow Places a Dashed Arrow graphical object on the canvas.
Arrow > Crossed Arrow Places a Crossed Arrow graphical object on the canvas.
Bracket > Parentheses Places a Parentheses object on the canvas.
Bracket > Square Brackets Places a Square Brackets object on the canvas.
Bracket > Braces Places a Braces object on the canvas.
Bracket > Chevrons Places a Chevrons object on the canvas.

Electron Flow > 1 Electron Places an electron flow arrow object on the canvas representing one-electron
 transfer.

Electron Flow > 2 Electrons Places an electron flow arrow object on the canvas representing two-electron

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/electronflow.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/electronflow.html
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 transfer.
Graphics > Line Places a Line object on the canvas.
Graphics > Single Arrow Places a Single Arrow graphical object on the canvas.
Graphics > Graph.
 Retrosynthetic Arrow Places a Retrosynthetic Arrow graphical object on the canvas.

Graphics > Graph.
 Equilibrium Arrow Places an Equilibrium Arrow graphical object on the canvas.

Graphics > Resonance
 Arrow Places a Resonance Arrow graphical object on the canvas.

Graphics > Curved Arrow Places a Curved Arrow graphical object on the canvas.
Graphics > Dashed Arrow Places a Dashed Arrow graphical object on the canvas.
Graphics > Crossed Arrow Places a Crossed Arrow graphical object on the canvas.
Graphics > Polyline Places a Polyline object on the canvas.

Graphics > Rectangle Places a Rectangle object (Square object in case the Shift button is pressed) on the
 canvas.

Graphics > Rounded
 Rectangle

Places a Rounded Rectangle object (Rounded Square object in case the Shift button
 is pressed) on the canvas.

Graphics > Ellipse Places an Ellipse object (Circle object in case the Shift button is pressed) on the
 canvas.

Text Places a Text object on the canvas. Allows changing text properties on the appearing
 toolbar.

Atom Menu

Stereo > R/S > Off Removes the absolute stereo configuration from a chiral atom along with the
 marking wedge bond.

Stereo > R/S > R Sets the absolute stereo configuration on a chiral atom to R, marking it with wedge
 bond.

Stereo > R/S > S Sets the absolute stereo configuration on a chiral atom to S, marking it with wedge
 bond.

Stereo > Reaction > Off Sets the stereo configuration of the atom not to be considered during the reaction.
Stereo > Reaction >
 Inversion Sets the stereo configuration of the atom to be inverted during the reaction.

Stereo > Reaction >
 Retention Sets the stereo configuration of the atom to be retained during the reaction.

Stereo > Enhanced See Stereo Documentation for details.

Charge
Allows you to change the charge of any atom between [-128, 128]. The number of
 implicit hydrogens will be adjusted if possible to accommodate the new charge.
 Valence errors will be highlighted in red.

Valence Allows you to change the valence of any atom between [0, 8].
Radical > Off Removes the radical designation from an atom.
Radical > Monovalent Sets Monovalent radical center.
Radical > Divalent Sets Divalent radical center.
Radical > Divalent Singlet Sets Divalent radical center with singlet electronic configuration.
Radical > Divalent Triplet Sets Divalent radical center with triplet electronic configuration.
Radical > Trivalent Sets Trivalent radical center.
Radical > Trivalent Doublet Sets Trivalent radical center with doublet electronic configuration.
Radical > Trivalent Quartet Sets Trivalent radical center with quartet electronic configuration.

Isotope Sets or changes the isotope number of the selected element, or resets the default
 atom (no isotope) when it is set to Off.

Map
Sets map labels/identifiers on the selected atoms that do not change while altering
 the molecule. They are useful when dealing with reactions, and can be saved in
 SMILES and MDL formats.

R-group Changes the selected atom to an R-group label. R-groups symbolize alternative
 substituents.

R-group Attachment The selected atom becomes the attachment point for the substituent.
R-group Attachment Order Changes the order (numbering) of the attachment points.
Link Node Specifies query structures containing rings or chains of variable size.
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Periodic Table Shows Periodic Table and query/atom property drawing window.
Edit Properties Specifies the property of an atom.
Add S-group attachment If the selected atom is part of an S-group, you can specify an attachment point.
Remove S-group
 attachment Removes the highest-numbered attachment point from an atom of an S-group.

Bond Menu

Type > Single Changes the selected bond type to Single.
Type > Double Changes the selected bond type to Double.
Type > Triple Changes the selected bond type to Triple.
Type > Aromatic Changes the selected bond type to Aromatic.
Type > Single Up Changes the selected bond type to Single Up.
Type > Single Down Changes the selected bond type to Single Down.
Type > Single Up or Down Changes the selected bond type to Single Up or Down.
Type > Double Cis or Trans Changes the selected bond type to Double Cis or Trans.
Type > Double C/T or
 Unspec Changes the selected bond type to Double Cis/Trans or Unspec.

Type > Single or Double Changes the selected bond type to Single or Double.
Type > Single or Aromatic Changes the selected bond type to Single or Aromatic.
Type > Double or Aromatic Changes the selected bond type to Double or Aromatic.
Type > Any Changes the selected bond type to Any.
Type > Coordinate Changes the selected bond type to Coordinate.
Bold Changes the selected bond to Bold. See details on bold tool application.
Hashed Changes the selected bond to Hashed.
Topology > None Unsets the bond topology property.

Topology > In Ring Sets a bond property so that when the molecule is used as a query, the specified
 bond must be in a ring to score a hit.

Topology > In Chain Sets a bond property so that when the molecule is used as a query, the specified
 bond must be in a chain to score a hit.

Reacting Center > None Unsets reacting center query feature of the selected bond.

Reacting Center > Center Sets reacting center query feature on the selected bond: the bond takes part in the
 reaction.

Reacting Center > Make or
 Break

Sets reacting center query feature on the selected bond: the bond is created or
 disappears in the reaction.

Reacting Center > Change Sets reacting center query feature on the selected bond: the bond remains in the
 reaction, but its bond type changes, for example from single to double.

Reacting Center > Make
 and Change

Sets reacting center query feature on the selected bond: currently it works exactly
 as "Center".

Reacting Center > Not
 Center

Sets reacting center query feature on the selected bond: the bond must not change
 in the reaction.

Stereo Search Uses stereo configuration of the specified double bond when this molecule is used as
 a query.

Regenerate Bonds Generate bonds for an XYZ structure with a different bond length cut-off.
Align > Horizontally Alters the molecule so that the selected bond is oriented horizontally.
Align > Vertically Alters the molecule so that the selected bond is oriented vertically.
Ligand order Changes the order of the attachment of R-group ligands.
Edit Properties Bond properties can be edited from this menu.

Structure Menu

Clean 2D > Clean in 2D Calculates new 2D coordinates for the molecule.
Clean 2D > Hydrogenize
 Chiral Center

Adds an explicit hydrogen atom to a chiral center having no terminal atoms when 2D
 cleaning is performed.

Clean 2D > Clean Wedge
 Bonds Arranges the wedge bonds of the molecule in 2D.

Calculates new 3D coordinates for the molecule. Clean3D builds up conformers of
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Clean 3D > Clean in 3D  fragments from which the best, i.e. the lowest energy conformer is given back. The
 quality of the structures is measured by a simple energy function (Dreiding type
 molecular mechanics).

Clean 3D > Cleaning
 Method > Fine Build

Fine Clean3D builds up conformers of fragments to find low energy conformer.
 Leaves failed fragments intact.

Clean 3D > Cleaning
 Method > Fine with
 Hydrogenize

The build process always adds explicit hydrogens to the structures which are
 removed if not present in the original molecule. This option prevents the removal of
 extra hydrogen atoms, otherwise gives the same results than Fine build.

Clean 3D > Cleaning
 Method > Fast Build

Fast clean, which if fails, performs fine clean. It accepts any generated structure,
 and it is the default behavior of the Clean3D function.

Clean 3D > Cleaning
 Method > Build or
 Optimize

Builds 3D structure for non-3D molecules and just optimizes the 3D molecules with
 the Dreiding force field.

Clean 3D > Cleaning
 Method > Gradient
 Optimize

Optimizes with the Dreiding force field using the actual structure as starting
 geometry.

Clean 3D > Display Stored
 Conformers

Allows you to choose one of the possible conformer structures which were calculated
 via the Conformers plugin.

Directed Merge > Assign
 Atoms Chooses the atoms of the fragments to be merged.

Directed Merge > Merge Merges the fragments at the atoms set.

Add > Add Explicit
 Hydrogens

Adds explicit H atoms instead of the current implicit ones. Explicit hydrogens are
 displayed with atoms joining its neighbor while implicit hydrogens are displayed by
 atom symbols only.

Add > Data Attaches data like stoichiometry coefficient to the molecule.
Add > Absolute Stereo
 (CHIRAL) Sets chiral flag for the molecule.

Add > Multi-Center Adds a multi-center attachment point representing a group of atoms.
Add > Position Variation
 Bond

Create a variable point of attachment to represent a connection point to a group of
 atoms.

Remove > Explicit
 Hydrogens Removes explicit H atoms and increases the number of implicit hydrogens.

Remove > Data Removes attached data from the molecule.
Remove > Absolute Stereo
 (CHIRAL) Removes the chiral flag of the molecule.

Edit data Changes a previously attached data like stoichiometry coefficient of the molecule.
Edit properties Bond properties can be edited from this menu.
Aromatic Form > Convert
 to Aromatic Form

Transforms the molecule to aromatic representation using the transformation
 method set.

Aromatic Form >
 Conversion Method > Basic Basic aromatization method is described here.

Aromatic Form >
 Conversion Method >
 General

General aromatization method is described here.

Aromatic Form >
 Conversion Method >
 Loose

Loose aromatization method is described here.

Aromatic Form > Convert
 to Kekulé Form Transforms the molecule to non-aromatic representation.

Group > Group Creates a custom S-group, R-group or Repeating Unit with Repetition Ranges.
Group > Frequency
 Variation Creates a Repeating Unit with Repetition Ranges.

Group > Merge Brackets Creates a bracket that crosses two bonds.

Group > Edit Group Modifies the properties of the selected group (restricted to 4 types: generic,
 component, monomer, mer).

Group > Contract Group Contracts all groups to its abbreviations.
Group > Expand Group Displays the full structure instead of the abbreviations.
Group > Ungroup Removes all abbreviated group associations from the molecule.
Reaction > Merge

http://onlinelibrarystatic.wiley.com/marvin/help/sci/aromatization-doc.html#basic
http://onlinelibrarystatic.wiley.com/marvin/help/sci/aromatization-doc.html#daylight_arom
http://onlinelibrarystatic.wiley.com/marvin/help/sci/aromatization-doc.html#loose
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 Reactants Merges the selected fragments to a reactant, product or agent.

Reaction > Unmerge
 Reactants Removes selected fragments from a previously merged reactant, product or agent.

Mapping > Map Atoms Inserts map numbers of the selected atoms.
Mapping > Reaction
 Mapping Method >
 Complete

All atoms in the reaction are mapped.

Mapping > Reaction
 Mapping Method >
 Changing

Only those atoms are mapped that have changing bond. Either the bond order
 changes, or new bond is created, or bond is deleted. Orphan and widow atoms are
 included.

Mapping > Reaction
 Mapping Method >
 Matching

Maps all matching atoms in the reaction (Daylight style mapping). A reaction atom is
 called matching if it is not an orphan/widow atom: it exists on both sides of the
 reaction.

Mapping > Unmap Atoms Removes map numbers of the selected atoms.

Attribute > R-Logic Allows setting additional R-group conditions such as occurrence, rest H and if-then
 expressions to R-groups in the R-logic dialog window.

Structure to Name > Place
 IUPAC Name Inserts IUPAC Name onto the canvas.

Structure to Name >
 Generate Name Generates IUPAC and/or Traditional Name.

Name to Structure Opens the Source window in IUPAC Name format, and enables you to enter directly
 a IUPAC Name and convert it to structure.

Markush Enumeration Generates a whole or a subset of the library of a generic Markush structure.

Check Structure Checks and corrects chemical structures. See Structure Checker in MarvinSketch for
 more details.

Auto Check Toggles auto checking of structures while drawing.

Calculations Menu

Elemental Analysis Calculates the elemental composition of the molecule.
Protonation > pKa Calculates the pKa values of the molecule.
Protonation > Major
 Microspecies Draws molecular microspecies at given pH.

Protonation > Isoelectric
 Point Calculates gross charge distribution of a molecule as function of pH.

Partitioning > logP Calculates the octanol/water partition coefficient.
Partitioning > logD Calculates the octanol/water partition coefficient at any pH.
Charge > Charge Calculates the partial charge value of each atom.
Charge > Polarizability Calculates the polarizability of each atoms.
Charge > Orbital
 Electronegativity Calculates electronegativity of each atoms.

Charge > Dipole Moment
 Calculation Calculates the electric dipole moment of the molecule

NMR > CNMR Prediction Predicts 13C NMR chemical shifts of the molecule.
NMR > HNMR Prediction Predicts 1H NMR chemical shifts of the molecule.
NMR > NMR Spectrum
 Viewer Opens and displays JCAMP-DX NMR spectral file.

Isomers > Tautomers Generates two dimensional tautomers of the molecule.
Isomers > Stereoisomers Generates all possible stereoisomers of the molecule.

Conformation > Conformers Generates selected number of conformers or the lowest energy conformer of a
 molecule.

Conformaton > Molecular
 Dynamics Calculates the configurations of the system by integrating Newton's laws of motion.

Conformation > 3D
 Alignment Overlays drug sized molecules onto each other in the 3D space.

Geometry > Topology
 Analysis Provides characteristic values related to the topological structure of a molecule.

http://onlinelibrarystatic.wiley.com/marvin/help/structurechecker/checker.html
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Geometry > Geometry Provides characteristic values related to the geometrical structure of a molecule. It
 can calculate steric hindrance and Dreiding energy.

Geometry > Polar Surface
 Area (2D) Provides estimation of topoligical polar surface area (TPSA).

Geometry > Molecular
 Surface Area (3D) Calculates van der Waals or solvent accessible molecular surface area.

Predictor Predicts molecular properties based on its structure. The method is based on QSAR
 algorithm using a multiple linear regression model and a least squares fitting.

Other > H Bond
 Donor/Acceptor Calculates atomic hydrogen bond donor and acceptor inclination.

Other > Huckel Analysis Calculates localization energies L(+) and L(-) for electrophilic and nucleophilic attack
 at an aromatic center.

Other > Refractivity Calculates molar refractivity of the molecule.
Other > Resonance Generates all resonance structures of the molecule.
Other > Structural
 Frameworks

Calculates Bemis and Murcko frameworks and other structure based reduced
 representations of the input structures.

Tools Menu

Services
Provides accessibility to previously integrated third-party
 calculations*.

Help Menu

Help Contents Shows MarvinSketch User's Guide.

Licenses Starts ChemAxon License Manager where you can manage the licenses of all
 ChemAxon products.

About MarvinSketch Shows MarvinSketch product information and technical details.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/predictor.html
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Toolbars of MarvinSketch

 The toolbars provide buttons that access some of the frequently used commands in the menus. To activate a
 command, click its toolbar button. If a command is unavailable, its button appears grayed-out.

Note: Place the mouse cursor over a toolbar button to see the tooltip describing its use.

General Toolbar

Rectangle Selection Allows selection in rectangle mode on mouse drag.

Lasso Selection Allows selection in lasso mode on mouse drag.

Structure Selection Allows selection in structure selection mode on mouse drag. With this selection
 mode only whole fragments can be selected.

Erase Removes all structures upon selection.

Undo Reverses the last command or the last entry you typed.

Redo Reverses the action of the last Undo command.

Cut Removes and copies the selection to the clipboard.

Copy Copies the selection to the clipboard.

Paste Inserts the contents of the clipboard at the location of the cursor, without
 replacing selection.

Check Structure Checks and corrects chemical structures. See Structure Checker in MarvinSketch
 for more details.

Zoom In Increases the canvas's magnification.

Zoom Out Decreases the canvas's magnification.

Zoom Tool

Changes the canvas's magnification to a specific value. It can also do autoscale
 using named values: All, Selection. 
 This is supplemented with 'Scaffold' and R-group(s) when there is a defined R-
group on the canvas.

Help Contents Shows MarvinSketch User's Guide.

Tools Toolbar

The tools consist of various command groups. The tools having chemical meaning (like bond or reaction arrow)
 are drawn in black lines, while strictly graphical objects are in blue. You can place for example only ONE reaction
 arrow on the canvas, but as many graphical arrows as you wish and they will look completely identical.

Insert Bond Places various bond types on the canvas.

Insert Chain
Places a carbon chain on the canvas. The number of carbon atoms can be increased
 or decreased by dragging the mouse. Selection of straight or curved chain drawing
 is available.

Bold Tool Thickens the selected bond. See details on bold tool function.

Hashed Bond Tool Makes the selected bond hashed. It only retains single original bond type.

Insert Text Places a Text object on the canvas. Allows changing text properties on the appearing
 toolbar.

Insert Reaction Arrow Places various reaction arrow objects on the canvas.

Create Group Creates a custom abbreviation group.

Insert Brackets Places brackets, parentheses, chevrons or braces on the canvas.

Insert Graphics Places various graphical objects on the canvas.

Increase Charge
Increases the charge of the selected atom. The number of implicit hydrogens will be
 adjusted if possible to accommodate the new charge. Valence errors will be

http://onlinelibrarystatic.wiley.com/marvin/help/structurechecker/checker.html
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 highlighted in red.

Decrease Charge
Decreases the charge of the selected atom. The number of implicit hydrogens will be
 adjusted if possible to accommodate the new charge. Valence errors will be
 highlighted in red.

Atoms Toolbar

Periodic Table Shows Periodic Table and query/atom property drawing window.

Insert Hydrogen Places Hydrogen atom on the canvas.

Insert Carbon Places Carbon atom on the canvas.

Insert Nitrogen Places Nitrogen atom on the canvas.

Insert Oxygen Places Oxygen atom on the canvas.

Insert Sulfur Places Sulfur atom on the canvas.

Insert Fluorine Places Fluorine atom on the canvas.

Insert Phosphorus Places Phosphorus atom on the canvas.

Insert Chlorine Places Chlorine atom on the canvas.

Insert Bromine Places Bromine atom on the canvas.

Insert Iodine Places Iodine atom on the canvas.

Chemical Toolbar

 This toolbar contains chemical functions and it is not visible by default.
 To make it visible, choose View > Toolbars > Chemical. 

Clean 2D Calculates new 2D coordinates for the molecule.

Clean 3D
Calculates new 3D coordinates for the molecule. Clean3D builds up conformers of fragments from
 which the best, i.e. the lowest energy conformer is given back. The quality of the structures is
 measured by a simple energy function (Dreiding type molecular mechanics).

Convert
 to
 Aromatic
 Form

Transforms the molecule to aromatic representation using the transformation method set.

Convert
 to
 Kekulé
 Form

Transforms the molecule to non-aromatic representation.

Markush Toolbar

 This toolbar contains funtions that help to work with Markush structures and it is not visible by default.
 To make it visible, choose View > Toolbars > Markush. 

Position Variation
 Bond

Creates a variable point of attachment to represent a connection point to a group of
 atoms.

Frequency Variation Creates a Repeating Unit with Repetition Ranges.

R-group attachment Adds an attachment to the structure.

Advanced Templates Toolbar

 This toolbar contains special buttons holding structure templates.
 Additional functions of this toolbar:
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1. The toolbar can show different template groups.
General and My Templates:

Crown Ethers and Bridged Polycyclics:

To control which template sets are displayed on the toolbar, use the Properties panel in the Template
 Library (Ctrl+t): 

 Checking the 'Use molecules as templates at 2D cleaning' checkbox will effect the structures
 containing that template during cleaning of the structure: the default cleaning form is overwritten by
 the template structure. This way, you can cutomize your drawings: add or draw a set of templates
 and check this option.

2. Any structure can be added to the My Templates group.
Using Drag & Drop to the toolbar

Using the Pop-up menu
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3. Set the name of the new template.
Right-click on the template icon on the template toolbar and select Properties.
Set the name and/or the abbreviation of the template in the Template Properties box.
After that the template is identified with its name and/or abbreviation.

4. Templates without a name
If the template does not have a name, hovering the cursor over its icon on the template toolbar
 magnifies the image on the icon. This improves the visibility of the template icon, especially for big
 structures.

5. The template can be removed from the toolbar.
Right-click on the template icon and select Remove to remove the template from the toolbar and
 from the My Templates list.

Simple Templates Toolbar

 If you only wish to use the 6 generic template structures without additional functions, you can use the Simple
 Templates Toolbar. This toolbar is not visible by default. To make it visible, choose View > Toolbars > Simple
 Templates. 

Cyclopentane (house)

Pyrrole

Cyclopentane

Cyclohexane
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Benzene

Naphthalene

3D editing Toolbar

Maps atoms to merge.

Merges assigned atoms.

Alters the coordinates of the molecule in order to put the 3 selected atoms of the molecule onto the plane of
 the canvas.

Adds new fragment to the canvas.
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Pop-up Menus of MarvinSketch

There are four pop-up menus (also called context or right-click menus) available in MarvinSketch:

Atom Pop-up Menu
Bond Pop-up Menu
Object Pop-up Menu
Edit Pop-up Menu

These popup menus do not require the corresponding atom, bond or object to be selected, however there are
 some additional menu elements that appear only when they are selected.

Please note that when a pop-up menu appears, it is usually the combination of these menus. For example when
 selecting an atom and pressing the right mouse button, a popup menu appears that contains elements of the
 context pop-up menu,in this case the Atom Pop-up Menu, the Edit Pop-up Menu, and the Selection Pop-up Menu.

Atom Pop-up Menu

The Atom pop-up menu appears when you right-click on an atom on the canvas. It contains options for atom-
specific activities that also can be accessed from the Atom Menu.

Menu Item Description

Stereo
Assigns reaction stereo labels or enhanced stereo labels to atoms. See the Enhanced
 stereo specification for details.
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Charge

Applies a charge between [-128,128] to the atom. Marvin will let you set any of these
 values on any atom, highlighting the Valence Errors in red upon completion. In other
 words, Marvin will allow you to set a charge of -5 on hydrogen, despite the fact that
 this is chemically impossible.

Valence Allows you to change the valence of any atom between [0, 8].

Radical
Sets the selected atom as a radical. You can select the type of radical - monovalent,
 divalent, divalent singlet, divalent triplet, trivalent, trivalent doublet, trivalent quartet.
 The Off option removes the radical designation.

Isotope
The Isotope submenu contains a list of the isotopes of the selected element,
 dynamically generated based on the selected atom. Select an isotope to set or change
 the isotope number or choose Off to reset the default atom type (no isotope).

Map
Set map labels/identifiers on the selected atoms that do not change while altering the
 molecule. They are useful when dealing with reactions, and can be saved in SMILES
 and MDL formats.

R-group
Changes the selected atom to an R-group label. R-groups symbolize alternative
 substituents.

R-group attachment Adds R-group attachment point to the selected atom.

R-group attachment
 order

Defines the order of the R-group or deletes R-group attachment point.

Link Node Link node specifies rings or chains of variable size.

Add S-group
 attachment

Creates an attachment point on the selected atom of an S-group.

Remove S-group
 attachment

Removes the last attachment point from the selected atom of an S-group.

Bond Pop-up Menu

The bond pop-up menu appears when you right-click on a bond within the molecule. It allows you to make a
 number of changes to the selected bond. It contains options for bond-specific activities that also can be accessed
 from the Bond Menu.

Menu
 Item

Submenu
 Items

Description

Type

Single Changes the selected bond type to Single.

Double Changes the selected bond type to Double.

Triple Changes the selected bond type to Triple.

Aromatic Changes the selected bond type to Aromatic.

Query bond
 types

Changes the selected bond to a bond type (Single Up, Single Down, Single Up or
 Down, Double Cis or Trans, Double C/T or Unspec, Single or Double, Single or
 Aromatic, Double or Aromatic, Any) for use in a query.

Coordinate Changes the selected bond type to Coordinate.

Bold Thickens the selected bond.

Hashed Changes the selected bond hashed.
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Topology

 
The following options can be set as bond property when the molecule is used as a
 query.

None Removes defined bond topologies.

In Ring The specified bond must be in a ring to score a hit.

In Chain The specified bond must be in a chain to score a hit.

Reacting
 Center

 
The following bond property options can be set in case of drawing reaction search
 queries. See Reacting center bond for further query feature descriptions.

None Removes added bond property.

Center Specifies that the bond takes part in the reaction.

Make or
 Break

The assigned bond can form or disappear in the reaction.

Change The assigned bond remains and can alter during the reaction.

Make and
 Change

The assigned bond can form, break,or change its type during the reaction.

Not Center The assigned bond can not be the reaction center.

Stereo Search
Uses stereoconfiguration of specified double bond when the molecule is used as a
 query.

Arrange

Bring to
 Front

Brings the selected bond in front of the others.

Send to
 Back

Sends the selected bond to the back of the others.

Align
Horizontally Orients the selected bond horizontally.

Vertically Orients the bond vertically.

Object Pop-up Menu

 This menu appears when the context is a graphical object like Text, Bracket, or other Graphics.

Menu Item Description

Bring to Front Brings the selected object in front of all others.

Send to Back Places the selected object behind all others.

Edit Pop-up Menu

The Edit pop-up menu appears when you right-click on open canvas space. In case there is an atom, bond or
 graphic object under the cursor, the appearing pop-up menu contains the elements of the Edit Pop-up Menu
 merged with the pop-up menu of the selected element.
 Edit pop-up menu items include:

Menu Item Description

Cut Removes and copies the selection to the clipboard.

Copy Copies the selection to the clipboard.

http://www.chemaxon.com/jchem/doc/user/query_reactionsearch.html#reactingcenter
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Copy As Copies the selection to the clipboard in the specified format.

Paste
Inserts the contents of the clipboard at the location of the cursor, without replacing
 selection.

Select All Selects the structure being on the canvas including all fragments and graphical objects.

Group
Creates an abbreviated Group from the selected substructure. See the S-groups section
 for more information on creating and using Groups.

Pop-up elements upon Selection

Menu Item Description

Add/Remove Explicit
 Hydrogens

Switches explicit H atoms to implicit ones and vica versa. Explicit hydrogens are
 displayed with atoms joining its neighbor while implicit hydrogens are displayed by atom
 symbols only.

Add/Remove Map
 Atoms

Adding atom maps is an automatic assignment of map numbers to all selected atoms of
 a reaction by using the automapper tool.

Add/Remove Data Attach/Remove data like stoichiometry coefficient to the molecule.

Add/Remove
 Absolute Stereo
 (CHIRAL)

Sets/Removes chiral flag for the molecule.

Add Multi-Center Add a multi-center attachment point representing a group of atoms.

Add Position
 Variation Bond

Create a variable point of attachment to represent a connection point to a group of
 atoms.

Link Node Specifies query structures containing rings or chains of variable size.

R-Logic Allows setting additional R-group conditions such as occurrence, rest H and if-then
 expressions to R-groups in the R-logic dialog.

Transformation >
 Drag Selection

The selected part of the molecule can be moved by dragging the mark box with your
 mouse or with the proper arrow keys.

Transformation >
 Rotate in 2D

The selection can be rotated in the plane of the canvas with changing coordinates.

Transformation >
 Rotate in 3D

The selected part of the molecule will be rotated according to the chosen rotation mode.

Transformation >
 Switch
 Transformation
 (space)

You can switch between dragging or 3D rotating the selected molecular parts by hitting
 the space bar.

Transformation >
 Flip

Flips the structure on the canvas. The submenu allows you to choose horizontally or
 vertically.

Transformation >
 Mirror

Flips the object horizontally, inverting tetrahedral stereochemistry. The submenu allows
 you to choose horizontally or vertically.

Transformation >
 Invert

Reflects the selected fragment(s) through the geometric or arbitrary center.

Document Style Change atom and bond drawing properties.

Add To My
 Templates

Adds the selected structure to the "My Templates" group that appears in the Template
 Library and on the Advanced Templates Toolbar.
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Status Bar of MarvinSketch

 The Status Bar appears at the bottom of the main frame, and unlike toolbars, it cannot be customized or moved.
 

 The Status Bar consists of 3 parts:

1. Dimension Button
 Switches between 2D and 3D modes. If the current structure is represented in 3D, then switching to 2D
 mode performs a 2D cleaning upon confirmation.

2. File Status Indicator
 This sign appears dynamically if there are unsaved modifications on the current structure, and disappears
 upon a Save command.

3. Structure Checker Status
 By default it is disabled as seen on the first image. To enable manual checking double-click on it. Right-
click enables automatic checking. The status bar displays different images when there is no problem, if
 checking is in progress or if problems were found.

4. Navigation Buttons
 The Navigation Buttons appearing on the Status Bar dynamically using multipage molecular documents
 provide a quick way to navigate between pages.
 For information about how to enable multipage molecular documents please visit this link.
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Dialogs of MarvinSketch

Contents

Customize
Preferences
Edit Source
Format
Periodic Table
Template Library Manager
Create Group
Attach data
Document Settings

Customize

 The Customize dialog window, located in the View > Editor style menu, provides options for altering the user
 interface by adding, removing, or reorganizing its elements. For a detailed description, please consult this page.

Preferences

The Preferences dialog window is located at the Edit menu. It allows you to change many of the MarvinSketch
 display settings, including look & feel, error highlighting, and object visibility.
 All settings are saved and used when the application is restarted.

Display
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Atom & Bond labels are used as the default font type and size to labels such as C/T label of bonds, atom
 query property labels of atoms, etc.
Double bond spacing is a gap between two lines/sticks representing a double or triple bond measured in
 Angstroms.
Wireframe bond thickness is the width of bonds in wireframe mode. It is measured in Angstroms.
Stick diameter is the width of bonds in stick mode in Angstroms.
Ball radius is the size of atom spheres in Ball draw type, measured in Angstroms.
Look & Feel allows changing the visual appearance of GUI components. The available options are: Java
 Metal, Motif, JGoodies Plastic, JGoodies Plastic XP, and the native Look & Feels (Windows, Aqua) based on
 the underlying operating system.
MarvinView Layout sets the default layout to Automatic, Molecule matrix or Spreadsheet.
Show Bond in Hand when checked, bond types are shown under the mouse cursor like template
 structures.
Show Lone Pair as Line when checked, lone pairs on the canvas are shown as lines.
Show Charge in Circle when checked, a circle is displayed around the charge.
Circled Charge labels are used as the font type and size of the circled charge symbols.
Fog effect factor: manual setting of the fading strength. No fog: all regions of the structure is displayed
 with the same line strength and color. Strong effect: the fading is at its maximum (molecule is only slightly
 visible at the far end).

Bonds
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Down Wedge Orientation allows changing the wedge bond display convention. Down wedge points
 downward in MDL's convention, upward (at the chiral center) in Daylight's.
Any Bond Line Style offers three different modes to display bonds of unknown types: Automatic, Dashed
 and Solid. This option can be separately set to be used in MarvinSketch and MarvinView.
Terminal Bond Deletion Method offers 2 ways to delete the terminal bond of a molecule: only the bond
 is deleted or the terminal atom disappears with the bond.
"Coordinate" Bond Line Style allows changing the type of coordinate bonds from the default ones (arrow
 for single atom and hashed for multicenter) to solid.

Structure

Highlighting Valence Errors highlights atoms having wrong valences with red underline when it is
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 checked.
Automatic Lone Pair Calculation calculates lone pairs automatically. Make sure View > Misc > Lone
 Pairs is checked to see the result.
Validate S-groups At Creation disables the S-group types in the drop-down list which would not yield a
 chemically correct structure. Usage in MarvinSketch.
Carbon Labels options determine the condition of displaying C labels on Carbon atoms.

Always Never At straight angles
 and implicit H atoms

Ligand Orders
Always
Never
On R-groups with definitions

Checkers

Move up/down the checker items: the fixing process may depend on the sequence of the checkers.
 Checking order can be set using the Up/Down buttons on selected checkers.
Add checkers to the list: the default list can be modified by adding other checkers.
Remove checkers from the list: the default list can be modified by removing checkers not needed.
Open checker configuration from URL open a checker configuration from URL.
Open checker configuration: open your custom checker configuration from file.
Save checker configuration: save your custom checker configuration to file.
Configure external checkers/fixers: add external checkers/fixers; save or load external checker/fixer
 configuration.

Services



Dialogs of MarvinSketch

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/dialogs.html[11/4/2015 9:57:07 PM]

The Services module provides seamless integration of third-party calculations into Marvin Sketch. You can add
 and configure the desired calculations in the Services tab. The set service(s) can be used from the Tools >
 Services menu afterwards.

Set the order of services by moving them up and down using the Up/Down buttons.
Add a new service to the list by the add button. The preference window of the new service will pop up.
 Read more about setting different services.
Remove the selected service from the list by the remove button.
Open Service Configuration from URL. Specify a previously set configuration of services with its URL.
Import Service Configuration from file. Import a previously set configuration XML file.

Export Service Configuration to file. You can export the set services to a configuration XML file.

Save/Load

http://onlinelibrarystatic.wiley.com/marvin/help/developer/services.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/setting_services.html
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Default location: the folder from which to load or to save molecules may be set by the user.
Startup directory: the folder where the command to start the application was given.
Last location: the last folder used for opening or saving a structure.
Custom working directory: a user-defined folder. If a molecule is loaded from another folder, then the
 file's location will be offered for saving.

Default file format determines which type is offered by default when structures are saved to file.
Save/Load settings

Save/Load GUI settings (.MRV, .PDF format) allows storing and loading of display options like
 background color, font type, stereo labels, atom indices etc. in addition to the chemical structure
 itself. This option can only be used with MRV and PDF formats.
Save/Load zoom factor (.MRV format) stores and loads the zooming scale of the structures. This
 option can only be used with the MRV format.
Zoom to scaffold on load (Sketch only) sets the zooming scale to 'Scaffold' if the loaded file
 contains defined R-groups, so the R-group definitions might not be seen on the canvas without
 scrolling. The 'Zoom level' dropdown list on the General Toolbar is supplemented with 'Scaffold' and
 'R1, R2, R3...' only when there are defined R-group(s). Without R-group definitions the zooming
 scale for the loaded structure(s) will not be modified, the last zooming scale will be used.
 When this option is switched off in the 'Preferences' menu then MSketch opens the new file with the
 last zoom level.

Recent file entries defines the number of files in the Recent files list in the File menu, with values
 between 1 and 10.
Image import service URL URL of a server on which a chemical structure recognition program runs can
 be given.
Name import service URL URL of a server on which a chemical name recognition program runs can be
 given.

OLEServer

http://onlinelibrarystatic.wiley.com/marvin/help/formats/mrv-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/pdf-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mrv-doc.html
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Edit Source

You can alter a molecule by directly editing its source in the Edit Source dialog window.
 The dialog window provides standard clipboard operations and it is also possible to send the source text to the
 console.
 You can view and edit the source in any of the supported file formats. You can also convert it to Java String
 which allows easy integration of the structure to a custom Java application code.
 To change the format of the source, simply select one from the View Menu. If there are more than one molecule
 on the canvas, setting View as multiple molecules in the View Menu causes each molecule to appear in a
 separate block in the source. This feature works only in those cases where the selected format is able to handle
 multiple fragments.
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After editing the source text, you can send the structure back to the MarvinSketch canvas by invoking File >
 Import As, and pressing Import on the appearing dialog window. This will close the Edit Source dialog window.

Format

Atoms and Bonds

 On this panel there are many options to change the drawing properties of atoms and bonds.
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For more information about using structure drawing styles, please visit this link.

Graphics Objects

 The drawing properties of graphics objects (text boxes, brackets, lines, etc.) can be changed on this panel.
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Periodic Table of Chemical Elements

Periodic Table

Chemical elements are available as buttons on the Periodic Table panel of MarvinSketch.
 Atom buttons are arranged according to the standard periodic table layout.
 When the mouse cursor is over a specific atom button, the information panel displays the name of the atom, the
 atomic number, mass, electronegativity and the oxidation states.
 When one of the atom buttons is pressed, the corresponding atom can be placed on the canvas. The atom
 symbol appears under the mouse cursor, while the button is highlighted in this case.

 The Atom List and NOT List buttons can be used to create special atom lists that can be used in queries. When
 one of these buttons is pressed, atoms can be added to the list by pressing atom buttons one after the other.
 The lists are not cleared when the list buttons become unselected. The atoms of the list are also shown under
 the mouse cursor above the canvas. See Query Guide for more details about atom lists and not lists.

Four different coloring schemas can be chosen:

1. CPK: colors the atoms according to the Corey-Pauling-Kultun coloring scheme
2. Standard state: colors according to the standard state of the element (gas, liquid, solid)
3. Blocks: colors elements according to the highest-energy electron's orbital (s-, p-, d- or f-block)
4. Metals/Nonmetals: colors according to the metallic character of the elements (alkali, alkaline earth,

 metalloid, transition metal, other metal, nonmetal)

Advanced

http://www.chemaxon.com/jchem/doc/user/query_features.html#atlist
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 For the meanings of the buttons on the Advanced tab please refer to the Query Guide.
 When the mouse cursor is over a button, a short description appears on the information panel.

Generic query atoms

Name Description

A Any (any atom except hydrogen)

AH Any atom, including hydrogen

Q Hetero (any atom except hydrogen and carbon)

QH Hetero atom or hydrogen (any atom except carbon)

M Metal (contains alkali metals, alkaline earth metals, transition metals, actinides,
 lanthanides, poor(basic) metals, Ge, Sb and Po)

MH Metal or hydrogen

X Halogen (F,Cl,Br or I)

XH Halogen or hydrogen

Atom query properties

Adding query properties to structures.

Name Description

.H+ Increase number of total hydrogens (total number of hydrogen substituents)

.H- Decrease number of total hydrogens (total number of hydrogen substituents)

http://www.chemaxon.com/jchem/doc/user/query_features.html
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.v+ Increase number of valence (total bond order)

.v- Decrease number of valence (total bond order)

.X+ Increase number of connections (number of substituents including hydrogens)

.X- Decrease number of connections (number of substituents including hydrogens)

.R- Increase number ofrings (number of rings the atom is a member of)

.R+ Decrease number of rings (number of rings the atom is a member of)

.r+ Increase smallest ring size (size of the smallest ring the atom is a member of)

.r- Decreasesmallest ring size (size of the smallest ring the atom is a member of)

.rb+ Increase ring bond count (number of ring bonds next to the atom)

.rb- Decrease ring bond count (number of ring bonds next to the atom)

.s+ Increase substitution count (number of non-H substituents)

.s- Decrease substitution count (number of non-H substituents)

.h+ Increase number of implicit hydrogens (number of implicit hydrogen substituents)

.h- Decrease number of implicit hydrogens (number of implicit hydrogen substituents)

.D+ Increase degree (number of explicit connections; default for "n" is one)

.D- Decrease degree (number of explicit connections; default for "n" is one)

.u Mark as unsaturated atom (atom has double, triple or aromatic bond)

.a/A Mark as aromatic/aliphatic (has aromatic bond)

Periodic Table Groups

Name Description

Group 1 (IA,IA) the alkali metals or hydrogen family/lithium family

Group 2 (IIA,IIA) the alkaline earth metals or beryllium family

Group 3 (IIIA,IIIB) the scandium family

Group 4 (IVA,IVB) the titanium family

Group 5 (VA,VB) the vanadium family

Group 6 (VIA,VIB) the chromium family

Group 7 (VIIA,VIIB) the manganese family

Group 8 (VIII) the iron family

Group 9 (VIII) the cobalt family

Group 10 (VIII) the nickel family

Group 11 (IB,IB) the coinage metals or copper family

Group 12 (IIB,IIB) the zinc family

Group 13 (IIIB,IIIA) the boron family

Group 14 (IVB,IVA) the carbon family

Group 15 (VB,VA) the pnictogens or nitrogen family

Group 16 (VIB,VIA) the chalcogens or oxygen family

Group 17 (VIIB,VIIA) the halogens or fluorine family

Group 18 (Group 0) the noble gases or helium family/neon family

Special nodes
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Name Description

Pol Pseudo atom 'Pol'. This button changes the selected atom to a pseudo atom labelled
 Pol (polymer).

* This button creates a '*' atom, which indicates an unspecified end group in
 polymers.

homology
 groups The drop-down list contains the default homology groups. Detailed list.

R-groups

 These atoms can be used to describe unknown or unspecified molecule parts or to draw R-group queries or
 Markush structures.

Custom Property

Name Description

R-group
Converts the atom to an R-group with the given number (only numerical characters are
 allowed). Maximum index is 32767. This atom can be used to describe an unknown or
 unspecified molecule part or to draw an R-group query or Markush structure.

Alias The given value is shown as atom label but the atom itself does not change.

Pseudo The given value is shown as atom label and the type of the atom is changed to 'Any'.

SMARTS Converts the given value to a complex SMARTS query molecule or atom. If the cursor is
 kept over the canvas during typing, the conversion can be seen on-the-fly.

Value Adds the given value to an atom as a custom property ("Atom value").

Template Library Manager

The Template Library is a hierarchic display of template sets.

It contains several template sets by default (such as Generic, Rings, Amino Acids, etc), and a special set called
 My Templates.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html
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 The dialog has buttons to customize template handling. With the help of these buttons you can add and remove
 template sets to/from the template library, can change order of a given template set, or open the "Options"
 dialog. The cleaning options of the templates can be set using the last three buttons on the toolbar. With these
 buttons you can specify how the template will be placed onto the canvas (NoClean, 2D, or 3D). These options
 can be set separately for each template category. Note, that the buttons are synchronized with the "Template
 Options" dialog settings.

Template Options

Maximum number of molecules: template sets can contain large number of molecules. This option
 maximizes the number of structures being loaded from a template set when it is selected in the Template
 Library. For example if the option is set to 100, only 100 structures will be loaded to memory and
 displayed in the library, even if the underlying molecule file contained 25000 structures.
Coordinates: this option is to specify an operation affecting the coordinates when the templates are placed
 on the canvas.
 For example result of placing L-Alanine to the canvas with different options:
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As in the original
structures

Always perform
Clean2D

Always perform
Clean3D

Size of templates: the size with which each template is displayed in the library, measured in pixels.
Maximum number of buttons: this determines the maximum number of buttons allowed on the
 Advanced Templates Toolbar

Adding a new template set to the library

 It is possible to add new template sets to the library using the Add Template Set button on the tool bar.
 Using the Browse button you can select a directory or a file of the file system. Specifying a directory will create a
 hierarchic template set containing all subdirectories and files. 

It is also possible to specify a location with ftp protocol. The underlying subdirectories and files will be displayed
 as with the local file system.

Please note that protocols other than file and ftp are not supported. However remote file systems can help to
 overcome this restriction.

Removing a template set from the library

 You can remove template sets from the library using the Remove Template Set button on the tool bar.
 The template set will only be removed from the library, without modifying files on the file system. 

Create Group

 This dialog makes it possible to create a number of groups along with setting their properties. Group drawing in
 MarvinSketch.



Dialogs of MarvinSketch

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/dialogs.html[11/4/2015 9:57:07 PM]

 The available groups and their detailed description are available by clicking on the links below:

Anypolymer (anyp)
Component (c)
Copolymers
Crosslink (xl)
Generic ()
Graft
Mer (mer)
Modification (mod)
Monomer (mon)
Multiple group
Ordered mixture (f)
Repeating units with repetition ranges
R-group
SRU polymer(n)
Superatom (abbreviation)
Unordered mixture (mix)

 Displaying charges on groups is described here.

Attach data

Attached data is a custom field assigned to atoms or brackets. It has an identifier string (name) and a value.
 Furthermore, a query operator can describe different restrictions in queries.
 The dialog provides interface to set the properties of such a field.
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Further details of attached data can be found in the Query guide.

Attaching data in MarvinSketch is described here.

The Attach Data dialog is customizable; configuration options and a small example can be found here.

Edit properties

Properties may be added and viewed in MarvinSketch. Various properties can be added, but the value is displayed
 only on the canvas. Detailed description

Document Settings

 You can set the number of horizontal and vertical pages in the Document Grid part, and you can also define the
 title, the page size and the margins in the corresponding sections of this dialog window. Henceforward, the given
 title will specify the "molecule title" property.

http://www.chemaxon.com/jchem/doc/user/query_features.html#attached_data
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Shortcuts of MarvinSketch

The table below contains a list of the available shortcuts in MarvinSketch.

The way of changing the default shortcuts is described in the Customization section.

Keyboard shortcut Function

Mouse Wheel Scrolls canvas vertically.

Shift+Mouse Wheel Scrolls canvas horizontally.

Ctrl+Mouse Wheel Zooms canvas in and out.

Arrow Keys,
 Ctrl+Arrow Keys

Scrolls canvas in the proper direction if no object is selected on the canvas.

Arrow Keys
Moves the seleted object if an item is selected on the canvas. (You can scroll the
 canvas with Ctrl+Arrow Keys in this case.)

Shift+Arrow Keys Move the selected object on the canvas in greater units.

Delete Removes the selected element.

Ctrl+A Select All

Ctrl+C, Ctrl+Insert Copy

Ctrl+K Copy As

Ctrl+L Copy As Smiles

Ctrl+X,
 Ctrl+Shift+Delete

Cut

Ctrl+V,
 Ctrl+Shift+Insert

Paste

Ctrl+Y Redo

Ctrl+Z,
 Alt+Backspace

Undo

Ctrl+L Copy as SMILES

Ctrl+O File open (if available)

Ctrl+S Save to file (if available)

Ctrl+Shift+S Save as... (if available)

Ctrl+P Print (if available)

Ctrl+M Display Periodic Table dialog (More window)

Ctrl+N Create a new window

Ctrl+Delete Clear Desk

Ctrl+W Close current window

Ctrl+Q Exit from the application

Ctrl+G Create Group

Ctrl+2 Clean in 2D

Ctrl+B Clean Wedge Bonds

Ctrl+3 Clean in 3D

Ctrl+F Select conformer

Ctrl+T Opens the Template Library

Ctrl+R Checks and corrects chemical structures.

Ctrl+Shift+N
You can view the name of the current structure, and enter a new name to be
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 imported.

Ctrl+Shift+M Open MarvinSpace

F5 Exit transformation mode and return to Sketching mode.

F6 Switch on the Zoom mode.

F7 Enter into the Rotate in 3D mode.

F11 Sets the visibility of the main menubar.

Space
Changes transformation mode from Drag to Rotate in 2D, Rotate in 2D to Rotate in
 3D, while Rotate in 3D to Drag.

- Negative charge

+ Positive charge

1 Single bond

2 Double bond

3 Triple bond

4 Aromatic bond

5 Single up bond

6 Single down bond

7 Single up or down bond

12 Single or double bond

14 Single or aromatic bond

24 Double or aromatic bond

0 Any bond

* Any atom

Q Hetero atom

C, N, H, ...
carbon, nitrogen or hydrogen atom. For the other elements, type the mark of the
 element, e.g.: Cl for Chlorine. (Also works in lower case: n, cl etc.)

Au,Ag,Pt,...
Atom List can be defined by typing chemical symbols separated by commas. (Also
 works in lower case: au,ag,pt,...)

!Au,Ag,Pt,...
Not List can be defined by starting the atom list with an exclamation mark. (Also
 works in lower case: !au,ag,pt,...)

R1, R2, ..., R32767

R-group label with specified number. To define a set of fragments as R-group, select
 the fragments before the shortcut. To create an attachment point in the R-group,
 select an atom in the R-group and type the name of the R-group (e.g.: R5) (Also
 works in lower case.)
 To define a set of fragments as R-group 5, select the fragments then type R5. After
 then, you can choose an attachment point on R-group 4, just type R5 and click on
 the atom.

M1, M2, ... Atom maps for reactions. (Also in lower case.)

M0 Unmap

M= or M+
Unique atom map labels. Assigns unique atom map numbers to individual atoms
 picked by the mouse or to selected atoms in selection mode.

11, 22, ..., 77
Select a template. Select first, second, ..., or 7th element from the actual template
 list from the toolbar (if the referred index is not out of range).

abs, or1, or2, and1,
 and2

Stereochemical groups: abs (ABSOLUTE),\ or1,or2,...,or10,... (OR n),
 and1,and2,...,and10,...,&1,&2,..., &10,... (AND n)

AcAc, Acm, Ade, ...

The abbreviated group denoted by the abbreviation. You can ungroup the
 abbreviated group if you press the SHIFT button when you place it to the canvas.
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 (Also in lower case.) To complete a longer name, press ENTER or END after typing
 the first few characters.

.a,.A,.u,.H0,H1

Special atom properties: .a (aromatic), .A (aliphatic), .u (unsaturated), .H0, .H1, ...
 (number of hydrogens), .h0, .h1, ... (implicit hydrogens), .X0, .X1, ...
 (connectivity), .D0, .D1, ... (degree), .R0, .R1, ... (rings), .r3, .r4, ... (smallest
 ring size), .s*, .s0, .s1, ... (substitution count), .v0, .v1, ... (valence), .rb*, .rb0,
 .rb1, ... (ring bond count).
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Customizing MarvinSketch GUI

 You can personalize the user interface to better suit your needs or style.
 For example, you can reorganize the menu bar, you can create, delete or modify toolbars, and many more.
 Any changes you make will become your personal default environment, though you can restore the default
 settings any time.

Basic Changes

Moving Toolbars

 To move a toolbar, drag it by its separator bar, which is located at the left edge of horizontal toolbars or at the
 top of vertical toolbars.
 (Note, that depending on the Look&Feel you currently use, the separator bar might be harder to notice and
 drag.)
 While dragging the toolbar, you can see a colored border around it, indicating the place and direction the toolbar
 will have if you finish dragging. Depending on the current Look&Feel the colors of the border are different. For
 example, using JGoodies SkyBluer Look&Feel theme, light-blue border means that the toolbar will float, while
 dark-blue shows that the toolbar will be docked. If you set a toolbar to be floating, you can dock it back by
 closing it.

Hide/Show Toolbars

 You can change the visibility of toolbars in the View > Toolbars menu.

Hide/Show Menu Bar

 To hide the Menubar, choose View > Menubar. To show it, press F11 after clicking on the canvas.

Hide/Show Status Bar

View > Status Bar turns the Status Bar on or off.

Advanced Changes

 The graphical user interface of MarvinSketch can interactively be personalized using the View > Editor Style >
 Customize... dialog.
 Note that the customization related functions usually do not ask for confirmation before taking action to make
 the procedure faster. The original interface can be restored any time by choosing View > Editor Style > Reset
 current configuration.

Menus
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 By choosing a menu from the Menus list, the contents of the selected menu will be listed in the Menu Contents.
 With selecting a menu entry, its detailed help text will appear in the Details field. If a black triangle is visible on
 the right side of a menu entry, it means that this entry is a Submenu. To list the contents of the submenu, select
 it from the Menus list.

List of the available Menu commands

New Creates a new menu and places it at the end of the Menu Bar.
Menu > Move Allows altering the position of main menus.
Menu > Rename Renaming a menu in an appearing dialog.
Menu > Delete Removes a menu with all of its contents.

List of the available Menu Contents commands
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Add
Makes the above Add Commands dialog visible, where you can browse all available
 commands of MarvinSketch. The commands are organized to Categories, and are listed in
 alphabetical order.

Move Up/Down Moves a menu element by one position in the container menu.
Modify > Add
 Submenu Adds a new submenu after the currently selected element.

Modify > Begin a
 Group Adds a menu separator after the currently selected element.

Modify > Rename Renames a sumbenu or menu element. You can also change the mnemonics by replacing
 the & sign in the name.

Modify > Delete Removes the menu element or submenu.

Popups

 The customization of Pop-up menus are similar to normal menus. However it is not possible to remove, rename
 or create a new Pop-up menu, you can only change the contents of the available Pop-up menus. The reason for
 this is that these menus are context-sensitive, and their name and existence are bound to the underlying
 contexts.

Toolbars
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 Note, that the Advanced Templates Toolbar is not possible to be customized.

List of the available Toolbar commands

Use Large Icons When checked, all toolbar buttons have 24x24 pixel sized icons, otherwise the 16x16 pixel
 versions. By default the large icons are used.

New Creates a new toolbar and places it north to the first row having some space on the right-
hand side.

Toolbar > Rename Renaming a toolbar in an appearing dialog.
Toolbar > Delete Removes a toolbar with all of its contents.

Toolbar > Icons Only The buttons contained by this toolbar will be shown by icon only. Those commands that
 does not have a corresponding icon defined will be shown by text in this case too.

Toolbar > Text Only The buttons contained by this toolbar will be shown by text only.
Toolbar > Icons &
 Text

Icon and text will also be shown for the buttons contained by this toolbar. The text is
 appearing below the icon.

List of the available Toolbar Contents commands

Add
Makes the Add Commands dialog visible, where you can browse all available commands
 of MarvinSketch. The commands are organized to Categories, and are listed in
 alphabetical order.

Move Up/Down Moves a toolbar element by one position in the container toolbar.

Modify > Rename Renames an element. You can also change the mnemonics by replacing the & sign in the
 name.

Modify > Delete Removes the element or separator.
Modify > Begin a
 Group Adds a toolbar separator after the currently selected element.

Keymap
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 It is possible to define and switch between Keymap Shemes, where all Sheme is a different shortcut-set.
 On the Keymap tab, you can browse all available commands of MarvinSketch to define shortcuts to any of the
 commands you would like to.

 Only one scheme can be active at a time. A scheme can be made active by selecting and pressing the Activate
 button. If a scheme is based on another it means that all of the shortcuts are inherited from the base scheme,
 though they can be overwritten one-by-one. Duplicating a scheme will create and activate a new scheme which
 will be based upon the previously selected one. Shemes - except the default one - can also be Removed.

Adding shortcuts

 A shortcut can be added by focusing the Shortcut field, and pressing the desired shortcut combination, for
 example F1. If the shortcut already exists, a warning message appears, and shows which command has the
 activated shortcut.

 The Tab button is required if you would like to use the Tab key for a shortcut, because if you press Tab in the
 Shortcut field, it will loose the focus instead of defining the shortcut.
 The Clear button helps you to remove the shortcut from the field, because pressing the Backspace button
 defines a new shortcut instead of removing it.

 This document described the interactive way of customizing the user interface using the user interface itself.
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 Another way of personalization is shown in the Configurations document.

 The same method can be used on server side as well.

Special commands

There are a few elements which are not part of the default configuration of MarvinSketch but you can add it via
 the customization dialog. These are:

Lone Pair Group 
 The toolbar and the menu can be customized to contain the "Lone Pair Group" tool. You have to disable
 "Automatic Lone Pair" calculation (Preferences dialog, Structure tab) to be able to set the lone pairs
 manually. Then choose View > Customize..., Menu or Toolbars tab. The Lone Pair Group can be added in
 the menu contents section. Choose Tools from the Toolbars list, then click Add at the Toolbar contents
 section. Choose Lone Pair Group from the Insert Lone Pair category, click Add then click Close. The Lone
 Pair Group tool is now visible on the toolbar on the left of the canvas.
Radical Group 
 You can add the "Radical Group" toolbar to your MarvinSketch configuration. This group contains a "Radical
 switch" button, a "Monovalent radical" button and a "Radical off" button.
Free Radical Group 

 You can add the "Free Radical Group" to your MarvinSketch configuration. This group contains a  "0

 radical",  "1 radical",  "2 radicals",  "3 radicals",  "4 radicals" and "Increase Radical" buttons.
 The last one increases the number of radical electrons on the atom by one. In case the number of radicals
 on the atom is 4, it will be set to zero instead of increasing.
Manual Atom Map 

 "Manual Atom Map" can be added from "Structure" category. Selecting the "Manual Atom Map" tool,
 hold down the left mouse button on an atom of the first molecule, then drag it to the corresponding atom
 of the second molecule. The same map number will be added to both atoms.
Manual Atom Map-Unmap Group 
A group containing actions: "Manual Atom Map" and "Unmap Atoms".
Reaxys Generics 

 "Reaxys generics" can be added from the "Insert Template" category. This template library contains
 the generic abbreviation commonly used in the Reaxys database.
Substitution Count 
 Extension of the menu with the "Substitution Count": create a new entry recommendably in the "Atom"
 menu. Select the new submenu in the Menus dropdown list. Select the new entry and click Add.. Choose
 the commands from Atom Properties category (Substitution Count off, Substitution Count as Drawn, 0
 substituent, 1 substituent, etc.), click Add, then click Close.
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Configurations of MarvinSketch

 The whole collection of Menubar, Toolbar, Pop-up menu and Shortcut definitions is called Configuration.

 In the Customization section we describe the way of personalizing the Graphical User Interface (GUI) of
 MarvinSketch. This includes adding, removing and modifying elements of the interface.

 At the first launch of MarvinSketch a dialog asks the user to select the desired skin for the GUI configuration: 

 The default configuration is called Marvin Configuration, and it has the (active) suffix. This selection can be
 changed any time from the View menu.

 These configurations can be modified, exported and imported, or reset to the default settings from the
 Configuration Settings submenu. As soon as any changes are made, the configuration becomes modified, but
 a new configuration is not created yet, the modifications are only stored. If the Configuration Settings are
 Reset, the modifications will be lost, and it is not possible to restore them. To prevent this, a new configuration
 can be made which stores the personalized GUI settings.

Six predefined configurations are available by default: Marvin, Marvin v5.0, Marvin v1.0-5.0, ChemDraw-

like*, ISIS/Draw-like*, and the View Mode. Each one has its own menubars, toolbars, etc.
 A configuration can inherit the definitions from others. For example the Marvin v5.0 configuration inherits the
 default menubar, pop-up menu and shortcuts definitions from the Marvin v1.0-v5.0, only the toolbars are
 redefined.
 Note: configuration settings will not change the behavior of the application, it only applies to the GUI.

 The configuration-related commands can be found in the View > Editor Style (or View > Configurations)
 menu.

 The available functions are described in the following table:

Make Active Activates a configuration which will not cause the loss of modifications when the current
 configuration is modified.

Edit Opens the Customize dialog with the selected configuration definitions loaded.
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Rename Simply changes the name of a configuration.
Copy Creates a new configuration based on the selected one inheriting all GUI definitions.

Reset Returns to the default configuration settings by dismissing all modifications. 
This operation cannot be undone.

Import Imports an XML or a serialized (.ser) configuration file.
Export Exports the active configuration to an XML or a serialized (.ser) file.

 Screenshots of the six available configurations:

1. Marvin Configuration

2. Marvin v5.0 Configuration
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 Note: only menu items are different from the ones in "Marvin Configuration".
3. Marvin v0.1-0.5 Configuration
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4. ChemDraw-like* Configuration
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5. ISIS/Draw-like* Configuration
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6. View Mode
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* Please see the Trademarks document for details.

http://onlinelibrarystatic.wiley.com/marvin/help/Trademarks.html
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Customizing MarvinSketch GUI - Server side

The Customization document demonstrates an easy, interactive way of GUI personalization.

 This document shows how to use the same interactive method to customize the GUI if MarvinSketch is used as an applet being on a
 server or as a JavaBean.

Note, that API and XSD will also be available very soon.

The configuration file

 MarvinSketch stores all changes made on the GUI in a configuration file.
 This file is located at USER_HOME/CHEMAXON_DIR/VERSION/customization.xml, where

USER_HOME is C:\Documents and Settings\USERNAME on Windows, /home/USERNAME on Unix

CHEMAXON_DIR is chemaxon (Windows) or.chemaxon (Unix)

VERSION is the actual version number of MarvinSketch, with which the customization is made

 Example location:
 Windows: C:\Documents and Settings\USERNAME\chemaxon\6.0.0\customization.xml
 Unix/Linux: /home/USERNAME/.chemaxon/6.0.0/customization.xml

Applet customization step-by-step

1. Remove the the configuration file from your local file system (make sure to create a backup)
2. Launch MarvinSketch on the client side
3. Personalize the GUI using the methods described in the Customization document
4. Upload the newly created configuration file to be beside the MarvinSketch applet on the server, e.g., http://example-

server.org/marvin/customization.xml
5. Set the "menuconfig" applet parameter to the URL of the configuration file, e.g., 

msketch_param("menuconfig", "http://example-server.org/marvin/configuration.xml");

 or
msketch_param("menuconfig", "files/marvin/configuration.xml");

JavaBean customization step-by-step

1. Remove the the configuration file from your local file system (make sure to create a backup)
2. Launch MarvinSketch on the client side
3. Personalize the GUI using the methods described in the Customization document
4. Copy the newly created configuration file to a path which is included in the classpath of the application
5. Use UserSettings to instantiate the bean:

        UserSettings userSettings=new UserSettings();

        userSettings.put("menuconfig", "org/example/configuration.xml");

        MSketchPane sketchPane=new MSketchPane(userSettings);

        

Example 1 : Make ISIS/Draw-like configuration to be the default

The Configurations document describes built-in alternative schemas for personalized GUIs.
 To make a configuration schema to be the default, the identifier of the desired configuration has to be set in a simple xml file.

The identifiers of the available configurations are below:

Configuration Identifier
Marvin default
Classic Marvin classic
ISIS/Draw-like config1
ChemDraw-like config2

 The contents of the configuration file:

    <?xml version="1.0" encoding="UTF-8"?>

    <customization active="config1">

    </customization>

Example 2: Creating a custom Tools palette

http://onlinelibrarystatic.wiley.com/marvin/help/developer/sketchman.html#parameters.menuconfig
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This example shows a configuration file which performs the following changes:

the Tools toolbar on the left hand side is hidden
a new toolbar is defined in its place with some custom actions
the Atoms toolbar on the right hand side is changed

The result is shown in the picture below:

The content of the default scheme of the configuration file is as follows:

       <scheme id="default">

        <modify path="toolbar/atoms/atom.N" visible="false"/>

        <modify path="toolbar/atoms/atom.S" visible="false"/>

        <modify path="toolbar/atoms/atom.F" visible="false"/>

        <modify path="toolbar/atoms/atom.P" visible="false"/>

        <modify path="toolbar/atoms/atom.Cl" visible="false"/>

        <modify path="toolbar/atoms/atom.I" visible="false"/>

        <add path="toolbar/atoms">

          <item id="increaseCharge"/>

          <item id="decreaseCharge"/>

        </add>

        <order 

itemorder="periodicSystem/atom.H/atom.C/atom.N/atom.O/atom.S/atom.F/atom.P/atom.Cl/atom.Br/atom.I/increaseCharge/decreaseCharge"

 path="toolbar/atoms"/>

        <modify index="1" path="toolbar/tools" row="0" visible="false"/>

        <toolbar anchor="west" id="CustomToolbar-0" index="0" name="Custom-Tools-Palette" row="0">

          <item id="bondGroup"/>

          <item id="insertElectronFlow"/>

          <item id="insertElectronFlow2"/>

          <item id="insertRectangle"/>

          <item id="insertArrow"/>

          <item id="insertTwoHeadedArrow"/>
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        </toolbar>

      </scheme>

Currently using a configuration file is the only way to change the GUI of applets or beans. The possibility of using the API will be available
 soon.

 Note that the graphical user interface of MarvinView and MarvinSpace can not be customized yet.
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Configure the Attach Data Dialog in MarvinSketch

The Schema definition

The XML Schema Definition file of the configuration xml can be downloaded from this link.

With the help of the XSD file, you can validate your configuration before applying it to the MarvinSketch
 application. You can also find information about the usable elements, and attributes in the documentation
 sections of the definition file.

The default AttachData dialog configuration

The default configuration becomes active when no user configuration is found. If a user configuration file is in the
 [.]chemaxon directory inside the home directory of the user with the name "AttachDataDialog.xml" can be found,
 then the configuration defined in the file will be used, and the default configuration will not take effect.

 Contents of the default configuration: <?xml version="1.0" encoding="UTF-8"?>
 <AttachDataDialogConfig

     xmlns="AttachDataDialogConfig"

     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

     xsi:schemaLocation="AttachDataDialogConfig AttachDataDialogConfig.xsd ">

 <context name="Atom"></context>

 <context name="Bond"></context>

 <context name="Single Bond"></context>

 <context name="Double Bond"></context>

 <context name="Fragment"></context>

 <context name="Group" displayName="Group (Selection)">

     <dataname textRepresentation="COEFF"/>

     <dataname textRepresentation="Stoichiometry"/>

     <dataname textRepresentation="[DUP]"/>

     <dataname textRepresentation="REAGENT"/>

 </context>

 </AttachDataDialogConfig>

A complex example configuration file

<?xml version="1.0" encoding="UTF-8"?>

 <AttachDataDialogConfig

     xmlns="AttachDataDialogConfig"

     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

     xsi:schemaLocation="AttachDataDialogConfig AttachDataDialogConfig.xsd ">

 <context name="Atom">

     <dataname textRepresentation="foo" defaultTag="f" multipleValuesEnabled="false"

 valueFieldEditable="false">

         <value>bar1</value>

         <value>bar2</value>

         <value>bar3</value>

         <unit>u1</unit>

         <unit>u2</unit>

     </dataname>

     <dataname textRepresentation="foo2" multipleValuesEnabled="true">

         <value>bar2</value>

         <value>bar4</value>

         <unit>u1</unit>

         <unit>u3</unit>

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/sketch-basic_files/AttachDataDialogConfig.xsd
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     </dataname>

 </context>

 <context name="Group" displayName="Group (Selection)" nameFieldEditable="false">

     <dataname textRepresentation="foo">

         <value>bar3</value>

         <value>bar4</value>

         <value>bar5</value>

         <unit>u1</unit>

         <unit>u3</unit>

         <unit>u4</unit>

     </dataname>

 </context>

 <context name="Bond"/>

 <context name="Single Bond">

     <dataname textRepresentation="foooo"/>

 </context>

 </AttachDataDialogConfig>

The result of this configuration can be seen in the dialog.
 With this file the following have been configured:

The context field will have four values: the Atom, Group, Bond, Single Bond
When the Atom context is selected, the Name combo box will have the following values set: editable empty
 field, foo, foo2
When the Atom context is selected, and the value foo is selected in the Name combo box, the Value field
 will not be editable
When the Group context is selected, the Name combo box will have the following value set: foo
When the Group context is selected, the Name combo box will not be editable
When the Bond context is selected, the Name combo box will only contain the editable empty field
When the Single Bond context is selected, the Name combo box will have the editable empty field, and the
 foooo name set
In one session if the user enters something into the editable empty field, then that value will be added to
 the list of names belonging to the context. These values will be missing after restarting the application.
Same names in the name field are independent from each other, if they are in a different context. Same
 names inside the same context will cause confusion, and maybe malfunction.
After selecting the name, the Value field will load the defined values in the given Context for the specified
 name, if there are any.
If the multipleValuesEnabled attribute of the namedata element is set to true, then the user can select
 more than one value in the Values field, otherwise only one value can be selected.
If the defaultTag attribute is set for the dataname element, and the name is selected, then the Tag field will
 be filled with its defaultTag. (Tag can be of a single character length, this is only checked by the GUI.)
The Values field also has an empty editable field, newly entered values work the same as by the Name
 field.
The Unit field also has an empty editable field, newly entered values work the same as by the Name field.
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Configuring copy/paste operations in applets.

 Using this configuration the copy/paste operations available in the applet can be controlled: the formats available
 for copy or paste can be manipulated, or the corresponding resources can be preloaded.
 For example, the copy or paste of specific file formats can be forced to be immediately available after the start of
 the applet, so instead of loading the underlying architecture on demand, the required resources are loaded
 during the applet initialization time.
 In addition, the formats available on the clipboard after a simple copy operation can be configured, as well as the
 list of formats available in the Copy As dialog.

 The configuration is available through a Java properties file which has to be placed to the
 APPLET_CODEBASE/chemaxon/marvin/datatransfer.properties file. If this file is available in the applet codebase,
 the configuration will take effect.

 This properties file contains settings for format keys. The property name format is as follows:
 formatkey.configuration.setting.id, so for example, if somebody wants to disable the png format on the copy
 as dialog, then the png.use.dialog key has to be set to false.

Available format keys in the property file, and the corresponding formats:

Format key The corresponding format
mrv Marvin Document Format
skc IsisDraw Sketch file format
cdx ChemDraw Sketch file format
mol MDL MOLfile format
rxn MDL RXNfile format
smiles Daylight SMILES format
smarts Daylight SMARTS format
cxsmiles Chemaxon extended SMILES format
cxsmarts Chemaxon extended SMARTS format
name IUPAC name format
trad_name Traditional name format
inchi IUPAC InChI format
inchikey IUPAC InChIKey format
string Molecule source, containing the actual file format of the molecule object
emf Enchanced Metafile picture format (available only on windows platforms)
jpg JPG image format
png PNG image format

Available configurable properties for all formats and their meanings:

Parameter
 name Valid values Meaning

name can be any String This will be displayed in the Copy As dialog to represent the format.
disabled true/false If set to false, then the format won't be available at all.

preload.copy true/false If set to true, then the classes needed for copying in the specified format will
 be preloaded at applet initialization.

preload.paste true/false If set to true, then the classes needed for pasting in the specified format will
 be preloaded at applet initialization.

preload true/false If set to true, then the classes needed for copying or pasting in the specified
 format will be preloaded at applet initialization.
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use.default true/false If set to true, then the molecule will be placed to the clipboard by a simple
 copy operation in the specified format.

use.dialog true/false If set to false, then the specified format won't be available in the Copy As
 dialog.

 By default, none of the formats are preloaded, all of them are configured as they worked before.

Other available options:

 The following keys are not related to the formats, and should be used as they are:
Property

 name Valid values Meaning

ole.enabled true/false If Microsoft OLE object copy should be disabled then set to false.

ole.name can be any String This will be displayed in the Copy as dialog to represent the
 Microsoft OLE object format.

separator a comma separated list of
 format keys.

After the enumerated formats a separator will be placed in the copy
 as dialog.

The default configuration file

 #define where to place separator in the copy as dialog.

 #comma separated list, separators will be placed after the listed formats

 separator = string

 #OLE related settings. Note: OLE is usable only on Windows platforms.

 ole.name = Marvin Object (OLE)

 ole.enabled = true

 #structure formats

 mrv.name = Marvin Document (MRV)

 mrv.disabled = false

 mrv.preload.copy = false

 mrv.preload.paste = false

 mrv.use.default = true

 mrv.use.dialog = true

 skc.name = ISIS (Symyx) file (SKC)

 skc.disabled = false

 skc.preload = false

 skc.use.default = true

 skc.use.dialog = true

 cdx.name = ChemDraw file (CDX)

 cdx.disabled = false

 cdx.preload = false

 cdx.use.default = true

 cdx.use.dialog = true

 mol.name = MDL MOLfile

 mol.disabled = false

 mol.preload.copy = false

 mol.preload.paste = false

 mol.use.default = true

 mol.use.dialog = true

 rxn.name = MDL RXNfile



Configuring copy/paste operations in applets.

http://onlinelibrarystatic.wiley.com/marvin/help/developer/applets/clipboard_configuration.html[11/4/2015 9:57:15 PM]

 rxn.disabled = false

 rxn.preload.copy = false

 rxn.preload.paste = false

 rxn.use.default = true

 rxn.use.dialog = true

 smiles.name = Daylight SMILES

 smiles.disabled = false

 smiles.preload.copy = false

 smiles.preload.paste = false

 smiles.use.default = false

 smiles.use.dialog = true

 smarts.name = Daylight SMARTS

 smarts.disabled = false

 smarts.preload.copy = false

 smarts.preload.paste = false

 smarts.use.default = false

 smarts.use.dialog = true

 cxsmiles.name = ChemAxon SMILES (CXSMILES)

 cxsmiles.disabled = false

 cxsmiles.preload.copy = false

 cxsmiles.preload.paste = false

 cxsmiles.use.default = false

 cxsmiles.use.dialog = true

 cxsmarts.name = ChemAxon SMARTS (CXSMILES)

 cxsmarts.disabled = false

 cxsmarts.preload.copy = false

 cxsmarts.preload.paste = false

 cxsmarts.use.default = false

 cxsmarts.use.dialog = true

 name.name = Name

 name.disabled = false

 name.preload.copy = false

 name.preload.paste = false

 name.use.default = false

 name.use.dialog = true

 inchi.name = InChI

 inchi.disabled = false

 inchi.preload = false

 inchi.use.default = false

 inchi.use.dialog = true

 inchikey.name = InChIKey

 inchikey.disabled = false

 inchikey.preload = false

 inchikey.use.default = false

 inchikey.use.dialog = true

 string.name = Molecule Source (Plain Text)

 string.disabled = false
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 string.preload = false

 string.use.default = true

 string.use.dialog = true

 #image formats

 #emf supported only on Windows platforms

 emf.name = EMF Image

 emf.disabled = false

 emf.preload = false

 emf.use.default = true

 emf.use.dialog = true

 #default copy contains these formats because Java Image Flavor is used in default copy.

 jpg.name = JPG Image

 jpg.disabled = false

 jpg.preload = false

 jpg.use.default = false

 jpg.use.dialog = true

 png.name = PNG Image

 png.disabled = false

 png.preload = false

 png.use.default = false

 png.use.dialog = true

Further format couplings

 Please consider this information also while changing the configuration.

If OLE is enabled, then the OLE data will contain the mrv, the mol or rxn file, and the emf image also.
Default copy places image data to the clipboard, in java image format. If you want to disable this behaviour
 you have to set the jimage.use.default property to true.
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How to Use Basic MarvinSketch Functions

Table of Contents

Creating a New Molecule

A new, blank molecule is created when you first launch MarvinSketch. You can immediately begin working with
 this molecule. A MarvinSketch window can hold only one molecule at a time, so all work you do within the canvas
 is considered part of the same molecule. You can create a new, blank molecule at any time during your session
 by choosing File > New > Clear Desk from the menu bar. This will clear the desk and discard any unsaved
 changes to the molecule you were previously working with (but you can get it back using the Undo option).

The application allows you to work with multiple molecules in multiple windows by choosing File > New > New
 Window.

Opening and Saving a Molecule File

To Open an Existing Molecule File

You can open existing molecule files (from supported file formats) by choosing File > Open... on the menu bar.
 It will load the content of the molecule file into Marvin and discard any unsaved changes.

Tick the Show preview checkbox to see the contents of the file (molecules, reactions, queries). A single item is
 displayed in the preview window; the text field at the bottom shows the index of the current structure and the
 number of structures in the file. When a multiple structure file is selected (e.g., mrv, sdf), the navigation buttons
 become active. Their functions are: go to first, go to previous, go to next, go to last. Note that the preview
 window allows you only to check the contents of a file, but not to select the structures you would like to open.
 For this purpose the Select textbox has to be used, where you can write the serial numbers of the molecules to
 open. The numbers have to be separated either by commas or by a dash. (Clicking on the Info button in this
 row will present tips for specifying the desired molecules.) Leaving this textbox empty means that every
 molecule in the file will be loaded onto the canvas. Currently this is the default behavior of file loading in
 MarvinSketch.
 In order to open a pdf file containing chemical names in MarvinSketch, you need to apply Document to Structure
 (d2s) conversion. If your pdf file conatins images of compounds, you need OSRA to be installed on your
 computer in order to import the structures into Marvin (possible since version 5.3.0). Please consult this page for
 details.

 The File > Insert file menu option has to be chosen if you want to open a file, but, at the same time, you do
 not want to lose the molecule(s) currently on the canvas. The Insert dialog window works in the same way as
 the Open dialog.

You can also Paste existing structures from other windows, as well as Drag & Drop a chemical structure into the
 MarvinSketch window. Both actions will add the new structure to the currently loaded ones without overwriting
 the contents of the canvas.

Importing structures from image files or pasting them from the clipboard with the help of OSRA is also possible
 (since version 5.3.0). Select File > Import Image if you want to open an image file. The supported formats
 are: bmp, png, jpg, gif, svg, and tif. Alternatively, the File > Open... menu option can also be used for opening
 an image file. In this case you should select All Files from the list of Files of Type.

To Save a Molecule File

You can save the molecule in any of the supported file formats. This will allow you to open and work with this
 molecule later. In case of a single structure, the default behavior of the Save menu is to save the molecule to
 the same file as it was opened from, in the same format. If you want to change the filename or format, choose
 Save As. If you are working with a new molecule, Save will function the same way as Save As. If you are
 working with a multistructure file, both Save and Save As will open a dialog window where you have to define

http://onlinelibrarystatic.wiley.com/marvin/help/formats/imageimport.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/imageimport.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/imageimport.html
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 the parameters for saving.
 On the dialog window used for saving files, a Saving method tab can be opened with the help of the Advanced
 checkbox. The first half of the tab offers the following choices:

All structures TOGETHER: Saves all structures together in a single file.
 This is the default behavior of saving. If you do not open the Saving method tab, this option will be
 applied.
All structures SEPARATELY: Saves all structures separately in a single file.
Into SEPARATE FILES: Saves each structure into a separate file.
 In this last option, the numbering of molecule files begins with the molecule in the upper left corner.

The second option remains inactive unless the chosen file type supports multimolecule files (such as mrv or sdf).
 Similarly, for one molecule only files, only the first option is enabled. The same applies to reactions and
 structures containing R-group definitions: in these cases only the "All structures TOGETHER" option is available
 as well.
 When the given parameters for saving (filename, format, and route) are the same as for an already existing file,
 the outcome will be determined by the other two radio buttons of the dialog window. If you select the Overwrite
 file option, the original contents of the file will be replaced. However, selecting the Append to end of file radio
 button will add the new structures to the original file, so its content will be preserved. In the first case, a new
 dialog window will be displayed, where you can reinforce or change your decision about overwriting the file. If
 the chosen file format does not support multiple structures, the Overwrite option is applied automatically.

To Edit and Save atom, bond, and molecule properties

 You can add, edit, and save properties of atoms, bonds, and molecule; just select the relevant part and choose
 "Edit properties..." option from the contextual menu. The added properties will be saved in the file which
 supports properties such as MRV or SDF (in case of the molecule property only). You can display atomic
 properties, setting Menu>View>Misc>Atom Properties; bond and molecule properties cannot be displayed
 on the canvas currently.

To Save as an Image File
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The Export to Image choice in the File menu allows you to save an image of the molecule in the sketcher.
 Marvin supports the following image formats: JPG, PNG, PPM, SVG, BMP, and SVG. Please note that the saved
 image cannot be edited in Marvin.

Printing

You can print an image of the current molecule by choosing File > Print. If you print from a single page
 document, if the size of your molecule(s) is bigger then the paper size, it will be shrunked to one page.

 If you want to print your molecule(s) to multiple pages, you have to change the document type to Multipage
 Document in File > Document Settings..., and arrange the structures on the pages.

Working with Multipage Molecular Documents

How to create a multipage molecular document

 Multipage molecular documents help to work with large drawings by dividing them into pages. You can create a
 multipage molecular document by choosing File > Document Settings..., then checking in the Multipage
 document checkbox.

 

 You can set the number of horizontal and vertical pages in the Document Grid part, and you can also define the
 title, the page size and the margins in the corresponding sections of this dialog window. After pushing the OK
 button, the following controls become automatically available:

The items in the View > Pages menu are enabled
A navigation status bar appears on the bottom of the window
The frame of the pages appear on the canvas, while the title, the margins and the page numbers are
 displayed on each page
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How to navigate in multipage molecular documents

The navigation status bar and the items in the View > Pages menu are available only if the Multipage
 document checkbox is set. The status bar contains information about the current page number in a text field
 and the number of all pages on a label. It also contains a collection of buttons to aid your quick navigation in the
 document. You can go the first, previous, next, and last page using them. Alternatively, you can go directly to a
 specific page by entering a number in the current page field and pressing enter.

All the navigation possibilities: go to first, previous, next, last, specific pages are available from the View >
 Pages menu as well. In addition, some automatic page zooming functions are also available in this menu, such
 as:

View > Pages > Fit page height adjusts the height of the current page to the height of the canvas.
View > Pages > Fit page width adjusts the width of the current page to the width of the canvas.
View > Pages > Fit page adjusts the height and/or the width of the current page to see the whole page,
 and places it centralized within the canvas.

Drawing Structures

You can create structures using atoms, bonds, and templates.

How to Draw Atoms

Select an atom from the Atoms Toolbar, the Periodic Table dialog window, or by shortcut.
Move the mouse into the molecule canvas. You will see the symbol of the selected item at the tip of your
 cursor. It can be placed in the molecule by left-clicking on the desired location.

Marvin is chemically intelligent. It will account for implicit hydrogens and set the charge according to
 valence rules.
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 In case of metals, the following rules apply: metallic elements from the 1st and 14-16th groups are added
 hydrogens, other appear as simple elements as default.
You can replace any atom in the molecule by placing a new atom on top of it.
You can represent atoms in a molecule with practically any arbitrary symbol instead of standard atomic
 symbols by using Atom Aliases. An alias can be defined on the Advanced tab of the Periodic Table,
 among the Custom Properties.

How to Draw Bonds

Select a bond type using the Bond toolbar button or by shortcut.
To link two existing atoms, click on one then drag the cursor to the other.

Marvin will allow you to draw a bond between any two atoms in the molecule. Valence errors will be
 highlighted (if that option is enabled).

To draw a bond from a single atom, simply click the atom. A carbon atom will be added at the other end of
 the bond.
If you add a bond to empty canvas space, a carbon atom will be added to each end of the bond.
You can replace any bond in the molecule by placing a new bond type on top of it.
Bond types can also be changed using the Bond pop-up menu. Single bonds can be changed to Double or
 Triple by left-clicking on them.

Bold Tool, , is intended to be used for graphical presentations of molecules. Activate the tool, click on a
 bond and it will be changed to bold. In case of single, double, or aromatic bond the tool keeps the type of
 the bond during multiple clicking. In case of aromatic bond, Bold Tool has four positions: bold single, bold
 aromatic up, reversed bold aromatic up, and single. Note: your mouse must point to the same position of
 the bond. In case of other bond types (e.g., triple, wedges) multiple clicking has a different result; it does
 not retain the original bond type, but undoing the action does. Bold Tool is located in the Bond Menu, Tools
 toolbar, and bond PopUp menu by default.
Example

You can make the selected bond hashed: Choose the  icon from the "Tools" toolbar or the Bond
 >Hashed menu. It only retains single original bond type.

How to Draw Chains

 You can draw carbon chains easily selecting the Insert > Chain menu or clicking on the "Draw Chain" (

) icon of the "Tools" toolbar. For curved chains click on the  icon. The direction of the chain growth
 follows the mouse path. The number of carbon atoms can be increased or decreased by dragging the
 mouse. The chain drawing direction is mirrored based on the direction of the mouse movements.

Templates

MarvinSketch provides several predefined chemical structures, called templates or structure templates. They
 are categorized into template groups, like Amino Acids, Polycyclics e.t.c.
 The following template groups are available in MarvinSketch by default:

Generic
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Rings
Amino Acids
Aromatics
Bicyclics
Bridged Polycyclics
Crown Ethers
Cycloalkanes
Heterocycles
Polycyclics
Homology Groups
Alpha D sugars
Beta D sugars
Deoxynucleosides
Flavonoids
Nucleobases
Nucleosides
Organometallics
Protoalkaloids
True Alkaloids
Vitamins
My Templates

The templates can be accessed via the Advanced Templates Toolbar or through the Insert > Template menu
 item.

How to use Templates:

Select a template using the Template Library or the Advanced Templates Toolbar area.
In case the template structure contains any S-groups, the group(s) can be optionally expanded or
 contracted by pressing the Shift button.
Place the template structure by left-clicking on the desired location.

The Template Library Manager dialog contains buttons that customize template handling.

New substituent (fragment) editing

In some cases, you will find it difficult to add new fragments to your molecule file, for example if you already
 have structures cleaned in 3D. To add a new fragment to the canvas, follow these steps:

1. Choose the  New substituent from the Insert menu.
2. Draw the structure in the new canvas. If you would like to transfer and match it to your original 3D

 molecule, do a 3D clean on the new fragment (Structure/Clean 3D).

3. Click the  Transfer button in the top left corner to return to the original canvas and place the new
 fragment.

Sprouting

Atom sprouting:

Click an atom symbol on the toolbar or in the Periodic Table.
Place the cursor over the atom where you would like to add the atom.
Press the Shift key on the keyboard then click the atom. The new atom will be attached to that atom.
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Template sprouting: you can add the template connected by a bond formed between the selected non-primary
 atom and the attachment point of the template. This way adding a substituent will only replace a hydrogen atom
 on the selected atom, not the atom itself. This feature is limited to the use of symmetrical templates where
 attaching the template has only one possibility (e.g. as for phenyl).

Select a template from the toolbar or from the Template Library
Moving the cursor over an atom, a grey colored image will show you the positioning of the template.
Left-click on the atom will place the template.

To change the connection type (no sprouting):

Select a template from the toolbar or the template library.
Move the cursor to the canvas and hover over an atom.
Press the Shift key and while holding it down, click the atom.

 In both cases, you can change the bond angle by rotating the template: holding down the left mouse button,
 move the mouse to rotate the molecule, and release it when desired position is reached.

Adding a cyclohexane template to a secondary carbon
 atom:

Adding a cyclohexane template to a secondary carbon
 atom while holding down the Shift key:

Notes: 

1. Abbreviated groups will be extended when holding down the Shift key, its attachment is not affected in
 terms of sprouting.

2. The grey outlined template will not be shown if the creation of a new bond would lead to the valence error
 of the atom but will be added if you click the atom.

Merging structures

If you would like to form a new structure by combining two already drawn molecules, you have the possibility to
 merge them in few steps. This starts with defining the merging points in both the template and the substituent
 molecules (1, 2 or 3 pairs of them). The template molecule' coordinates are not changed, only the substituent is
 resized, rotated (in three dimensions) and moved to fit the template.

1. Select  Assign Atoms from the Structure menu, Directed Merge submenu.
2. Click and drag the arrow from the atom of the substituent to the template molecule. The arrow will be
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 numbered.
3. Repeat the assigning (the Assign Atoms action is still active, no need to re-select the command) once ore

 twice to define more merging points.

4. Merge the molecules by selecting the  Merge command from the Structure menu, Directed Merge
 submenu.

5. In case of assigning 1 or 2 atom pairs, the subsituent is selected after the merge and the Rotate in 3D
 mode is active, and you can rotate the substituent around an axis: 
1 atompair

In case of one bond, this bond is the axis;
In case two bonds, the axis is the bisector of the angle of these bonds;
In case of 3 bonds have to choose the x,y, or z axis, or define the axis by selecting two atoms.

2 atompairs
The rotation axis is defined by the two connection points of the template and the substituent. Now
 the user can rotate the substituent, and if any atom pairs fall in the merging range after the 3D
 rotation, they will be merged.

After the 3D rotation, any atom pair that falls in the merging range are merged. If this second merge
 happens only on one atom pair, the substituent remains selected, and is subject to a second 3D rotation
 action, where the rotation axis is defined by the original and the new connection points. Now rotate the
 substituent around this new axis, and again, if any atom pairs fall in the merging range after the 3D
 rotation, they will be merged.

Note: pressing the Shift key on your keyboard offers an alternative rotation axis

6. To finish merging, click anywhere on the blank canvas.

How to merge structures

Assigned atoms Selected for rotation Merge product

1 atom pair

2 atom pairs

3 atom pairs

Coordination compounds
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 You can use coordinate bond to represent coordination compounds (ferrocenes, metallocenes). For example: 

 
 The coordinate bond type can represent the connection between an atom and a group of atoms. The coordinate
 bond has two kinds of appearance according to IUPAC recommendation:

arrow between two atoms,
dashed line between an atom and a group of atoms.

 In the Edit >Preferences >Bonds menu item you can change the default line type of coordinate bonds to solid.
 To draw a bond between two atoms just choose the coordinate bond from the bond list and draw the bond by
 specifying the required direction. To draw a bond between an atom and a group of atoms you need to create a
 multi-center attachment point to represent the group of atoms.

To draw a coordinate bond between an atom and a group of atoms

Select the atoms to be represented at one end of the coordinate bond by a multi-center.
Choose "Structure>Add>Multi-center" from the main menu or "Add/Multi-center" from the contextual
 menu. A multi-center represented by a "*" will be added. If you move the cursor to the multi-center the
 represented atoms are highlighted (blue circle around the atom labels).
Draw a coordinate bond from the multi-center and edit the other end of the bond if required. The "*"
 representing the multi-center disappears after bond drawing.
Repeat steps 2-4 to draw further multi-centers and coordinate bonds if required.

Importing and displaying biomolecules

You can import RNA, DNA and peptide sequences from the menu choosing File > Import As or through the Edit
 > Source panel.

In the second case you have to select the import mode ('Peptide Sequence', 'DNA Sequence', or 'RNA sequence')
 if it is not possible to decide whether the sequence belongs to a peptide or to a nucleic acid. Peptides can be
 entered using their 1- or 3-letter amino acid codes (see documentation on peptide import). DNA nucleic acid
 sequences can be imported in four different formats: ACGT, A-C-G-T, dAdCdGdT or dA-dC-dG-dT. RNA nucleic
 acid import accepts sequences in two formats: ACGU and A-C-G-U. DNA/RNA sequences are displayed with their
 1-letter code on the canvas.

For peptides/proteins MarvinSkecth offers you the possibility to display them as their 1-letter or 3-letter codes
 selecting the View > Peptide Display menu item.

http://onlinelibrarystatic.wiley.com/marvin/help/formats/seq-doc.html
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You can easily draw peptide bridges and cycles in MarvinSketch. This way, you can better visualize disulphide
 bridges, cyclic peptides, and lactame or lactone structures occuring frequently in peptides and proteins. 

 

Select single bond tool and start to drag a bond from an amino acid: when you do this, the amino acids which
 have free attachment point(s) get highlighted. Please do not forget to delete the "H" and "OH" from the terminal
 amino acid chain if you would like to draw a cycle. Note, you cannot start a bond from an amino acid which does
 not have at least one free attachement point.
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When you release the mouse, the new bond is established. If there is more than one free attachment point on the
 starting and/or ending amino acid, you have to select the appropriate one from the pop-up dialog.

You can expand an amino acid group selecting 'Expand Groups' from the contextual menu over the group. To
 expand all groups of the peptide you should select 'Expand Groups' from the contextual menu over the canvas.
 Nucleotides of a DNA/RNA sequence can also be expanded in the same way.

Geometric Transformations of Structures

Geometric transformation functions (Flip, Mirror, Invert) can be used from the 'Edit > Transformation' main
 menu on the whole molecule or only on the selected part of the structure.

Flip a molecule

You might need to flip the whole or parts of the structures. These operations are located in the Edit >
 Transformation menu. If no selection is made, the operation will be executed on the whole structure (except
 for Group Flip). The flip operation is equal to a rotation of 180° around a horizontal or vertical axis in the plane
 of the drawing. 
 All flips result in stereocenter retention.

Horizontal flip 
(around y axis)

Vertical flip 
(around x axis)
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Rotate 180° 
(in canvas plane, around z axis)

Horizontal Flip, Vertical Flip, Rotate 180°

Flip a selection:

1. Select part of the structure.
2. Right-click on the structure or go to Edit > Transformation menu.
3. Click on the command.

Flip the whole structure without selection:

1. Go to the Edit > Transformation menu.
2. Click on the command.

Note: If no structure is selected, the right-click on the canvas will not offer the flip command.

Group Flip

The Group Flip operation can be executed only on a selected structure connected to the rest of the molecule by
 only one bond (of any type): the selection can not be in the 'middle' of a molecule. The selection is not permitted
 for disjunctive structures either.

This operation rotates the selected group by 180° around an axis set on the bond connecting the selection to the
 rest of the molecule. Stereocenters in the molecules are retained, the wedge bond styles change to keep the
 stereo information.
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Group flip

1. Select part of the molecule.
2. Right-click on the canvas and select Transformation > Group Flip; or go to the Edit > Transformation

 menu.
3. Select Flip > Group.

Mirror a molecule

 Apart from flipping Marvin is able to produce mirror images of the molecules or parts of. These operations can be
 found in the Edit > Transformation menu. If no selection is made, the operation will be executed on all the
 structures present in the canvas. Stereocenters will be inversed. Mirroring horizontally means that the theoretical
 mirror is horizontal and placed perpendicular to the canvas (left-to-right mirroring); the vertical mirroring means
 the mirror is vertical and perpendicular to the canvas (upside-down mirroring).

Horizontal mirroring (to yz plane)

Vertical mirroring (to xz plane)

Mirroring to canvas plane (to xy plane)



MarvinSketch Help

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/sketch-basic.html[11/4/2015 9:57:27 PM]

Mirror a selection:

1. Select part the molecule.
2. Right-click on the canvas or go to the Edit > Transformation menu.
3. Click the command.

Mirror the whole structure without selection:

1. Go to the Edit > Transformation menu.
2. Click on the command.

Group Mirror

In case of only one connecting bond between the selected and unselected parts of the structure, the Group mirror
 command is available. The group is mirrored to the plane perpendicular to the plane defined by the two atoms of
 the above mentioned connecting bond plus a neighboring atom (in the group) that is not collinear with the
 connecting bond.

Central inversion of a molecule

This feature mirrors all compounds on the canvas or selected fragments in 3D to a selected inversion center. The
 chirality is changed, all R is inversed to S, and vica versa.

The inversion center is the geometric center of the selected atoms: if there are more than one selected
 fragment, then all fragments are inversed separately to their geometric center.

The inversion center is a selected atom: all fragments are mirrored to the selected atom.
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Reactions

How to Draw Reactions

You can place a reaction arrow on the canvas at any time, even on a blank canvas. Only one reaction is allowed
 per molecule.

1. Select the Insert Reaction Arrow button. You will see the reaction arrow on the tip of the cursor when you
 move the mouse into the canvas area.

2. Click the location of the tail of the arrow.
3. Drag the mouse and release at the location of the head.

Once you have placed a reaction arrow on the canvas, MarvinSketch considers each part of the molecule in
 relation to the reaction. All parts of the molecule that are before the arrow are considered reactants. Every
 molecule after the arrow is a product, and the ones placed along the arrow are considered agents. You can align
 and/or distribute the objects of the reaction scheme by selecting the relevant option in Edit > Object menu. The
 centers of the objects will be considered during the alignment/distribution of objects. Note Selected agent
 fragments and texts are moved together with the arrow while keeping the distance between them.

How to Map Reactions

The arrow tool provides the easiest manual way to map corresponding reactant and product atoms. Select the
 arrow tool, hold down the left mouse button on a reactant atom, and drag it to the corresponding product atom.
 The same map number is added to both atoms marking, that they represent the same atom on the two sides of
 the reaction scheme. Similar tool "Manual Atom Map" can be added by customization. There are also keyboard
 shortcuts for mapping. Type m8, for example, and click on an atom. Atom map 8 is assigned to that atom.

 Marvin contains an automapper tool as well (available as Structure > Mapping > Map Atoms) assigning map
 numbers to all selected atoms of a reaction automatically.

 Map numbers of the selected atoms can be removed by the Structure > Mapping > Unmap Atoms menu item, or
 by typing m0 for the selected atoms.

How to Draw Electron Flow Arrows

Electron flow arrows show the actual direction of motion of the electrons. They can point from an electron or lone
 pair of an atom or from a bond to another atom or bond or even to an incipient bond (formed after the electron
 transition).

1. Select the arrow type (single electron flow or electron pair flow). (Menu: Insert > Electron Flow)
2. Move the cursor over a bond, electron, or lone pair (or over the atom itself if the valence electrons are not

 displayed around it) of the structure on the canvas, and push the mouse button. (It will be the source of
 the electron flow.)

3. Select the destination: drag the arrow while holding down the mouse button and release the button over
 the destination to finalize the electron flow arrow.
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See detailes of handling and displaying endpoints here.

Query Structures

There are molecules that cannot be represented by a single structure. Although it is possible to run multiple
 structure searches in cascade, it is much more efficient to run a search only once using a well designed query
 structure. This structure often contains query features, possibly including complex conditional expressions for
 atoms and bonds. For a more detailed description of this please see the Query Guide.

The easiest way to use Query Atoms, different Query Groups and Query Atom Properties is to find them on the
 Periodic Table's Advanced tab. 

Atom Lists and NOT Lists

It is possible to define the type of an atom in a custom atom list. If the type of the corresponding atom in the
 target molecular structure is a member of the list, it is considered a matching atom. NOT lists can be used to
 specify atoms to be excluded in the search.

"Atom List" and "NOT List" can be reached from the Periodic Table's Periodic Table dialog.

Custom Properties

Values can be added to the following "Custom Property" types from the Periodic Table's Advanced tab.:

R-group Converts the atom to an R-group with an index of the input "Value". (Only numerical values are
 allowed, with a maximum number of 32767.) This atom can be used to describe an unknown or
 unspecified molecule part or to draw an R-group query or a Markush structure.

Alias Converts the Alias value to the atom label. The input of the textbox is displayed as the atom label,
 but the atom itself does not change.

Pseudo Converts the input of the textbox "Value" to Pseudo atom type. The input of the textbox is
 displayed as the atom label, but the atom is replaced by an "Any" type Query atom.

SMARTS Converts the input of the textbox "Value" to a complex SMARTS query molecule or atom. If the
 cursor is kept over the canvas during typing, the conversion can be seen on-the-fly.

Value Adds the input of the textbox "Value" to the atom as its "Atom Value" property.

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/electronflow.html
http://www.chemaxon.com/jchem/doc/user/query_features.html
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Homology Groups

'Built-in' Homology groups can be found in the 'Special Nodes' section of the Periodic Table's Advanced tab, as a
 dropdown list, starting with "Alkyl".

More deatils of some other Query features and Homology groups are in the Query Guide.

R-group Query

An R-group query describes a set of derivatives in one query structure (substitution variation). It can be drawn
 the following way: First draw the root structure and place some R atoms either from the Periodic Table dialog
 window, from the popup menu or by typing a corresponding label such as "R1" on the keyboard. Then draw the
 variable R-group ligands and select those substituting the R1 atom. If you type "R1" now, the selected groups
 will be marked with "R1". Additional R-group conditions (Occurrence, RestH, If-then) can be set in the R-logic
 dialog window available from the Structure > Attributes menu.

To draw the attachment points for the R-definitions, you can use menu "Atom > R-group Attachment" from the
 menu (or R-group Attachment from the popup menu), or alternatively, when you draw the R-definitions and the
 mouse cursor still shows "R1", clicking on an atom of the definition will toggle the attachment point on that
 atom. (Please note that divalent R-groups must have two attachment points defined.)

How to draw R-group queries -- Step by step example

1. Draw the root structure first.

2. Move the cursor to the atom where you would like to place the R-group. (In this example, we place R-
groups in place of the terminal carbon atoms.) When the atom is highlighted (blue circle around the atom
 label), type the shortcut of the required R-group ID (e.g. R1). Alternative solution is selecting the ID from
 R-group sub-menu of the popup menu by pressing right mouse button over the atom.

3. Draw an alternative ligand with an R-group connection: Move the cursor to an empty place on the canvas
 (take care that nothing is selected) then press the shortcut of the next R-group (R2). The "in hand" object
 changes to the ID of the R-group (R2). (In this example, we add a ligand to terminal oxygen atom.) Click
 the terminal oxygen, then drag the mouse. You will see that the new bond is displayed and its orientation
 follows the cursor. Release the mouse button when the bond stands in the right direction.

4. Draw new fragments to the canvas (separately from the root structure), which will be the R-group
 definitions. (In this example, we draw the fragments for the first R-group definition to the right side and
 the second R-group definition will be placed below the root structure.)

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html#definition
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html#definition
http://www.chemaxon.com/jchem/doc/user/query_features.html
http://www.chemaxon.com/jchem/doc/user/query_special_types.html
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5. Next, define the R-group definitions. To do this, select those fragments that the first R-group should
 contain (on the right side). After the selection, press the shortcut of the R-group ID (R1). The ID and equal
 sign (R1=) will display beside the selected set and the "in hand" object will be the R-group ID.

6. Define attachment point to R-group members: Click the left mouse button on atoms where you would like
 place the attachment points. Repeat this operation on the other definitions of the R-group. (In this
 example, at the third definition, we select the left oxygen atom for attachment.) Alternatively, you can
 define R-group attachment points via the popup menu (by selecting R-group Attachment option on an
 atom of an R-group definition).

7. Create the second R-group by repeating the last two steps on the two remaining fragments.

8. In case of one attachment point, the connections are not numbered, only marked by a wavy line on the
 substituent side. 
In case of more than 1 attachment point, the connections are marked by numbers on the scaffold.
 Connection points on the substituents are marked with a wavy line, and the order is indicated by numbers
 (except for the 1st).
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If two R-groups are connected by a bond, the ligand order may be changed simply by the Bond > Ligand
 order command. Simply select the bond in question and select the combination in the menu (also available
 upon mouseover in the context menu).

9. You can define additional conditions, such as occurrence, rest H and if-then expressions to R-groups in the
 R-logic dialog window. To do this, select menu option Structure > Attributes > R-logic. After setting the
 conditions in the R-logic dialog window, press the OK button to apply the changes. R-logic can be
 visualized by switching on the Display > Misc > R-logic option.

Markush structures

 A Markush structure is a description of compound classes by generic notations. They are often used for patent
 claims and for combinatorial libraries. Link R-groups, link nodes, atom lists, position variation and repeating units
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 with repetition ranges are commonly used features in the representation of Markush structures.

Position Variation (variable point of attachment)

 You can create a variable point of attachment to represent a variable connection point to a group of atoms. The
 representation is similar to the above mentioned multi-center bonds. For example: 

 
 The alternative attachment points are displayed with grey shadow. If you move the cursor to the center (the
 bond ending in the ring) the represented atoms are highlighted (blue circle around the atom labels). How to
 draw Position Variation:

Draw the structure that will include the position variation.
Select the alternative connection point atoms.
Choose "Structure/Add/Multi-center" from the main menu or "Add/Multi-center" from the contextual menu.
 A multi-center represented by a "*" will be added. If you move the cursor to the multi-center the
 represented atoms are highlighted (blue circle around the atom labels).
Draw a bond from the center and edit the bond if required. The represented atoms are displayed with grey
 shadow after this step. The "*" representing the multi-center disappears after bond drawing.
Repeat step 2-4 to draw further variable points if required.

Frequency variation (Repeating unit with repetition ranges)

 A sequence of ranges to specify the repetition can also be used in a special group called repeating unit with
 repetition ranges. For example: 

 
 Here the repetition range is "3,5-7". The repetition count for the included structure (enclosed by the brackets)
 can be: 3,5,6 or 7. See Repeating units with repetition ranges for further information on drawing this feature.

Homology groups in a Markush structure

The simplest way is to insert homology groups from the Periodic Table's Advanced tab.
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1. Open the Periodic Table (toolbar or from the Atom menu), choose the Advanced tab.
2. In the Special nodes section, choose the homology group from the dropdown list.
3. The homology group stays at the mouse pointer, you can click the atom(s) on the canvas. You don't need

 to close the Periodic Table to continue drawing.

Editing the homology group properties in MarvinSketch

Select the homology group and right-click. Choose Edit Properties... Set the group properties in the dialog box.

Here is an example of the property dialog window for a cycloalkyl group:

By default, the atom and homology group properties are not shown. You can switch it on by checking the View >
 Advanced > Atom Properties menu.

 How to Create Groups

You can create a group easily from a structure. There are two possibilities:

Select the molecule or part of the molecule. Click the Create Group button in the toolbar and edit the group
 properties in the dialog window.
Click the Create Group button in the toolbar then select parts of the group. Upon releasing the mouse
 button, the Group dialog pops up.

Command shortcut: Ctrl-G

Edit groups: (since version 5.3) right-click on the group, select Edit group from the contextual menu and the
 group dialog opens.
Alternatively, select the group atoms and select Edit Group from the structure menu, Group submenu.

Group types: In the dropdown list of the group type only those types are allowed which are enabled for the
 actual selection in the molecule (to enable all types: go to Edit > Preferences > Structure tab and uncheck the
 'Validate S-groups at creation' box.)
 Enabling/disabling a group type depends on:

The number of crossing bonds it would have.
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The embedding of groups into each other: several conditions are checked here for the group to be created
whether it can be embedded into the groups which would contain it, 
e.g. polymer S-groups can not be embedded into multiple S-groups
whether it can embed all the groups which would be contained by it, 
e.g. structural repeating unit S-groups (SRU) can not embed monomers
whether it can be embedded directly into the group which would be its direct embedder, 
e.g. component S-groups can be directly embedded only into ordered or unordered mixtures
whether it can directly embed the groups which would be embedded by it directly, 
e.g. mixtures can directly embed only components.

Expandable S-groups are not allowed to be embedded into each other.

 Since those group types which are allowed only for whole fragments (mixtures, components and monomers) are
 always extended to whole fragments, thus these types are allowed even if only fragment parts where selected, if
 they are correct when extended to the whole fragment. 
 Extension to whole fragment is not allowed if the group type is changed by editing an existing group: in this case
 mixtures (etc.) are not allowed for fragment parts.

Abbreviated (superatom) groups

 Abbreviated groups are used to represent a part of a structure with a text abbreviation.

Insert an abbreviated group into your sketch: type the name of the abbreviation, to complete a longer
 name, press ENTER or END after typing the first few characters. Typing group abbreviations is case
 sensitive: e.g., typing either "NO" or "no" both lead to the nitrosyl (NO) functional group, while typing "No"
 results in the atom symbol of nobelium. If the cursor was placed over an atom, it will be automatically
 changed to the abbreviated group. If no atom was selected, the abbreviation is placed on the cursor. Click
 on the canvas to place it. If you would like to ungroup an S-group before placing it to the canvas, press
 the SHIFT button before you release the mouse on the desired location.
Create an abbreviated group: Click the Create Group button in the toolbar then select the group atoms
 and bonds. Upon releasing the mouse button, the Group dialog window pops up (this dialog window may
 be opened from the Structure > Group submenu as well). Name the group in the dialog window.

You can retrieve the hidden structure from the text abbreviation with the "Expand" function and hide the
 structure with the "Contract" function. Manipulation with abbreviated groups is possible with "Expand",
 "Contract", "Ungroup", and "Remove" from the Group submenu.

A short animation about abbreviated groups: Expand and ungroup abbreviated groups.

Add attachment points to abbreviated groups

After creating the abbreviated group (see previous section), right-click the corresponding atom and choose "Add
 S-group attachment", or select the atom and use the same option in the Atom menu. The attachment point is
 marked by a number in a green rectangle. This way, you defined a connection point of this group. (Please note
 that attachment points can be added only to abbreviated groups, so it is important to define the group first.) 
There is no limit to how many attachment points can be added to an abbreviated group; they will be numbered in
 the order of their creation. Crossing bonds will connect to group atoms through their first free attachment point.
 Only attachment points not occupied by crossing bonds are marked by numbers in the expanded abbreviated
 group. Similarly, crossing bonds connect to a contracted abbreviated group through the first free attachment
 point of the whole group. 
Removal of an attachment point works the following way: Select the "Remove S-group attachment" option either
 from the pop-up menu or from the Atom menu to erase the attachment point with the highest number on the
 atom in question.
 When you defined an abbreviated group, you can add it to the templates. Select the group, right-click and press
 "Add to My Templates". The template can be inserted by typing its name and clicking on the canvas.

Syntax of the abbreviated group name

 Numbers are automatically subscripted unless "\n" is used or at the start of string. Charges (+, -, ++, --, 3+
 etc.) are automatically superscripted at end of string or if the following character is a closing parenthesis. 

http://www.chemaxon.com/library/expand-and-ungroup-abbreviated-groups/
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 Allowed control sequences in the abbreviated group name:

\s - subscript
\S - superscript
\n - normal mode.

 Example: \S13CH4

User-defined abbreviated groups

Besides the default abbreviated groups you can also set up your own user-defined groups or redefine the default
 ones. Marvin stores its default groups in a formatted .txt file named default.abbrevgroup and by adding your
 own group file you can complement the default. To assemble your own .abbrevgroup file you should strictly
 follow abbreviated groups file format. The newly defined file must be named user.abbrevgroup and should be
 stored in the chemaxon folder of your home directory in your file system. Note that Marvin gives priority to the
 user-defined abbreviated groups and overrides the default after redefinition.

Multiple groups

 Multiple groups are used to represent a repeating part in a structure with a shorter form. To create a multiple
 group, click the Group tool on the toolbar, then select the structure involved. Here you can specify a positive
 repeating count depending on how many times you want the structure to be repeated. You can retrieve the
 whole structure from the condensed form with the "Expand" function and shorten the structure with the
 "Contract" function. Manipulation with multiple groups is possible with "Expand", "Contract", "Ungroup", "Edit
 Group", and "Remove" from the Group submenu.

Components, Unordered Mixtures and Ordered Mixtures

 These features can be expressed by brackets (groups) of type component, unordered mixture (also called
 mixture) and ordered mixture (also called formulation). A component here is a set of atoms contained by a
 component bracket.

Ordered and unordered mixtures

 An unordered mixture (denoted by "mix" at the bottom of the right bracket) consists of several unordered
 components (denoted by "c" at the bottom of the right bracket). For these types of mixtures, the order of
 addition during the preparation is not important. Example:

 Ordered mixtures, on the other hand contain ordered components, which define the order of addition. Example: 

http://onlinelibrarystatic.wiley.com/marvin/help/formats/abbrevgroup-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/library_location.html
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To draw an unordered component

1. Draw the structures that form the mixture.
2. To define a structure as a component in a mixture, click the Group tool on the toolbar, then select the

 structure.
3. In the "Create Group" dialog window choose "Component (c)" from the "Type" list.
4. The "Order" field should be empty or should contain "none". If the "Order" field already contains a number,

 just delete it (you can type in "none" as well).
5. Click OK.

To draw an ordered component

1. Draw the structures that form the mixture.
2. To define a structure as a component in a mixture, click the Group tool on the toolbar, then select the

 structure.
3. In the "Create Group" dialog window choose "Component (c)" from the "Type" list.
4. If this is the first component of the mixture, click the "Order" field and enter "1" in place of "none". If the

 "Order" field already contains a number Marvin will automatically increment the "Order" field for
 subsequent components.

5. Click OK.

To draw a mixture

1. Create the components to form the mixture.
2. Click the Group tool on the toolbar, then select the structures.
3. In the "Create Group" dialog window choose the type ("Ordered mixture(f)" or "Unordered mixture(for)")

 from the "Type" combobox.
4. Click OK.

To change the type of a mixture

1. Hover the mouse over the group.
2. Choose "Edit Group" from the contextual menu (right mouse click on the selected mixture).
3. Change the type of the mixture.
4. Click OK.

To add a new component to a mixture
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1. Draw the new component.
2. Drag one part of the bracket and move it to enclose the new component.

To delete a component from a mixture

1. Select the component.
2. Press the Delete button on your keyboard or select the Erase tool.

Polymers

 The polymer structure consists of structural fragments. These fragments are enclosed by polymer brackets. The
 meaning of a polymer bracket is that the fragment within the brackets can repeat with itself. The fragment
 within the bracket is called repeating unit. Polymers can be represented as structure-based or source-based
 polymers depending on how much structural detail is known.

Source-based representation of polymers

 You can use the monomer (mon) or mer (mer) repeating unit types to draw a polymer where only the source-
based representation is known. For example:

 To draw a repeating unit, click the Group tool on the tooolbar, then select the atoms you want to be included.

Structure-based representation of polymers

 You can use the structural repeating unit type (SRU) to draw a polymer where the structure-based
 representation is known. Each SRU S-group has two or more dedicated bonds, called crossing bonds, which cross
 the brackets. The crossing bonds of an SRU show how the repeating units may connect in several ways to each
 other within the polymer. Depending on the number of crossing bonds and brackets we differentiate the following
 polymers and connectivities within the polymer:

Polymers with two crossing bonds. If the polymer has one crossing bond on each bracket of the SRU there
 are three possibilities for the repeating pattern:

head-to-tail
head-to-head
either/unknown

Ladder-Type Polymers. Polymers with paired brackets and with two crossing bonds on each bracket are
 called ladder-type polymers. Here it must be specified how the two crossing bonds on each bracket
 connect to the corresponding bonds of the adjoining repeating units. Additionally to the head-to-tail, head-
to-head connectivity information there is flip information to specify whether the repeating unit flips around
 the polymer backbone when it connects to the adjoining SRU. These types of information are handled only
 in case of brackets with exactly two crossing bonds on both side (head and tail side). We differentiate the
 following polymer connectivities:

head-to-tail with no flip
head-to-tail with flip
head-to-head with no flip
head-to-head with flip



MarvinSketch Help

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/sketch-basic.html[11/4/2015 9:57:27 PM]

either/unknown

Polymers with three or more brackets. If the polymer has three or more bonds with a separated bracket on
 each bond, the polymer always has the either/unknown repeating pattern.

 The end groups of polymers are often unknown or unspecified which are represented by star atoms (*). The
 modified (mod), grafted (grf) and crosslinked (xl) form of a structural repeating unit can be drawn as well.

Copolymers

 If the structure consists of more than one repeating unit (mon, mer) or structural repeating unit, Copolymer (co)
 brackets/groups can be used to represent the structure. Copolymers might contain crossing bonds and star
 atoms. The following copolymers can be drawn:

random(ran)
alternating(alt)
block with or without junction unit (blk)
copolymer to represent modified polymers (mod)
copolymer to represent grafted polymers (grf)
copolymer to represent cross-linked polymers (xl)

 For example: 

To draw a simple polymer

1. Draw the structure that forms the polymer.
2. Click the Group tool on the toolbar, and select the structure. Leave out the atoms that should be replaced

 by "*" (star atoms).
3. In the "Create Group" dialog window choose the appropriate type from the "Type" list.
4. Set the polymer repeat pattern if necessary.
5. Click OK. The star atoms ("*") will be added automatically.

To draw a ladder-type polymer

1. Draw the structure that forms the polymer.
2. Click the Group tool on the toolbar, and select the structure. Leave out the atoms that should be replaced

 by "*" (star atoms).
3. In the "Create Group" dialog window choose the "SRU polymer" type from the "Type" list.
4. Set the polymer repeat pattern if necessary.
5. Click OK. The star atoms ("*") will be added automatically.
6. To create a bracket that crosses two bonds select the two brackets each crossing a bond and click Merge
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 Brackets in the contextual menu.

To draw a copolymer

1. Create the components to form the copolymer.
2. Click the Group tool on the toolbar then select the components to be included.
3. In the "Create Group" dialog window choose the type ("Copolymer (co)", "Copolymer, alternating (alt)",

 "Copolymer, block (blk)" or "Copolymer, statistical (stat)") from the "Type" list.
4. Click OK.

To change the type of a polymer

1. Hover the mouse over the group.
2. Choose "Edit Group" from the contextual menu (right mouse click on the selected mixture).
3. Change the type of the polymer.
4. Click OK.

To add a new subpolymer to a copolymer

1. Draw the subpolymer to add outside of the bracket.
2. Drag one part of the bracket to include the new subpolymer. The new molecule should be marked with blue

 circles when you hover the mouse cursor over it.

To delete a subgroup from a copolymer

1. Select the subpolymer to delete.
2. Press the Delete button on your keyboard or with the Erase tool.

Repeating units with repetition ranges

 A sequence of ranges to specify the repetition can also be used in a special group called repeating unit with
 repetition ranges. For example: 

 
 Here the repetition range is "3,5-7". The repetition count for the included structure can be: 3,5,6 or 7.

Syntax of the repetition ranges

 The repetition ranges consist of ranges separated by commas. A range can be either a simple non-negative
 number (e.g. 3) or two non-negative numbers separated by "-" (e.g. 5-7).

To draw a repeating unit with repetition ranges

1. Draw the structure that forms or contains the repeating unit.
2. Click the Group tool on the toolbar, and select the structure.
3. In the "Create Group" dialog window choose the type "Repeating unit with repetition ranges" from the

 "Type" list.
4. Set the repetition ranges.
5. Click OK.

Charge of the group
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Four types of groups can be assigned a charge sign: generic, component, monomer and mer groups. During
 group creation, you have the option to display the charge on the charged atom itself or the whole group. In the
 latter case, the charge will be displayed outside of the bracket on the right. If any additional charges are added
 (negative or positive) the net charge will be calculated and displayed. The charge-bearing atom can be revealed
 by pointing the cursor over the group (in select mode). To replace the charge, select the group and go to the
 Structure menu, Group submenu and click Edit Group (or right-click the selected group, and select Edit Group). 

How to Draw Graphic Objects and Text Boxes

To draw a (poly)line, rectangle or text box, use the Insert menu or the toolbar (if visible). These objects are
 depicted in blue color outlines to indicate that any object here does not bear any chemical meaning like reaction
 arrows or S-group brackets (in black). Point the mouse to the desired position on the canvas, click and hold the
 left button, move the mouse and release the button. To create a small rectangle or text box click again.

 The shape of an object is changeable or resizable by dragging one of its points to do it.

After placing a text box, you can immediately use the keyboard to type a text. Symbols can be inserted directly
 through the Insert symbol tool, . The tool contains the list of the most commonly used symbols by default.
 This list will be updated according to your latest selections. Click on the relevant symbol and it will appear in the
 textbox. If the desired symbol is not on the list, click on More Symbols for the full character list.

To change the contents of a text box, choose Select mode, click on the box, then use the keyboard.

You can place a text box with the IUPAC name(s) from the Structure > Structure to Name > Place IUPAC
 Name menu command and it will be automatically inserted under the structure. The name will be updated in
 real-time.

How to Draw a Link atom

You can draw link atoms using the popup menu in two ways:

1. Right-click on the atom to bring up the popup menu. Select the required repetition number from the "Link
 node" submenu. Marvin will find out the outer (non-repeating) bonds for you.

2. Select the atom you would like to be the link node and two neighboring bonds for outer (non-repeating)
 bonds. Right-click anywhere on the canvas to bring up the popup menu. Select the required repetition
 number from the "Link node" submenu.

Marvin will advise you if it is not possible to create a link node for the specified configuration (for example at ring
 fusions).

Outer (non-repeating) bonds will be denoted by brackets crossing them, and the repetition numbers will be put
 on the atom. All portion of the molecule connected to the link atom through non-outer bonds are supposed to
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 repeat together with the atom. See examples below.

 Molecule with link
 node  Meaning

To edit a link node repetition number or change outer bonds, repeat the drawing steps above. To make a link
 atom ordinary atom again, select "Off" from the "Link node" submenu.

How to Select a Structure
1. Set Selection mode on by clicking one of the three available Selection buttons.

1. To select a single atom, click on it.
2. To select two joined atoms, click on the bond that links them.
3. To select a rectangular region, choose Rectangle Selection, click at one corner of the desired region

 and drag the mouse to the opposite corner. While the mouse button is pressed down, a guide will be
 displayed to aid you.

4. To select a non-rectangular region, choose Lasso Selection, press the left mouse button to start
 selecting, and draw the region with your mouse without releasing the mouse button. A blue guide
 line appears along the selection region. A pink line will connect the start and end points.

5. To select a fragment
double-click on an atom or bond using Rectangle or Lasso selection,
or use the Structure Selection button and single-click on an atom or bond.

You can unselect all by clicking an empty area of the canvas.

How to Delete a Structure
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Using the Erase button:

1. Set Erase mode on by clicking the Erase button.

1. To erase a single atom or bond, click on it. The deletion of the terminal bond deletes the terminal
 atom by default. Pressing the Alt button while deleting the bond, the terminal atom is not deleted.
 To change the default behaviour, go to Edit > Preferences > Bonds tab and choose the desired
 Terminal Bond Deletion Method.

2. To erase a rectangular region, click at one corner of the desired region and drag the mouse to the
 opposite corner. While the mouse button is pressed down, a guide will be displayed to aid you.

3. To select a non-rectangular region, use the lasso selection function first, then press the Erase button.

Using Selection mode:

1. Select a portion of the structure.

2. Click the Cut button or use the DELETE button on your keyboard.

Using pop-up menus:

1. Right click on an atom or bond.

2. Select Remove from the pop-up menu.

How to Work with Structures

Visually Editing the Structure

You can edit a molecule using the methods described in How to Draw Structures and How to Delete a Structure.

Editing the Source

You can alter a molecule by directly editing its source in the Edit Source Window. You can view and edit the
 source in any of the supported file formats. To change format, simply select the desired one from the View
 Menu. If there are multiple molecules on the canvas, checking View as multiple molecules in the View Menu
 leads to each molecule appearing in a separate block in the source. This feature works only, if the selected
 format is able to handle multiple structures.

To reload the molecule described by the text in this window into the MarvinSketch canvas (including any changes
 you may have made), select File > Import As. If the automatic format recognition detects a file format
 (checking it by a priority list), it will be offered in the Select Import Mode field (Import as Recognized, indicating
 the file type in brackets). If the structure is associated to a file type of higher priority than your choice, choose
 the Import As option to set the file format. 
 For example, you want to create the seryl-asparagine dipeptide: write "SN" in the Source, then select Import.
 The automatic option detects it as SMILES, but if you select the Import As option, and then the "Peptide
 Sequence" from the list, it will be imported correctly.
 In addition, there are some cases when the automatic recognition cannot detect the file format, even though the
 entered text is correct (although it is very rare). In this case the Import As Recognized option is disabled and
 you have to choose the format from the list of the Import As option.

Cleaning

Marvin allows you to clean your molecule in either 2D or 3D. Cleaning will calculate new coordinates for the
 atoms. Generating conformers and choosing the favored one is also supported. You can initiate cleaning via the
 Structure > Clean2D/3D submenu. For more information on molecule cleaning, please visit this link.

Submenus

http://www.chemaxon.com/marvin/doc/user/cleanoptions.html
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Clean 2D
Clean in 2D: cleans the molecule(s) in 2D
Hydrogenize Chiral Cneter: adds an explicit hydrogen with a wedge bond to chiral centers which have
 no terminal atoms as substituents
Clean Wedge Bonds: changes wedge bonds for convention display

Clean 3D
Clean in 3D: cleans the molecule(s) in 3D
Cleaning Method: choosing from various methods
Display Stored Conformers: works only if conformers of the sketched molecule had been generated
 with the help of the Conformer plugin, choosing the 'Store conformer information in property field'
 option. See details in the plugin's documentation.

Aromatic Rings

You can toggle the display of rings as aromatic using the Structure > Aromatization submenu.

Structure Display Options

There is a wide range of functions related to the display of the molecules. These settings can be found in the View
 menu and the Preferences dialog window. Additionally, you can move, rotate, and zoom in/out on the structure.

Moving and Rotating

You can move or rotate a selected structure.

First, select the part of the structure you wish to move.

1. Moving the selection:

1. Move the mouse pointer toward the center of the selected structure until a blue rectangle appears. 
 (You can also use the Space key to change between transformation modes.)

2. Translate the selection by dragging the mouse.

2. Rotating the selection:

1. Move the mouse pointer toward the outline of the molecule until a blue gear appears.
 (You can also use the Space key to change between transformation modes.)

2. Rotate the selection by dragging the mouse.

3. Rotating the selection in 3D:
 Rotation in 3D of the following structural parts is possible:

all compounds on the canvas,
selected fragments,
selected groups.

Rotation of all compunds on the canvas in 3D can be accomplished by the View > Mouse mode > Rotate in
 3D menu option.
 The axis of the 3D rotation for selected objects can be determined in the Edit > Transform > Rotate in 3D
 menu (or from the contextual menu) by choosing from the following list:

Around an arbitrary axis defined by two atoms: in this case you are asked to select the atoms prior to
 the rotation.
Around x axis: horizontal axis in the plane of the canvas
Around y axis: vertical axis in the plane of the canvas
Around z axis: axis perpendicular to the plane of the canvas
Free 3D rotation: the rotation follows the movement of the mouse (click&drag). 
(Note: 3D rotation mode until version 5.3.x: pressing the Space key 3 times initiates the free 3D
 rotation.)

http://www.chemaxon.com/marvin/help/calculations/conformation.html#conformer
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Group Rotate: available only for a selected group in a molecule. The connecting bond(s) is recognized
 between the selected and unselected parts of the structure and selects the rotation axis accordingly.

The rotations are visualized by the fog effect: parts of the molecule behind the canvas are of lighter colour
 than the parts on the canvas. To see best the 3D view, use white background (View > Colors > White
 Background).

4. Customized tool: 3D plane:

1. Select 3 atoms in the molecule.

2. Click the 3D Plane button or select Edit > Transformation > 3D Plane.  The selected 3
 atoms will lie in the plane of the canvas. The coordinates are changed, not only the view of the
 structure.

Note: currently 3D coordinates of brackets (e.g. monomer, component type groups) are not correctly
 updated when rotating the molecule in 3D mode. Avoid when possible.

Scaling

Set the magnification of the molecule on the canvas by the Zoom buttons. If you have a mouse with a wheel,
 hold down the Ctrl key, and then scroll the wheel to zoom in or out. When a molecule is loaded into the sketcher,
 it is scaled automatically to fit the window.

Individual objects (bonds, reaction arrows, graphical objects, text boxes) or sets of objects can be scaled, too.
 Selecting these objects, corners of a bounding rectangle will appear. Dragging one of these corners, the selection
 will be scaled proportionally. In case of bond scaling, the percentage of the current bond length relative to the
 default value will be visible. The same result can be achieved by opening the Format... dialog either through the
 File > Document Style option or from the pop-up menu.

Molecule Format

You can set the display format for the molecule and screen resolution using the View > Structure Display
 submenu. Available molecule formats are Wireframe, Wireframe with Knobs, Sticks, Ball and Stick, and
 Spacefill. You can set the resolution to low or high via the Quality submenu.

Colors

The View >Colors submenu allows you to specify the color scheme of the molecules. The available options are:

Monochrome

CPK

Shapely - based on RasMol's shapely color scheme for nucleic and amino acids

Group - based on PDB residue numbers

Atom Set

Implicit/Explicit Hydrogens

Marvin has a number of options for the display of implicit and explicit hydrogens. Because Marvin is chemically
 intelligent, it will automatically add hydrogens as necessary within the structure. Generally, these will be implicit
 and displayed based on the options set in the View menu.

To view all hydrogens explicitly, displayed as atoms with bonds to neighbors, chose Structure > Add > Add
 Explicit Hydrogens. The Structure > Remove > Remove Explicit Hydrogens will return to the previous
 display mode.

http://onlinelibrarystatic.wiley.com/marvin/help/developer/sketchman.html#parameters.colorScheme
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To view implicit hydrogens by symbol, use the View > Implicit Hydrogens menu group. This option is disabled
 in Spacefill and Ball & Stick display modes.

Displaying the label of carbon atoms

Displaying the label of carbon atoms in structures is possible the following way:

Always - Always show the atom labels of carbon atoms.
Never - Never show the atom labels of carbon atoms.
At straight angles and at impl. Hs - Show the atom labels of carbon atoms at straight angles and at implicit
 Hydrogens.

 This option can be set in the Display tab of the Edit > Preferences box.

Error Highlighting

Marvin can not automatically correct all valence errors or any reaction errors. Instead, these errors are
 highlighted and you may make the appropriate corrections yourself. This option can be enabled and disabled
 through the Edit > Preferences box.

Saving Display Options

Many of the display settings in Marvin are saved and reloaded the next time you start the program. Background
 color, molecule color scheme, and hydrogen visibility can be set from the View menu and will be saved
 automatically when you exit the program. Other options, including look & feel, error highlighting, and object
 visibility can be set using the Preferences dialog window from the Edit menu.

Launching Other Windows

2D and 3D Viewer Windows

Choosing View >Open 2D Viewer or Open 3D Viewer launches a MarvinView window containing the current
 molecule of MarvinSketch.

How to customize structure drawing styles

More advanced display format can be obtained for the molecule by applying format styles. Format styles in
 Marvin include the setting of the following attributes:

type of atom font,
size of atom font,
color of atoms,
thickness of bonds,
color of bonds,
length of bonds.

 All these options can be collectively set using styles. To load or define styles use the File > Document Style
 menu. This menu brings up the "Format of the current document" dialog in which atom and bond format options
 can be specified. The original attributes for atoms and bonds can be restored by using the Reset functions of the
 dialog at any time.

When loading a molecule all atoms/bonds belong to the default atom/bond set if no styles were applied
 previously. After selecting an atom/bond set and applying a style for it, the selected atoms/bonds are removed
 from the default atom/bond set and a new set is created from the atoms/bonds with new style. All the
 atoms/bonds, whose style were not yet modified by selection and applying a style on them, still belong to the
 default atom/bond set.

Your changes might be applied for a set of atoms/bonds:

for the selected atom/bond set,
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for the default atom/bond set,
for all the atoms/bonds.

 The top three radio buttons specify the target of the format settings being edited in the dialog. The "Apply
 changes for all the atoms/bonds" option allows loading of predefined styles or creation of custom styles using the
 Load Style and Save Style buttons.

Loading a style

After pressing the Load Style button, you can load a style from a combo box or browse amongst the previously
 defined style files. The chosen style will be loaded into the "Structure Drawing Properties" in the "Format of the
 current document" dialog.

Saving a style

Set the "Structure Drawing Properties" you wish to save and press the Save Style button to get to the "Save"
 dialog where you can enter the name of the style file and save the style. All your own saved files will be stored
 under the chemaxon/styles/ directory of your home directory and will be added to the combobox items. A new
 style file can be added to the chemaxon/marvin/styles directory under the Marvin installation directory. This new
 style file has to be listed in file chemaxon/marvin/styles/styleFileList.properties. The new style file will be copied
 to the chemaxon/styles/ library in your home directory and appear in the combobox of the "Loading of a journal
 style" dialog. (Existing style files will not be overwritten.)

Return to Top

 Copyright © 1998-2013 ChemAxon Ltd.

http://www.chemaxon.com/marvin

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/library_location.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/library_location.html
http://www.chemaxon.com/
http://www.chemaxon.com/marvin
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File Formats in Marvin

Basic Export Options
Document formats:

Marvin Documents (MRV) (text)

Schema and validation
Molecule formats:

CML (text)

Molfiles and compressed molfiles (text)

MDL molfiles, RGfiles, SDfiles, Rxnfiles, RDfiles
Compressed molfiles
Export options
Programming interface

in Java
in JavaScript
in C and C++

Online compression

ISIS/Draw sketch file (skc) (binary)

ChemDraw sketch file (cdx (binary), cdxml (text))

SMILES, SMARTS and related formats (text)

SMILES and SMARTS
ChemAxon Extended SMILES and SMARTS
ChemAxon SMILES Abbreviated Group

Query properties in molecule file formats

IUPAC InChI and InChIKey (text)

Name (text)

Sequences(Peptide, DNA, RNA) (text)

Tripos SYBYL Mol and Mol2 (text)

PDB (text)

FASTA (text)

XYZ (text)

Gaussian Cube (text)

Gaussian Input/Output (text)

Markush DARC (vmn) (binary)

Graphics formats:
Image export

JPEG (binary)

BMP (binary)

PNG (binary)

PPM (binary)

EMF (binary)

PDF (text)

SVG (text)

Export to POV-Ray (text)

Image import via OSRA
Compression and encoding:

GZIP (binary)

Base64 (text)

http://onlinelibrarystatic.wiley.com/marvin/help/formats/basic-export-opts.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mrv-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mrv-schema.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/cml-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html#mol
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html#csmol
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html#options
http://onlinelibrarystatic.wiley.com/marvin/help/developer/molcompress-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/molcompress-doc.html#java
http://onlinelibrarystatic.wiley.com/marvin/help/developer/molcompress-doc.html#js
http://onlinelibrarystatic.wiley.com/marvin/help/developer/molcompress-doc.html#c
http://www.chemaxon.com/marvin/doc/dev/molcompress-demo.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/skc-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/cdx-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/smiles-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/cxsmiles-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/abbrevgroup-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/queryprops.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/queryprops.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/inchi-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/name-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/seq-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/sybyl-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol2-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/pdb-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/fasta-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/xyz-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/cube-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/gaussian-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/vmn-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/images-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/jpeg-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/msbmp-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/png-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/ppm-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/emf-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/pdf-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/svg-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/pov-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/imageimport.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/gzip-doc.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/base64-doc.html
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Molecule file conversion with the MolConverter program

http://onlinelibrarystatic.wiley.com/marvin/help/formats/molconvert.html
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Cut/Copy/Paste and Drag & Drop Functionality

 The cut, copy, and paste operations work in the bean and application versions of Marvin, and also in the applets.
 However, because of security reasons, the untrusted (unsigned) applets perform these operations using a local
 clipboard inside the JVM process. The non-applet versions of Marvin and the signed Marvin applets are allowed to
 use the system clipboard.

Where available?

 Marvin unsigned
applets

Marvin signed
applets1

Marvin Beans and 
 applications

Cut/Copy/Paste inside Marvin yes yes

Drag & Drop no yes2 yes

1: You can find more info about signed Marvin applets in the following documents: Browser compatibility of Marvin Applets, Signed applets

2: Drag & Drop works only when the sketcher is in its own window. When the applet is in the browser window, drop events are received by the browser

 instead of the applet.

Copy, Copy As..., Copy as Smiles

Marvin has three commands to place objects on the clipboard: Copy, Copy As... and Copy as Smiles.

Using the Copy command, the structure is copied to the clipboard in a couple of formats. The molecule
 always will be there in mrv, MDL Molfile and DayLight SMILES formats. The other formats (like Plain
 Text or Bitmap Image) are optional. See the table in the Clipboard formats section about supported
 options and default settings.
Using the Copy As... command, a dialog will display to select in which format you would like to place the
 molecule to the clipboard.
Using the Copy as Smiles command, the Smiles string of the structure is copied to the clipboard in String
 and Plain Text formats.
Note:Any file format of Marvin can be copied to the clipboard as a string or as plain text. From the Edit menu choose Source then

 Edit/Copy to place the desired format on the clipboard as plain text.?

Clipboard formats

 Marvin can place more than one clipboard object on the clipboard, each represents the same molecule in
 different format. Copy from Marvin supports the following representations:

Marvin Document (mrv): Marvin's own format. Only Marvin can paste it.
MDL Molfile: a popular molecule description format. A lot of chemical drawing tool can paste it like Marvin,
 ChemDraw, etc.
Daylight SMILES: wide range molecule format. Several chemical editor can paste it. In a few editor,
 SMILES can not be pasted directly. E.g. ChemDraw uses the "Paste Special/SMILES" option to copy
 SMILES from the clipboard.
Daylight SMARTS: a chemical format for specifying substructural patterns in molecules. Compared to
 SMILES, SMARTS is a more general notation thanks to its use of extended sets of atomic and bond
 symbols and logical operators, which make SMARTS a useful tool in substructure searching.
Plain Text (molecule source): To be able to copy the molecule source into text editors or into other
 application that do not support chemical formats.
Bitmap Image: To paste molecule image into presentations or into documents.
Vector Graphical Image (EMF): The vector graphics is scalable unlike bitmap image. It can be pasted
 into MS-Office documents or into other applications that support Enhanced MetaFile format.

http://onlinelibrarystatic.wiley.com/marvin/help/developer/applets/browsers.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/applets/signing.html
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OLE object: To copy a Marvin OLE object into MS-Office. This format is available under Windows. To be
 able to paste it into an MS-Office document, marvinOLEServer.exe registration is required. (Marvin
 installer does it automatically or you can register it manually in Marvin applications through the
 Edit/Preferences/OLEServer menu.) You can read more about OLE support in Marvin OLE User's Guide.
Portable document format (PDF) which contains vector graphical image. It is the default format in
 MacOSX.

 A couple of formats are not available on a few platforms.

Setting copy format options

You can also apply or deny the accessibility of one or more copy formats. You can set it by the following ways:

On the Copy panel of the Preferences dialog in the Edit menu.
As an applet parameter: copyOpts
From the Marvin Beans API: UserSettings.setCopyOpts(String)

Format Windows Mac OS X Linux

Marvin Document (mrv) +D - +D

MDL Molfile +D - +D

Daylight SMILES +D - +D

Plain Text (molecule source) + + +D

Bitmap Image + + +D

Vector Graphical Image (EMF) +D - -

OLE object +D - -

 

+  supported
-  not supported

D  selected as
 default

When the content of the clipboard is pasted into an application (and it is available in more than one format),
 the application retrieves data in the most descriptive format. Most versions of Microsoft Office prefer pasting
 image instead of text if the content of the clipboard is available in both formats. But there are a few ones that
 paste text as default. In that case, you should use "Paste As Special" option in MS-Office to paste it as image but
 it can be unconfortable to someone. The workaround can be the restriction of the text copy from Marvin. That is
 the reason why text copy is disabled in the default settings of Marvin (on a couple of platforms). 
 In that case, we recommend Copy As... or Copy as SMILES to paste text into MS-Word and in other editors.
 Another solution can be to change the default options of the Copy command (see above how to do it).

If we compare Bitmap and Vector Graphical Image formats, the situation is the same as in the previous case
 (text vs. image). Most of the applications prefer bitmap image although they can accept vector graphical images
 as an Enhanced MetaFile (EMF), like MS-Word. Since vector graphics are scalable unlike bitmap images, we have
 chosen EMF as default from image formats (where it is supported).

Data transfer between Marvin and other chemical drawing tools

 Windows1 Macintosh OS X4

ISISDraw2 Copy &
 Paste Copy & Paste

ChemDraw Copy &
 Paste Copy & Paste

ChemDraw
 Plugin

Copy &
 Paste Paste

 

Copy: copy a structure from the application into Marvin
Paste: copy a structure from Marvin into the
 application

1: On windows in Java 1.2-1.3.1, the <Java home directory>/jre/lib/flavormap.properties file must be edited: MDLCT=chemical/x-mdl-Molfile

http://onlinelibrarystatic.wiley.com/marvin/help/marvinoleserver.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/sketchman.html#parameters.copyOpts
http://onlinelibrarystatic.wiley.com/marvin/help/developer/beans/api/chemaxon/marvin/common/UserSettings.html#setCopyOpts(java.lang.String)
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2: In case of ISISDraw the following option must be checked: Option -> Settings -> General -> Copy Mol/Rxnfile to the Clipboard

3: Copy as SMILES works

4: In OS X, since Java 1.4, data transfer in chemical formats does not work. In that case, molecule can be pasted only as image or text into chemical

 drawing tools. Copy from an application to Marvin works if the application can place data as Plain Text to the clipboard.

Data transfer between Marvin and other applications

Marvin can paste SMILES strings, MDL MolFiles, etc. from a text editor as molecules.

 X Window System: most text editors (xedit, emacs, gvim, etc.) do not transfer data to the X clipboard, so Marvin
 is unable to communicate with them. Copy & Paste works with the following editors and other programs:

GNOME programs: gedit, gnotepad+ (gnp), gxedit, etc.
Motif programs: asWedit, nedit, Netscape, etc.

Note: With the xclipboard program, you can test whether your favorite editor uses the X clipboard or not.
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Chemical Features of MarvinSketch

Table of Contents

Valence Check

MarvinSketch does not automatically correct valence errors. Instead, they are highlighted by a red underline and
 you may make the appropriate corrections. This option can be turned on or off using the Edit> Preferences
 box.

Structure Checker

MarvinSketch offers a structure checking addon that gives warning for specific features or errors in the molecule.
 Single molecules can be checked in MarvinSketch, batch usage is available via command line or API (with
 license). Read more about Structure Checker.

Charges

In MarvinSketch, the charge of an atom is initially set to be neutral. As bonds are added or removed,
 MarvinSketch adjusts the number of implicit hydrogens to let the charge remain neutral. You may change the
 charge of any atom using the 'Atom' popup menu. The number of implicit hydrogens will be adjusted, if possible,
 to accommodate the new charge. MarvinSketch will then perform a valence check and highlight the atom if an
 error is found. Optionally, it is possible to display the charge symbols in circles. To set this option, go to the
 Display tab of the Preferences dialog located in the Edit menu. Here, you can also change the font type/size of
 the circled charge symbols.

Working with Radicals

MarvinSketch allows you to specify that an atom in the molecule is a radical. This functionality is available via the
 'Atom' popup menu.
To change an atom into a radical, right-click on it to access the 'Atom' popup menu. Select the type of radical
 from the Radicals submenu. A radical symbol will appear next to the atom and a valence check will be run with
 errors highlighted.

Isotopes

MarvinSketch allows you to change an atom into one of its isotopes using the 'Atom' popup menu or selecting the
 atom and choosing Atom>Isotope from the Menu Bar. 
There is the possibility to extend the isotope list with custom items. Technical details.

Stereochemistry

MarvinSketch provides enhanced stereochemical representations. Using the 'Atom' menu or 'Atom' popup menu,
 you can set the configuration of each chirality center in a molecule. The absolute configuration of a chiral
 molecule can also be defined by using Structure Menu. To see R/S labels in the structure, set the Stereo options
 in 'View' menu. 
 You can find more info about the scientific background of stereochemistry in MarvinSketch.

E/Z Feature

By choosing View > Stereo > E/Z Labels , you can toggle the display of absolute double bond
 stereoconfiguration labels. Bonds known to have an (E) or (Z) configuration will be marked as such.

Reactions

MarvinSketch allows you to draw reactions in your molecule by placing a reaction arrow. You can place the
 reaction arrow in any position, pointing in any direction. The structures before the arrow will be considered
 Reactants, structures along the arrow Agents, and structures after the arrow as Products.

http://onlinelibrarystatic.wiley.com/marvin/help/structurechecker/checker.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/isotopelist.html
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Mapping

MarvinSketch allows you to set a map label on any atom in the molecule. Map labels are useful because they
 remain constant, unlike atom indexes, which can change as the molecule is altered. Atom mapping can be very
 useful when drawing reactions. It allows you to specify that specific reactant atoms will become specific product
 atoms. You can assign the same free map number to both of these atoms by pressing the 'Reaction' Button on
 the toolbar then drawing the arrow from the first atom to the second one. You can also select a map number for
 an atom from the 'Atom' popup menu or use the shortcuts M1, M2, ... to assign map labels, M0 to remove map
 labels, and M= or M+ to assign unique map numbers.
 Alternatively, you can use the built-in automapper tool of Marvin, available from the Structure >Mapping >
 Map Atoms menu or from the 'Selection' popup menu, to assign map numbers to atoms in a reaction
 automatically.

Abbreviated groups (Superatom group)

MarvinSketch has a rich collection of features related to abbreviated groups.

Predefined Abbreviated Groups

A number of predefined abbreviated groups are available in MarvinSketch. The complete set is listed in the
 Groups menu. These groups are also available as shortcuts. 
Their usage is described in the Basic MarvinSketch page.
 The rotation of the molecule might change the groups' writing order, thus retaining the chemically correct
 connectivity. Read a detailed description of this feature.

User-Defined Abbreviated Groups

You can easily create new groups that you often use. Select the structure and give it a name (Superatom
 (abbreviation) in Structure > Groups > Create Group) and if needed, define an attachment point. Details.

S-groups as My Templates

User-defined groups are, by default, session-only. To retain an abbreviated group for future use, add it to My
 Templates. This will also make the group available in the Groups menu or as a shortcut.

Link Nodes

Link nodes enable specifying query structures containing rings or chains of variable size. In the following
 example, the number of carbons can be between 1 and 7:

Working with Groups

Group manipulation functions are available through the Structure > Group submenu and by right-clicking on an
 existing group. 
Choosing Contract from the context menu or Structure > Group > Contract Group from the main menu
 contracts one group to its abbreviation if there is one group selected, otherwise contracts all groups in the
 molecule. 
Choosing Expand Group from the context menu or Structure > Group > Expand Group from the main menu
 displays the full structure instead of a contracted group if there is one group selected, otherwise expands all

http://onlinelibrarystatic.wiley.com/marvin/help/formats/abbrevgroup-doc.html
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 groups in the molecule. 
Selecting Ungroup will remove all abbreviated groups from the molecule. The structures will remain, but will no
 longer be associated with their abbreviations. You will be unable to Expand/Contract these structures. 
To add or remove an Attachment Point, right-click on an atom within the group and select the S-group
 attachment icon.

Query features

The JChem Query Guide provides more detailed information on how to use JChem's query functionality. The
 following are some of the query building features available in MarvinSketch.

R-groups

MarvinSketch allows you to specify R-groups within your molecule. An R-group is a variable representing a user-
defined list of structures. These R-group definitions can be applied in R-group queries. 
 Using R-groups in a query structure can allow you to quickly search for a wide range of substructure hits using
 only a single query.

You can set or change the R-group label of a molecule node from the 'Atom' popup menu or by typing the
 corresponding R-group label on the keyboard. 
 To define the set of structures that are represented by an R-group label, select the structures you wish to
 include. Then, select the corresponding label from the Periodic Table or use one of type the R-group label on
 the keyboard. Set additional Occurrence, RestH and If-then conditions for the query in the R-logic dialog
 available from the Edit/Attributes menu.

Atom List

MarvinSketch allows you to add Atom List query atoms to your molecule. An Atom List is a user-defined list of
 elements included in a query structure, any of which will produce a hit if found in the target.

You can add Atom Lists to your molecule through the Periodic Table. To add an Atom List to the molecule,
 select the Atom List button, then select the elements you wish to include in the list. Move the mouse into the
 canvas and click to add a Query atom representing this atom list.

You can create the preferred Atom List without opening the Periodic Table. Move your mouse over the canvas
 and start typing the chemical symbols you wish to add to the Atom List. The entries of the Atom List must be
 separated by commas (e.g., au,pt,ag). You can use Backspace to delete errors. The items of the Atom List
 appear on the upper left corner of the canvas and concurrently at the tip of the pointer (e.g., L[Au,Pt,Ag]). Click
 on the query atom you want to add this Atom List.

You can move your mouse over the appropriate atom of a molecule or make selections on one or multiple atoms
 of the molecule before creating the Atom List as a different manner. When you start typing chemical symbols
 separated by commas, the Atom List adds directly to the selected atoms.

NOT List

A NOT List is a query atom that allows you to define a list of elements that should not be included in the target
 structure. If an atom within the query structure is set as a NOT List, then the atom in the same position within
 the target structure can be any atom that is not on the list to produce a hit. 
To add a NOT List to the molecule, select the Not List button in the Periodic Table, then select the elements
 you wish to include in the list. Move the mouse into the canvas and click to add a query atom representing this
 Not List.

You can create Not Lists without opening the Periodic Table. Move your mouse over an empty space of the
 canvas and type an exclamation mark first, then start typing the chemical symbols you wish to add to the Not
 List. The entries of the Not List must be separated by commas (e.g., !au,pt,ag). You can use Backspace to delete
 errors. The items of the Not List appear on the upper left corner of the canvas and concurrently at the tip of the

http://www.chemaxon.com/jchem/doc/user/queryindex.html
http://www.chemaxon.com/jchem/doc/user/query_special_types.html


MarvinSketch Help

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/sketch-chem.html[11/4/2015 9:58:30 PM]

 pointer (e.g., ~L![Au,Pt,Ag]). Click on the query atom you want to add this Not List.

You can move your mouse over the appropriate atom of a molecule or make selections on one or multiple atoms
 of the molecule before creating the Not List as a different manner. Start with an exclamation mark and then type
 the chemical symbols separated by commas. The Not List adds directly to the selected atoms.

Generic Query Atoms

MarvinSketch supports the following types of Generic Query Atoms:

Name Description

A Any (any atom except hydrogen)

AH Any atom, including hydrogen

Q Hetero (any atom except hydrogen and carbon)

QH Hetero atom or hydrogen (any atom except carbon)

M Metal (contains alkali metals, alkaline earth metals, transition metals, actinides,
 lanthanides, poor(basic) metals, Ge, Sb and Po)

MH Metal or hydrogen

X Halogen (F,Cl,Br or I)

XH Halogen or hydrogen

Generic Query Atoms can be added to a query structure to include a wide range of elements. For a more detailed
 description of this please see the Query Guide.

To add a Generic Query Atom to the molecule, select one of the Generic Query Atom types from the Periodic
 Table and place it on the canvas with the mouse.

Atom Properties

Atom properties: various atom properties can be added to an atom in the drawing. The property key and the
 value is free to set by the user in the Edit properties dialog. First select an atom in the molecule, right-click and
 choose Edit properties... In the dialog box double-click the blue text field and type the property key then the
 value. Press Enter after each entry. The visibility of the atom properties can be switched on and off: go to View >
 Advanced > Atom properties.

Query properties: You can define the chemical neighborhood for an atom within a query structure.
 MarvinSketch allows you to set properties, such as hydrogen count, valence count, ring size, and aromaticity,
 which must be matched by the corresponding atom in the target structure to produce a hit.

First select one or more atoms then go to the Advanced tab of Periodic Table to add the propertiy to every
 selected atom.
First go to the Periodic Table then click individual atoms to increase/decrease property value.
Each query property can be drawn typing .<query property name> (e.g., .H2) while the mouse pointer is
 over the relevant atom or there is active selection containing atoms.

The list of available query properties can be found here.

Attached data

Information may be attached to atoms and brackets. This data may include search restrictions in queries. Find
 details of query usage in JChem's Query Guide.

Adding data

http://www.chemaxon.com/jchem/doc/user/query_features.html
http://www.chemaxon.com/jchem/doc/user/query_features.html
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Select an atom or group bracket, right-click and choose Add > Data... or Data..., respectively, from the
 context menu. Fill the appropriate fields in the dialog and click OK. The attached data can be edited any
 time: right-click the atom, the bracket or the data label and choose Edit Data... from the context menu.

Context field

Atom - the data will be attached independently to all atoms in the selection.
Bond - the data will be attached independently to all bonds in the selection.
Single Bond - the data will be attached independently to all single bonds in the selection.
Double Bond - the data will be attached independently to all double bonds in the selection.
Fragment - the data will be attached independently to all disconnected fragments that are completely or
 partially contained by the selection.
Selection - the data will be attached to the whole selection.

The number and name of the selectable contexts may vary in different configurations.

URLs as attached data

 Values starting with www and including at least 2 full stops are handled as web page links (no spaces
 allowed). The format <scheme>://<authority><path>?<query>#<fragment> is also recognized. Double-
click or Ctrl-click on the link will open the webpage. Links are currently not underlined.

Customizability

The elements of the 'Name' and the 'Value' editable combo boxes can be customized by the administrator.
 The corresponding elements of the 'Value' combo box can be defined for each element in the 'Name'
 combo box list, just as the corresponding 'Name' combo box contents for each element in the context
 combo box.
Details on the customization process.

Label placement

The labels can be positioned in 3 ways: absolute, relative or next to objects. Absolute means a stationary
 label, which can be moved independently from the structure. If the structure is moved, the label does not
 change its place. Relative labels always move with the same xy coordinates as the object. Labels next to
 objects can not be moved separately.

Mouseover highlights all details of the attached data.

Return to Top

 Copyright © 1998-2013 ChemAxon Ltd.

http://www.chemaxon.com/marvin

https://www.chemaxon.com/marvin/help/sketch/sketch-attachDataConfig.html
http://www.chemaxon.com/
http://www.chemaxon.com/marvin
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Stereochemistry

Scientific Background

Tetrahedral Stereocenters

The dimension of a molecule can be interpreted topologically, based on the connections of the consisting atoms,
 or spatially, based on the Cartesian coordinates of them. In this section the notion of dimension is used in spatial
 sense.

Molecules with same connectivity but different spatial arrangement are called stereoisomers.

Stereoisomer types:

Enantiomers: Molecules that are non-superimposable, complete mirror images of each other.
  

Diastereomers: Stereoisomers that are not enantiomers.
  

Special cases

Non-carbon tetrahedral stereocenters
Ammonium and phosphonium salts 

Amine oxides and phosphanones 

Phosphanes
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 In this case the lone pair of phosphorus atom is considered as the fourth ligand.
Phosphates and phosphonates 

Sulfoxides 

An atom in a ring is a tetrahedral center, if
the central atom has 2 different kinds of ligands outside the ring, and
the graph invariant of the ring is not the same in the two sides of the central atom, or
the graph invariant of the ring is the same in the two sides of the central atom, but

the ring contains even numbers of atoms (including the parity central atom), or
there is an atom with nonzero parity in the opposite side of the ring: 

Nitrogen atoms in a ring is tetrahedral stereo center, if
they are bridgehead atoms. 

N is a tetrahedral stereo center in a 3 membered ring,
if the graph invariant of the ring is not the same in the two sides of the nitrogen atom.

 Representation in 0D, 2D and 3D

0D: Stereoinformation is defined in 0 dimension by parity.
2D: Stereoinformation in 2 dimension is defined by wedge, hatch or wiggly bond types.
3D: Stereoinformation in 3 dimension is defined by the coordinates.

Cis-Trans stereoisomerism

http://onlinelibrarystatic.wiley.com/marvin/help/sci/parity.html
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In general, single bonds are rotatable, but double bonds are not. If the substituents on each side of the double
 bond are different, then two diastereomers of the molecule can be distinguished based on the orientation of the
 ligands. Two substituents located on the same side of the double bond are referred to as cis isomer, otherwise, if
 the two substituents are located on the opposite side it is referred to as trans isomer.

  

trans-1,2-dichloroethene cis-1,2-dichloroethene

Alicyclic compounds can also display cis-trans isomerism. In this case a single bond becomes non rotatable due to
 constrain of a cycle. However, in these cases we use tetrahedral stereochemistry.

  

(1R,2S)-1,2-dichlorocyclohexane (1S,2S)-1,2-
dichlorocyclohexane

E/Z notation

The cis/trans system for naming isomers is not effective if more than two different substituents are attached to
 the double bond. In this case, following the Cahn-Ingold-Prelog priority rules, a priority is assigned to each
 substituent on a double bond. If the two groups of higher priority are on opposite sides of the double bond (trans
 arrangement), then the E configuration is assigned to the bond. If the two groups of higher priority are on the
 same side of the double bond (cis arrangement), than the Z configuration is assigned to it.

  

2E-2,3-dichlorobut-2-ene 2Z-2,3-dichlorobut-2-ene

E/Z stereochemistry of the nitrogen atom is also supported:

 (E)-ethylidene(methyl)amine  (Z)-ethylidene(methyl)amine

Chirality

An atom in the molecule around which the ligands are arranged so that interchange of two ligands leads to
 stereoisomer is called stereocenter or stereogenic center. Chirality appears in stereoisomerism which is due to
 tetrahedral stereogenic centers. These centers can have point chirality. The ligands of the chiral center are

http://en.wikipedia.org/wiki/Cahn_Ingold_Prelog_priority_rules
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 assigned a priority based on the Cahn-Ingold-Prelog priority rules. Each chiral center is then labeled by R or S
 based on the orientation of the assigned numbers. The center is oriented so that the lowest-priority is pointed
 away from the viewer. If the priority of the remaining three substituents decreases clockwise, it is labeled R,
 otherwise, if it decreases counter clockwise, it is S.

  

R-bromo(chloro)iodomethane S-bromo(chloro)iodomethane

Cahn-Ingold-Prelog priority rules

Explained in Wikipedia: Cahn-Ingold-Prelog priority rules.

 Atrop stereocenters

 Hindered rotation around single bonds where the steric strain barrier to rotation is high enough to allow the
 isolation of the conformers resulting in atrop stereoisomerism.

 Axial stereocenters

 If two stereoactive atoms (atoms with at least three different ligands) are connected by an even numbered chain
 of rigid parts then axial stereo information can be defined on the ligands of the stereactive atoms. These ligands
 are the ones which are not in the chain of the rigid part.

 The following substructures are considered as rigid parts:

double bonds,
four- or six-membered ring,
odd membered rings having lower than eight members, connected to each other directly or connected by
 intermediate four or six membered rings. Connection of two rings means that they share exactly one
 common bond (all rings are fused). The intermediate even membered rings have to connect to other rings
 by bonds on the opposite sides.

http://en.wikipedia.org/wiki/Cahn_Ingold_Prelog_priority_rules
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 You may find more information concerning stereochemistry in the query guide or in the developer guide.

 Stereo Specification

 Basic stereo specification

Chirality

 The relative position of ligands on a chiral atom is marked with wedge bonds: up (solid), down (hatched),
 up or down (wiggly). Having wedge bonds at chiral atoms with the chiral flag on the entire structure
 implies that a single isomer is present. The absolute configuration (R or S) is known for all chiral centers
 that are marked with wedge bonds.

 Non-stereo bond to atom at stereogenic centers implies that no information is known about the
 configuration of a stereogenic center. It could be either of two stereoisomers, or a mixture of the two.

The existence of wedge bonds at chiral atoms without chiral flag on the entire structure has two meanings
 depending on the file format used.
MDL file types (mol, sdf ...): The structure is a racemic mixture of the two enantiomers.
Daylight file types (smiles, smarts): Wedges mean absolute stereo configuration, the structure represents a
 single enantiomer.

Cis-Trans isomerism

 The positions of the double bond ligands already define the stereo configuration of the double bond (cis or
 trans). Special query double bond types allow us to specify cis or trans, not trans or not cis isomers.

Enhanced stereo specification

 Works in MDL molecule formats: mol, rgf, sdf, rxn etc... and in ChemAxon Extended SMILES format: cxsmiles.

 Enhanced stereochemical representation introduces three types of identifiers that can be attached to a
 stereogenic center. A stereochemical group label is composed from an identifier and a group number. Each
 stereogenic center marked with wedge bonds belongs to one (and only one) stereochemical group. Grouping
 allows us to specify relative relationships among stereogenic centers.

Stereochemical group types:

ABS 
 Stereogenic center where the absolute configuration is known.
OR 
 Stereogenic center where the relative configuration is known, but the absolute configuration is
 not known. The structure represents one stereoisomer that is either the structure as drawn
 (R,S) OR the epimer in which the stereogenic centers have the opposite configuration (S,R).
AND 
 Mixture of stereoisomers. It can be a pair of enantiomers or all the diastereomers.

How to specify and view R/S configuration

1. Draw a chiral molecule.

https://www.chemaxon.com/jchem/doc/user/query_stereochemistry.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/core/stereochemistry_intro.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html#mol
http://onlinelibrarystatic.wiley.com/marvin/help/formats/smiles-doc.html


Stereo specification in Marvin

http://onlinelibrarystatic.wiley.com/marvin/help/sci/stereo-doc.html[11/4/2015 9:58:38 PM]

2. Click on (select) the asymmetric carbon atom that you want to configure as S or R. Right-click onto the
 carbon atom pops up the Atom menu. Choose Stereo > R/S and the appropriate configuration.

3. The relevant bonds will change automatically according to the proper R or S configuration.

4. To display the stereo label on the asymmetric carbon atom, select View menu > Stereo > R/S Labels >
 All.
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5. The configuration of the asymmetric carbon atom presents in parentheses as follows.

6. If you want to remove the stereo label from the the asymmetric carbon atom, choose View menu >
 Stereo > R/S Labels > None.

7. If you want to delete stereo representation, right-click on the asymmetric carbon atom and choose Atom
 menu > Stereo > R/S > Off.

References

[1]  http://accelrys.com/products/informatics/cheminformatics/ctfile-formats/no-
fee.php

http://accelrys.com/products/informatics/cheminformatics/ctfile-formats/no-fee.php
http://accelrys.com/products/informatics/cheminformatics/ctfile-formats/no-fee.php
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Calculator Plugins

Introduction

Calculator Plugins are modules of ChemAxon's Marvin and JChem cheminformatics platforms which calculate
 physico-chemical properties from chemical structures. Calculator Plugins currently cover a wide range of life-
science-related properties.

Short usage guide

 They are available directly from Marvin, Instant JChem and Reactor applications, and also from command line,
 API, or via ChemAxon's Chemical Terms language. The calculations can be performed in single or batch mode.

The available calculator plugins are located in the Calculations menu in the graphical user interface of
 MarvinSketch, and in the Tools menu in MarvinView.

cxcalc is the command line tool of the Calculator Plugin. Batch processing is available using cxcalc (see the
 list of calculations accessible from cxcalc).

Calculators are used in the Chemical Terms language to calculate combinations of properties (like
 Lipinski's rule of 5) in an easy way. Learn more about it in the Chemical Terms section.

Plugin calculations can be used for filtering results of database searches in JChem Base, Instant JChem
 and JChem Cartridge.

Define smart reaction rules using plugin calculations in Reactor (ChemAxon's virtual reaction processing
 tool).

Plugin calculations can be integrated easily into any Java application. For more information on using
 calculator plugin Java API, please see our chemaxon.marvin.calculation package.

Some of the calculators (such as logP, pKa and Predictor ) can be trained with the user's data via cxtrain.

Third-party calculations can be integrated easily into MarvinSketch via the Services module of the
 graphical user interface. For more information on integrating third-party calculations, see our Setting
 Services page.

List of Calculator Plugins

Elemental Analysis Plugin
Naming Plugin
Protonation

pKa Plugin [training]
Major Microspecies Plugin
Isoelectric Point Plugin

Partitioning
logP Plugin [training]
logD Plugin [training]

Charge
Charge Plugin
Polarizability Plugin
Orbital Electronegativity Plugin
Dipole Moment Calculation Plugin

NMR
CNMR Prediction
HNMR Prediction
NMR Spectrum Viewer

http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/cxcalc-calculations.html
http://onlinelibrarystatic.wiley.com/marvin/help/chemicalterms/ChemicalTerms.html
http://www.chemaxon.com/marvin/help/developer/beans/api/index.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/predictor_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/cxtrain.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/setting_services.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/setting_services.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
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Isomers
Tautomers Plugin
Stereoisomers Plugin

Conformation
Conformers Plugin
Molecular Dynamics Plugin
3D Alignment Plugin

Geometry
Topology Analysis Plugin
Geometry Plugin
Polar Surface Area Plugin (2D)
Molecular Surface Area Plugin (3D)

Markush Enumeration Plugin
Predictor Plugin
Other

Hydrogen Bond Donor-Acceptor Plugin
Huckel Analysis Plugin
Refractivity Plugin
Resonance Plugin
Structural Frameworks Plugin

Test Results
References

Back to Marvin User's Guide
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http://onlinelibrarystatic.wiley.com/marvin/help/calculations/predictor.html
http://onlinelibrarystatic.wiley.com/marvin/help/index.html
http://www.chemaxon.com/
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Elemental Analysis Plugin

Basic molecular values related to the elemental composition of the molecule are calculated by the Elemental Analysis plugin.

In the Elemental Analysis Options panel you can check different properties:

Type

Mass: average molecular mass calculated from the standard atomic weights 1.

Exact mass: monoisotopic mass calculated from the weights 2 of the most abundant natural isotopes of the elements.

Formula: chemical formula of the molecule according to the Hill system 3: the number of carbon atoms is indicated first, the number of hydrogen
 atoms next, and then the number of all other chemical elements subsequently, in alphabetical order. Isotopes (like Deuterium and Tritium) are
 not listed separately but counted together (e.g., deuterium and tritium atoms are counted as hydrogens). When the formula contains no carbon,
 all the elements, including hydrogen, are listed alphabetically. If the molecule contains an SRU or Repeating Unit S-group, it will be taken into
 account and Polymer Formula will be generated. 
Note: For polymer structures, mass, composition, and atom count calculations are not available and will return NaN, N/A, and -1, respectively.
Isotope formula: chemical formula of the molecule listing isotopes separately according to the Hill system.
Dot-disconnected formula: chemical formula of the molecule(s) separating fragment formulas by dots (e.g. salts, counterions, solvent
 molecules etc. are present).
Dot-disconnected isotope formula: chemical formula of the molecule separating fragment formulas by dots and listing isotopes separately.
Composition: elemental composition given in weight percentage (w/w %) calculated from the atomic masses.
Isotope composition: elemental composition listing isotopes separately (w/w %).
Atom count: number of all atoms in the molecule.

The examples shown below illustrating the difference between formula types:

Multifragment Molecule with isotopes SRU Polymer S-group Polymer defined as Repeating units S-group

Use D/T symbols for deuterium/Tritium: if unchecked (default), isotopes of hydrogen are displayed in formulas as 2H and 3H, if checked, D and T
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 symbols are used.
Single fragment mode: if unchecked (default), the calculation handles unlinked molecules together (e.g. salt molecules), summing up the masses of
 each component, if checked, the results are displayed in a scroll window.

The results are shown in a new window:

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from MarvinView.

References

Atom weights: M. E. Wieser, "Atomic weights of the elements 2005 (IUPAC Technical Report)" Pure Appl. Chem., Vol. 78, No. 11, pp. 2051-2066, 2006;
 doi
Isotope weights: G.Audi and A.H.Wapstra, "The 1995 update to the atomic mass evaluation" Nuclear Physics A595 vol. 4, pp. 409-480, 1995; doi
The Hill system: E. A. Hill, "On A System Of Indexing Chemical Literature; Adopted By The Classification Division Of The U. S. Patent Office". J. Am.
 Chem. Soc., 22(8), pp. 478-494, 1900; doi

http://dx.doi.org/10.1351/pac200678112051
http://dx.doi.org/10.1016/0375-9474(95)00445-9
http://dx.doi.org/10.1021/ja02046a005
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Name generator

 Since version 4.1.7, Marvin contains a name generator for the evaluation of the IUPAC name or traditional name
 of any compound.

 When possible, the generated name conforms to the IUPAC Provisional Recommendations for the Nomenclature
 of Organic Chemistry published in 2004. However, we do not claim full conformance with that document. Our
 current goal is to generate chemically correct names for as many cases as possible.

 Importing IUPAC names is available from version 5.1.

You can generate either the "Traditional Name" or the "Preferred IUPAC Name" of the molecules; you can change
 between these options in the Naming Options panel. By default, the "Preferred IUPAC Name" option is set. If
 the traditional name is requested but cannot be generated, the preferred IUPAC Name will be generated instead.

By default, molecules are handled separately if more than one molecule are drawn in the sketcher. However,
 sometimes a single molecule consists of more fragments (e.g. salt molecules), where the fragments should be
 treated as one molecule. This can be reached by switching off the "Single fragment mode" option in the Naming
 Options panel.

 The snapshot below shows a molecule taken from the IUPAC specification, with its name computed by Marvin.

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu
 when right-clicking on it.

http://www.iupac.org/reports/provisional/abstract04/favre_310305.html
http://www.iupac.org/reports/provisional/abstract04/favre_310305.html
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 The next snapshot below shows a functionality that is available from version 5.0: the IUPAC name can be
 inserted into the sketch, and it changes with the structure dynamically. This functionality is available from the
 Structure menu by selecting the Structure to Name > Place IUPAC Name option.

Features

 Supported nomenclatures include:

Chains, Monocycles
Retained/traditional names for ring systems with and without heteroatoms
Spiro ring systems
All cases of von Baeyer nomenclature for bridged ring systems
Fused ring systems (linear fused ring systems are named using the fused nomenclature, others using von
 Baeyer nomenclature)
Ethers
Common characteristic groups
Ionic compounds
Compounds with one radical
Unlimited number of atoms and rings
All atom types
Substitutive nomenclature
Isotopes
Stereochemistry

Current limitations

Molecules containing multiple radicals (e.g. ethane-1,2-diyl) are not supported yet.

Amino-acids and peptides are supported only when the amino-acids are represented as groups.
Molecules containing coordinate bond are not supported.
Some aspects of nomenclature are only partially implemented, in particular complex cases of fused systems
 and multiplicative nomenclature. In those cases, a less straightforward but chemically correct name will be
 generated.
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Usage

Individual molecules

 You can name molecules by using the Naming menu entry of Tools menu in MarvinView, or Structure >
 Structure to Name > Generate Name in MarvinSketch.

 In MarvinSketch, the name can be added to the canvas by using the Structure to Name > Place IUPAC Name
 entry in the Structure menu. The name will be displayed below the molecule, and updated in real-time when
 the molecule is modified.

Batch naming

 Naming of a large number of molecules contained in a file can be achieved in two ways: with MarvinView, and on
 the command line, with molconvert. In both cases, all formats supported by Marvin are acceptable as input.

 With MarvinView, open the file containing the structures to be names. Then select the menu File/Save As, and
 choose "IUPAC Name files" in the "Files of type" drop-down box. Choose a name for the file, and click on the
 Save button. The file will contain the names of the structures, one per line.

 Alternatively, on the command line, you can use the following command:

 molconvert name inputs.mol -o names.txt

 The file names.txt will contain the names of the molecules in the input file, with one name per line.

 It is possible to use a format option to chose a nomenclature style:

i (default) uses the IUPAC rules for preferred names;

t uses a more traditional style.

 For instance, to generate traditional names, use the following:

 molconvert name:t inputs.mol -o names.txt

 Generate all common names for a structure:

molconvert "name:common,all" -s tylenol

 Generate the most popular common name for a structure (It fails if none is known.):

molconvert name:common -s viagra

 Adding names as an additional field to a SDfile can be achieved with the cxcalc tool.

 cxcalc -S name input.sdf -o named.sdf

API

 For information about how names can be generated from Java programs, see the developer documentation.

References

IUPAC Provisional Recommendations for the Nomenclature of Organic Chemistry

http://onlinelibrarystatic.wiley.com/marvin/help/applications/mview.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/mview.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/molconvert.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/mol-csmol-doc.html#mol-formats
http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/s2n.html
http://www.iupac.org/reports/provisional/abstract04/favre_310305.html
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Protonation

pKa Plugin 

Most molecules contain some specific functional groups likely to lose or gain proton under specific circumstances. Each
 ionization equilibrium between the protonated and deprotonated forms of the molecule can be described with a constant
 value called pKa. The pKa plugin calculates the pKa values of all proton gaining or losing atoms on the basis of the partial

 charge distribution. 
Learn more about how the plugin calculates pKa.

We introduced the trainable pKa calculation from version 5.2! You can define a file with experimental data, and use

 its values for the correction of calculations.

The pKa options panel offers different parameters to set:

General Options

Mode: micro, macro: micro and macro acidic dissociation constants. Read details.
Acid/base prefix:

static: submitted ionic forms are converted to their neutral forms (adding or removing protons) and their pKa
 is calculated.
dynamic: the pKa of ionic forms are calculated, not their conjugated acids or bases.

Min basic pKa: widens the calculation range because weak bases will have lower pKa values than the default -10.

Max acidic pKa: widens the calculation range because weak acids will have higher pKa values than the default 20.

Temperature: setting the temperature in Kelvin.
Correction library

Use correction library: check this box to use a file with experimental data for the calculation. See the
 detailed guide for training data setup.

Consider tautomerization: checking this option, the most feasible tautomer and resonance structures are
 considered as subject of the pKa calculation.
Show distribution chart: checking this box, you will have microspecies/macrospecies distribution as function of
 pH calculated and displayed. Go to Display Options tab for further settings of the distribution chart. Unchecking this
 box, only the pKa of the drawn molecule will be calculated.

Display Options

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pKa.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pKa.html#MultiProtic
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
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Decimal places: setting the number of decimal places with which the result value is given.
Distribution chart: you can set the range of displaying the microspecies distribution diagram.

pH lower limit
pH upper limit
pH step size

Show log[%] - pH distribution: checking this box, the common logarithm of microspecies/macrospecies
 distribution is calculated and displayed as function of pH.

log[%] - pH distribution lower limit: you can set the lower value of the Y axis ranging from -35 to zero.

Results are shown in a separate window. When checking the Show microspecies distribution box, this window appears (for
 the explanation about the red&blue color representation of the pKa values next to the protonable groups read this

 document):

The chart shows the microspecies distribution, or the common logarithm of microspecies distribution curves vs. pH. The
 microspecies images are shown in the legend. When clicking on an image, the corresponding microspecies molecule is
 displayed in the upper-left viewer. (The viewer can be detached from the chart panel by double clicking in it, or else by
 selecting Open Viewer from the View menu.) The original molecule with the pKa values is shown when clicking on the

 chart outside of the legend image areas, or else when selecting pKa Values from the View menu.

Note: If there are 8 or less ionizable atoms in the molecule, then microspecies distribution is displayed on the chart,
 otherwise macrospecies distribution is shown. Images of microspecies are displayed only on the microspecies distribution
 chart; on macrospecies distribution chart the formal charges of the macrospecies are shown.

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from
 MarvinView.

When moving the mouse over one of the microspecies images, the corresponding (pH : % of the microspecies)
 coordinates appear on the curves.

Calculation with the option 'Take major tautomeric form' gives same values for different tautomers.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/redbluepka.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/redbluepka.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/images/pKa.png
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/images/pKa_2.png
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Major Microspecies Plugin

Determines the major protonation form at a specified pH.

The pH can be set in the Major Microspecies Options panel, the default pH is 7.4.

Take major tautomeric form: if tautomeric forms are more likely to occur, tha major tautomer is used to
 calculate the major microspecies.

The result is shown in a separate window, indicated the pH value and the structure in a MarvinView field.

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from
 MarvinView.



Protonation

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/protonation.html[11/4/2015 9:58:47 PM]

Isoelectric Point Plugin

Net charge of an ionizable molecule is zero at a certain pH. This pH is called the isoelectric point, also referred to as pI.
 Isoelectric point plugin calculates gross charge distribution of a molecule as function of pH.

The Isoelectric Point Options panel contains the pH, and the option to switch off the charge distribution chart of the
 charge of the molecule vs. pH:

The result is shown in a separate window, containing the molecule structure at the pI and the value of pI. If the Show
 charge distribution checkbox was checked, the charge vs. pH curve is displayed. When moving the mouse over the dots
 in the curve, the coordinates (pH : charge) appear.

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from
 MarvinView.
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Partitioning

logP Plugin 

The logP plugin calculates the octanol/water partition coefficient, which is used in QSAR analysis and rational drug design
 as a measure of molecular hydrophobicity. The calculation method is based on the publication of Viswanadhan et al. (see
 Ref.1.) The logP value of a molecule is composed of the increment values of its atoms. The algorithm described in the
 paper was modified at several points. Many atomic types were redefined to accommodate electron delocalization.
 Contributions of ionic forms were added. The logP value of zwitterions are calculated from the logD value at the
 isoelectric point. The effect of hydrogen bonds on logP is considered if there is a chance to form a six membered ring
 between suitable donor and acceptor atoms. New atom types were introduced especially for sulfur, carbon, nitrogen, and
 metal atoms.

Learn more about how the plugin calculates logP and how a user defined set is used in the calculations.

We introduced the trainable logP calculation in version 5.1.3.
 What does trainability mean? With this new feature you can teach our program, how it should calculate the logP values of
 structures in your compound library. Experimental data and the molecules are saved into a file which is used in the
 calculation if user defined method is selected.

Read how you can benefit from the user defined method used in the calculations. Technical details about setting up.

Different calculation parameters can be set in the logP Options panel:

General Options

Method
VG: the calculation method derived from Reference 1. is applied (VG stands for Viswanadhan and Ghose, first
 authors of the cited paper).
KLOP: logP data from Klopman's paper is applied.

PHYSPROP: logP data from PHYSPROP© database is used.
User defined: if a training set of structures and corresponding experimental logP values is created by the
 user, and stored in the appropriate format, it can be used as a database for related molecules' logP
 calculations. See this document about creating such sets.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logPlogD.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logPlogD.html#methods
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logPlogD.html#methods
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
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Weighted: default setting. The use of methods can be melted by the user, selecting this method turns the
 Method weights section active.

Training ID: if the User defined or the Weighted method is selected, this dropdown list becomes active. All
 created training sets are listed here. Choose the one to apply for the calculation. Read more on creating a training
 set.
Method weights: you can set the proportion of the methods used in the calculations. Acitve only in Weighted
 method.
Electrolyte concentration

Cl- concentration: can be set between 0.1 and 0.25 mol/L.

Na+ K+ concentration: can be set between 0.1 and 0.25 mol/L.
Take major tautomeric form: the logP of the major tautomer will be calcutated.

Display Options

Precision: setting the number of decimal places with which the result value is given.
Show value

increments: calculates the increments given by the atoms.
logP: calculates the value of logP
Increments of hydrogens: displays the increments given by hydrogens (in brackets).

Display in MarvinSpace: the result window opens as 3D MarvinSpace viewer. If unchecked, the results will be
 shown on a 2D picture.

Notes to Method and Method Weights: These logP methods were developed by us based partly on the atom types
 given in Reference 1.. The three abbrevations only refer to the appropiate training logP data set according to the
 references 1, 2 and 3. Weighted method is a combination of the above three logP calclulations. The three methods are
 equally weighted (1/3) by the default setting. The calculated logP in this way will be the arithmetic average of the three
 methods. The weighted method usually provides more reliable logP value than any one of the three separate methods.

The result of the calculation appears in a new window, either in a MarvinView (2D) window or a MarvinSpace (3D)
 window:

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
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The result window shows the logP increments for each atom. The numbers in brackets refer to the logP increment sums of
 implicit H atoms, and displayed only if the "Increment of Hs" option is switched on in the logP Options panel.

logD Plugin

Compounds having ionizable groups exist in solution as a mixture of different ionic forms. The ionization of those groups,
 thus the ratio of the ionic forms depends on the pH. Since logP describes the hydrophobicity of one form only, the
 apparent logP value can be different. The octanol-water distribution coefficient, logD represents the compounds at any
 pH value (see Ref. 3.).
Learn more about how the plugin calculates logD.

Different calculation parameters can be set in the logD Options panel:

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logPlogD.html
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General Options

logP Method
VG: the calculation method derived from Reference 1. is applied (VG stands for Viswanadhan and Ghose, first
 authors of the cited paper).
KLOP: logP data from Klopman's paper is applied.

PHYSPROP: logP data from PHYSPROP© database is used.
User defined: if a training set of structures and corresponding experimental logP values is created by the
 user, and stored in the appropriate format, it can be used as a database for related molecules' logP
 calculations. See this document about creating such sets.
Weighted: default setting. The use of methods can be melted by the user, selecting this method turns the
 Method weights section active.

LogP Training ID: if the User defined or the Weighted method is selected, this dropdown list becomes active.
 All created training sets are listed here. Choose the one to apply for the calculation. Read more on creating a
 training set.
Method weights: you can set the proportion of the methods used in the calculations. Acitve only in Weighted
 method.
Electrolyte concentration

Cl- concentration: can be set between 0.1 and 0.25 mol/L.

Na+ K+ concentration: can be set between 0.1 and 0.25 mol/L.
pKa correction library: the custom pKa training for the compounds may be used. First, create a training set for
 your compunds, which then will appear in the dropdown list. If the option is checked, this list becomes active. Read
 more on creating a training set.
Consider tautomerization: in case of tautomer structures, all dominant tautomers at given pH are taken into
 account during the logD calculation.

Display Options

Precision: setting the number of decimal places with which the result value is given.
Chart: pH limits, pH step size: defines the pH window in which the logD is calculated, with pH values starting

http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/logp_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/pka_training.html
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 from the lower limit incremented by the step size, the results given in table format and a chart.
Reference pH values: the logD at the given reference pH values are calculated, both pH and logD values with an
 accuracy of the decimal places value set.

The chart shows the logD(pH) curves for each molecule drawn in the sketcher. The molecule images are shown in the
 legend. When clicking on an image, the corresponding molecule is displayed in the upper-left viewer. The viewer can be
 detached from the chart panel by double clicking in it, or else by selecting Open Viewer from the View menu. The
 reference logD values originally shown can be restored by either clicking on the chart outside of the legend image areas,
 or else by selecting logD at reference pHs from the View menu.

References

1. Viswanadhan, V. N.; Ghose, A. K.; Revankar, G. R.; Robins, R. K., J. Chem. Inf. Comput. Sci., 1989, 29, 163-172;
 doi
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3. PHYSPROP© database
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Charge

Charge Plugin

The partial charge distribution determines many physico-chemical properties of a molecule, such as ionization constants,
 reactivity and pharmacophore pattern. Use Charge plugin to compute the partial charge value of each atom. Total charge
 is calculated from sigma and pi charge components, and any of these three charge values can be displayed. Learn more
 about how the plugin calculates the partial charge.

In the Charge Options panel you can set the following:

Decimal places: setting the number of decimal places with which the result value is given.
Type: setting type of the calculus: total charge, sigma charge or pi charge components.
Charges of implicit hydrogens: gives you in detail the increments of the charge by the implicit hydrogens.
Take resonant structures: the average of the charge of the resonant srtuctures will be calculated.
Take major microspecies/ at pH: the charge of the major microspecies present at the given pH.
Display in MarvinSpace: the result window opens as 3D MarvinSpace viewer. If unchecked, the results will be
 shown on a 2D picture.

The results are shown in a new window, if more molecules present on the sketching canvas (in MarvinSketch) then all
 molecules appear in one single field in 2D:

Charge is expressed in atomic unit [e].The numbers in brackets refer to the charge sums of implicit hydrogen atoms, and
 displayed only if the "Increment of Hs" option is switched on in the Charge Options panel.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/charge.html
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If the Display in MarvinSpace checkbox was checked, the results appear in seperate fields, but operations (zooming,
 rotating etc.) are linked:

Polarization Plugin

The electric field generated by partial charges of a molecule spread through intermolecular cavities and the solvent. The
 induced partial charge (induced dipole) has a tendency to diminish the external electric field. This phenomenon is called
 polarizability. The more stable the ionized site is the more its vicinity is polarizable. This is why atomic polarizability is an
 important factor in the determination of pKa and why it is considered in our pKa calculation plugin. Atomic polarizability is

 altered by partial charges of atoms. We use two methods to calculate polarizability: one of the calculations is based on
 Miller's and Savchik's atomic parameters, while the other method is based on Thole's parameters.

In the Polarizability Options panel you can set the following:
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Decimal places: setting the number of decimal places with which the result value is given.
Type: setting type of the calculus: molecular or atomic polarizability components.
Take 3D geometry (Thole): calculates the polarization tensor values.
Take major microspecies: the polarizability of major microspecies at the given pH is calculated.

The result appears in a new window, displaying on each atom its polarizability value (dimension: Å3) (2D view and 3D
 view):

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from
 MarvinView.

Orbital Electronegativity Plugin

Partial charge distribution of the molecule is governed by the orbital electronegativity of the atoms contained in the
 molecule.
Learn more about how the plugin calculates orbital electronegativity.

In the Orbital Electronegativity Options panel you can set the following:

Decimal places: setting the number of decimal places with which the result value is given.
Type: setting type of the calculus: sigma charge or pi electronegativity components.
Take resonant structures: the average of the charge of the resonant srtuctures will be calculated.
Take major microspecies: the electronegativity of major microspecies at the given pH is calculated.

The result appears in a new window, displaying on each atom (except of hydrogens) its EN value:

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/charge.html#Concept of Orbital Electronegativity
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 The structure field offers a context menu from MarvinView.

Dipole Moment Calculation Plugin

Dipole moment (μ) is the measure of net molecular polarity, and describes the charge separation in a molecule, where
 electron density is shared unequally between atoms. 
Dipole Moment Calculation presents the overall dipole moment of a molecule as a vector expressed in the principal axis
 frame. The dipole moment information is deduced about the molecular geometry and partial charges. The unit of the
 dipole moment is Debye (D).

References

Miller, K. J.; Savchik, J. A., J. Am. Chem. Soc., 1979, 101, 7206-7213; doi
Jensen, L.; Åstrand, P.-O.; Osted, A.; Kongsted, J.; Mikkelsen, K.V. J. Chem. Phys., 2002, 116, 4001-4010; doi

http://dx.doi.org/10.1021/ja00518a014
http://dx.doi.org/10.1063/1.1433747
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Prediction of nuclear magnetic resonance (NMR) spectra

Version 6.1.7

 Fast and accurate prediction of 13C and 1H NMR spectra from the molecular structure plays an important role in
 structure validation and elucidation of molecules. The NMR predictor application is able to predict NMR spectra
 for standard organic molecules containing the most frequent atoms (H, C, N, O, F, Cl, Br, I, P, S, Si, Se, B, Sn,
 Ge, Te, As).
 Chemical shifts are estimated by a mixed HOSE and linear model based on a topological description scheme and

 are in relation to the chemical shift of tetramethylsilane (δ(TMS)=0 ppm). 13C and 1H chemical shift training data
 were retrieved from the NMRShift Database. Read more about NMR chemical shift model description.

Basic features

Prediction of 13C and 1H NMR chemical shifts;
Spin-spin couplings are taken into account according to the first order approximation;
H-H, H-F and C-F couplings are considered during NMR spectrum calculation;
Diastereotopic protons are differentiated;
NMR Spectrum Viewer is able to display NMR spectra in JCAMP-DX format.

The NMR Predictor graphical user interface incorporates the following features:

Export predicted spectrum to molfile;
Export predicted spectrum to JCAMP-DX file and/or import JCAMP-DX (*.jdx) reference spectrum;
Create PDF file as report of your prediction, containing molecule structure, predicted spectrum, and
 related tables;
Detached Copy to clipboard action for all predictor panels and tables is available;
Update molecule from MarvinSketch;
Toggle between decoupled and coupled NMR spectrum;

 Toggle between explicit and implicit hydrogen display;
Select NMR prediction frequency from a predetermined list;
Add common organic solvent peaks to predicted spectrum;
Add tautomer peaks to predicted spectrum;
Restore default NMR predictor settings, e.g., prediction frequency, display, and view options;
Display realistic or line NMR spectra;
Add atom indices or chemical shift values to signals as spectrum labels;
Display spectrum scale in ppm or Hz units;
Show integral curve to assign value to NMR spectrum signals;
Display legend on spectrum display panel.
Show local maximum values of reference spectrum;
Personalize the color management of NMR Predictor;
Set chart color uniquely;
When you click on a peak on spectrum display panel or on an atom on molecule preview panel, selection
 will move to and zoom in on the selected signal;
Choose multiplet selection mode: individual selection in case of overlapping multiplets is available;
Use various modes of zoom in on spectrum.
Find spectrum and molecule structure related information in Atom, Multiplet, and Coupling tables.
Show atom indices on molecule structure corresponding to the different multiplets;

 Atoms of the input molecule and multiplets of the NMR spectrum are linked together: upon selection of an atom
 the corresponding multiplet is highlighted and vice versa.

http://www.nmrshiftdb.org/
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmr_model.html
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 A single NMR prediction is allowed to contain more molecules.

 NMR predictor is integrated into MarvinSketch's Calculations menu, and contains the following three
 components to discover NMR spectra of molecules:

1. CNMR Prediction and
2. HNMR Prediction;
3. NMR Spectrum Viewer.

NMR Prediction is accessible via cxcalc as well (cxcalc nmr -h).

To improve our product, please send feedback to calculators-support@chemaxon.com.

Back to top

 
 Copyright© 2011-2012 ChemAxon Ltd.    All rights reserved.
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NMR Prediction - Tool to predict 13C and 1H Nuclear Magnetic Resonance spectra

Contents

NMR Prediction - 13C and 1H NMR predictor
NMR Prediction - Usage
NMR Prediction Window
NMR Prediction Menu

File Menu
Edit Menu
Options Menu
View Menu
Help Menu

NMR Prediction Toolbar
NMR Prediction Panels

Molecule View Panel
Table of Chemical Shifts
NMR Spectrum Preview Panel
NMR Spectrum Display Panel

NMR Prediction Pop-up Menu
Examples

NMR main page

NMR Prediction - 13C and 1H NMR predictor

NMR Prediction is integrated into MarvinSketch and is able to predict carbon-13 and hydrogen-1 nuclear

 magnetic resonance (13C NMR and 1H NMR) spectra for standard organic molecules drawn in MarvinSketch.
 Chemical shifts are estimated by a mixed HOSE and linear model based on a topological description scheme, and
 they are relative to the chemical shift of tetramethylsilane (δ(TMS)=0 ppm). NMR Prediction provides the details
 of the predicted spectrum for browsing in separate panels.

NMR Prediction - Usage

You can predict 13C NMR and 1H NMR spectra of organic molecules drawn in MarvinSketch using the relevant
 prediction in Calculations menu.

1. Draw molecule in MarvinSketch.
2. Go to Calculations > NMR >

CNMR Prediction to discover the predicted 13C NMR spectrum of the molecule, or

HNMR Prediction to discover the predicted 1H NMR spectrum of the molecule.
3. The predicted spectrum will open in CNMR Prediction window if you chose CNMR Prediction, and in HNMR

 Prediction window if you chose HNMR Prediction, respectively.

Note: You can predict both spectra of the molecule in question which will open in separate windows.

NMR Prediction Window
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Both NMR Prediction windows consist of a menu, toolbar, and four panels. The name of the window is displayed at
 the top left corner. At the bottom left corner of the status bar general information on the NMR prediction is
 shown, i.e., nucleus, measurement unit, and prediction frequency; while at the bottom right corner the
 coordinates of mouse cursor position on the NMR Spectrum Display Panel are shown. We will discuss the menu

 elements and panels of both 13C and 1H NMR Prediction windows together. Differences will be marked by the
 appropriate icon ( : CNMR Prediction, : HNMR Prediction).

Back to top

NMR Prediction Menu

 The menu contains File, Edit, Options, View, and Help elements.

File menu

is to export spectra to various molfiles or JCAMP-DX file format, to import spectrum of JCAMP-DX file format and
 superimpose it on predicted NMR spectrum, to remove the imported spectrum, and to close NMR Prediction.

File >  Export to PDF...: Exports the molecule structure, predicted spectrum (full), and related tables to
 PDF file. You can select Keep view settings option on the export dialog panel to keep the actual view of
 spectrum during export to PDF.
File > Export to JCAMP-DX...: Exports predicted spectrum to JCAMP-DX (jdx) file format.
File > Export to Molfile...: Exports predicted spectrum to molfile. You can export the predicted spectrum
 data to SDF file format. The SDF file will contain structure and NMR Spectrum fields. The NMR Spectrum
 field contains the relevant atom number (AN), value of chemical shift (vδ), unit of chemical shift (uδ), and
 multiplicity of the signal (M) in the following format:

vδ1;uδ1,M1;AN1|vδ2;uδ2,M2;AN2|...|vδi;uδi,Mi;ANi.

File > Import from JCAMP-DX: Imports a spectrum in JCAMP-DX format. The imported spectrum will be
 superimposed on the predicted NMR spectrum.
File > Remove Imported Spectrum: Removes previously imported JCAMP-DX spectrum from NMR
 Spectrum Display Panel.
File > Exit: Closes NMR prediction window.
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Edit menu

is to copy specific panel to clipboard and to update the molecule from MarvinSketch. You can also apply the right-
click of your mouse on the proper panel to copy it to the clipboard.

Edit > Copy Spectrum: Copies the actual view of Spectrum Display Panel to the clipboard.
Edit > Copy Spectrum Preview: Copies the actual view of Spectrum Preview Panel to the clipboard.
Edit > Copy Molecule: Copies the actual view of Molecule View Panel to the clipboard.
Edit > Copy Multiplet Table: Copies Multiple Table to the clipboard.
Edit > Copy Atom Table: Copies Atom Table to the clipboard.
Edit > Copy Coupling Table: Copies Coupling Table to the clipboard.
Edit > Update Molecule: Updates molecule on Molecule View Panel and the whole prediction at the same
 time. You can switch back to MarvinSketch window without closing NMR predictor window; modify the
 molecule or draw a new molecule of which NMR spectrum you wish to predict. Switch back to NMR
 predictor window and either select Update Molecule or click on the Update button on Molecule View Panel
 to refresh NMR prediction.

Options menu

 is to select optional NMR prediction settings:

Options >  Spin-Spin Coupling: Prediction considers spin-spin coupling; the result is splitting of signals
 into multiplets according to the interaction between two nuclei.

Options >  Implicit Hydrogen Mode: Hydrogens are displayed only on hetero and terminal atoms.
Note If you switch off this mode:

all hydrogens will be visible on Molecule Panel;
atoms will be re-numbered on all corresponding panels;
coupling table will be filled in with relevant data.

Options > NMR Prediction Frequency: Sets the frequency of the NMR prediction. Select prediction
 frequency from the predetermined list. Prediction frequency influences the fine structure of the spectrum.
Options > Add Solvent Peaks...: Adds NMR signal(s) of selected common organic solvent(s) to the
 predicted spectrum. Select solvents from the predetermined list and click OK. The signal(s) of selected
 solvent(s) will be added to the predicted spectrum. When spectrum labels are displayed, you can see the
 name of the solvent attached to the corresponding signal. We used the NMR shift data of common organic
 solvents in CDCl3 collected by Gottlieb et al.

Options > Select Tautomers...: Opens a dialog where tautomers of the relevant molecule are displayed.
 The major tautomer is automatically selected. The values of tautomer distributions are obtained from
 MarvinSketch's Dominant tautomer distribution calculation. You can select altogether 8 tautomers to add
 their signal(s) to the predicted spectrum. Check the upper right check box of the appropriate tautomer.
 The distribution of each tautomer has to be set before proceeding. When spectrum labels are displayed,
 the corresponding signals of the active tautomer can be seen on Spectrum Display Panel, while the
 tautomer peaks are signed according to their symbols.
Options > Clear Tautomers: Removes all selected tautomer peaks from predicted spectrum.
Options > Reset Default Settings: Resets zoom and the default Options, Color, and View settings of NMR
 predictor.

CNMR Predictor:
NMR Prediction Frequency: 500 [125] MHz
Spectrum Display: Realistic Spectrum
Spectrum Labels: Chemical Shifts
Measurement Unit: ppm
Zoom Follows Selection: On

HNMR Predictor:
Spin-Spin Coupling: On
Implicit Hydrogen Mode: On
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NMR Prediction Frequency: 500 MHz
Spectrum Display: Realistic Spectrum
Spectrum Labels: Chemical Shifts
Measurement Unit: ppm
Integral Curve: On
Zoom Follows Selection: On

View menu

 is to select different display options related to the predicted spectrum and the molecule structure:

View > Spectrum Display:

 Realistic Spectrum: Displays predicted spectrum in a realistic way.
 Line Spectrum: Predicted chemical shifts are presented by distinct lines with proper intensity.

View > Spectrum Labels: In order to assign signals and relevant atoms more easily, you can display the
 atom numbers or the chemical shift values of each signal on the NMR Spectrum Display an Molecule View
 Panels. Select:

 Atom Numbers to see atoms assigned to each signal and to display atom numbers on Molecule
 View Panel as well.

 Chemical Shifts to see the exact chemical shift value of NMR signals on NMR Spectrum Display
 Panel.

 None to remove spectrum labels.
Note that you can display only one type of label at a time.
View > Measurement Unit: The chemical shift of tetramethylsilane (TMS) is set to zero, and all other
 chemical shifts are predicted relative to it. Display unit can be:

 Hz or
 ppm.

View >  Integral Curve: Displays integral curve on spectrum. Default setting is: on.
View > Display Legend: Displays legend on Spectrum Display Panel. The legend contains information on
 different functions of Spectrum Display Panel.
View > Reference Spectrum: It is an imported JCAMP-DX NMR spectrum that can be superimposed on
 the predicted NMR spectrum.

Display Shifts: If the imported JCAMP-DX file has "PEAKTABLE" property, the chemical shifts of the
 imported spectrum can be displayed.
None: Remove chemical shift labels of the reference spectrum.

View > Set Colors...: You can customize the color of the predicted spectrum, reference spectrum, and
 selection.

View >  Zoom Follows Selection: If you select an exact atom on Molecule View Panel, or a signal on
 NMR Spectrum Display Panel, the appropriate signal is centered and zoomed in on NMR Spectrum
 Display Panel.

View >  Select Individual Multiplets: In case of overlapping multiplets, this option enables highlighting
 individual multiplets.

View >  Horizontal Zoom In: Zooms in on spectrum in X-axis direction.

View >  Horizontal Zoom Out: Zooms out of spectrum in X-axis direction.

View >  Vertical Zoom In: Zooms in on spectrum in Y-axis direction. Note: the bottom of the selection
 window is fixed.

View >  Vertical Zoom Out: Zooms out of spectrum in Y-axis direction. Note: the bottom of the
 selection window is fixed.

View >  Reset Zoom: Displays the whole spectrum in both directions.

View >  Scale Up Reference: Increases intensity of imported reference spectrum. Active when
 reference spectrum is imported.

View >  Scale Down Reference: Decreases intensity of imported reference spectrum. Active when
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 reference spectrum is imported.

Help menu

Help >  Quick Help
Help > Help Contents

Back to top

NMR Prediction Toolbar

You can use toolbar elements to access selected NMR Predictor menu items.

Export to PDF...

Spectrum Display

Spectrum Labels

Spin-Spin Coupling

Integral Curve

Measurement Unit

Zoom Follows Selection

Select Individual Multiplets

Horizontal Zoom In

Horizontal Zoom Out

Vertical Zoom In

Vertical Zoom Out

Reset Zoom

Scale Up Reference

Scale Down Reference

Quick Help

Back to top

NMR Prediction Panels

NMR Prediction window contains Molecule View Panel, Table of Chemical Shifts, NMR Spectrum Preview
 Panel, and NMR Spectrum Display Panel to present the predicted spectrum and to display selected features.
 Panels can be copied separately as images by right-clicking on the appropriate panel and selecting Copy to
 clipboard action.

Molecule View Panel

displays the molecule of prediction. Molecule has to be drawn in MarvinSketch. Using the Ctrl button while the
 cursor is located in this panel, the view of molecule can be controlled:

Ctrl+Mouse scroll button: Zooms in/out the molecule
Ctrl+Mouse dragging: moves the molecule

 If you select View > Spectrum Labels > Atom Numbers, atom numbers will appear on both Molecule View
 Panel and NMR Spectrum Display Panel.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmr_quickhelp.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmr_quickhelp.html
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 If you select View > Spectrum Labels > Chemical Shifts, chemical shift values of predicted multiplets will appear
 on both Molecule View Panel and NMR Spectrum Display Panel
 If you have added tautomers to the predicted spectrum via "Select Tautomers..." option, the layout of Molecule
 View Panel will change: the active tautomer is displayed on the panel. To go to the next/previous tautomer, click
 on the arrows next to the molecule. Above the displayed molecule, symbols T1, T2, ..., Tn, mark the selected

 tautomers. Hover over to see tautomer structure in a pop-up window. Click on the symbol to make it active. 

 Click on Update button after you have made any modifications on molecular structure in MarvinSketch and you
 want to predict the NMR spectrum of the new molecule. Effect of Update button on Molecule View Panel is
 equal to Edit > Update Molecule action.

Table of Chemical Shifts

The following tabs are available on this panel: Multiplet information, Atom information, and Coupling
 information tabs. Table on all tabs contains data of the predicted spectrum in Multiplet or Atom point of view.
 Coupling table contains the calculated coupling constants when Spin-Spin coupling option is selected.

Multiplet information Table has six columns, namely: Atom numbers, Chemical shift, Net intensity, Intensity
 pattern, Multiplet information, and Quality. You can sort data according to these columns.

Atom numbers are the numbers displayed on the molecule structure and are assigned automatically.
Chemical shift values are displayed in the selected Measurement Unit.
Net intensity is the integration value of the relevant signal.
Intensity pattern describes the relative intensity of the multiplet elements.
Multiplet information is the conventional one letter abbreviation of multiplicity, e.g.: s - singlet; d -
 doublet; t - triplet; ...
Quality defines the prediction quality according to our validation method. Definitions: good, medium,
 rough.

Atom information Table has five columns, namely: Atom number, Chemical shift, Net intensity, Multiplet
 information, and Quality.

Atom numbers are the numbers displayed on the molecule structure and are assigned automatically.
Chemical shift values are displayed in the selected Measurement Unit.
Net intensity is the integration value of the relevant signal.
Multiplet information is the conventional one letter abbreviation of multiplicity, e.g.: s - singlet; d -
 doublet; t - triplet; ...
Quality defines the prediction quality according to our validation method. Definitions: good, medium,
 rough.

Coupling information Table has four columns, namely: Atom 1, Atom 2, Value, and Quality.

Atom 1 and Atom 2 are the number of atoms that the coupling constant is connected to.
The value of the coupling constant is displayed in Hz.
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Quality defines the prediction quality according to our validation method. Definitions: good, medium,
 rough.

NMR Spectrum Preview Panel

displays the whole predicted spectrum. You can zoom in and out on spectrum by using your mouse, toolbar zoom
 items, or menu items.

If you want to zoom in on specific region of the spectrum, use left-click and drag on NMR Spectrum
 Preview Panel. The background of the selected region will turn to white, while unselected region of the
 spectrum will turn to grey.
You can move the selection window by left-clicking into the middle of the selection window; hold mouse
 button while moving the selection, and release button to place it.
You can resize the selection window if you grab-and-drag its yellow side frames (except bottom frame).

NMR Spectrum Display Panel

displays the appropriate zoom region of the spectrum of the molecule presented on Molecule View Panel. 
 Move your mouse pointer over the NMR Spectrum Display Panel and use mouse-wheel to zoom in and out on
 NMR spectrum along the X-axis. Using Ctrl+mouse-wheel will zoom in and out on NMR spectrum along the Y-
axis. 
 If you have added tautomers to the predicted spectrum via "Select Tautomers..." option and Spectrum Labels
 are on, the inactive tautomer signals are marked according to their symbols (T1, T2, ...).

Back to top

NMR Prediction Pop-up Menu
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Right-clicking on any panel pops up a menu with the following element:

Copy to clipboard: The panel in question will be copied to the clipboard.

Back to top

 

Examples

Toggle Spin-Spin Coupling: Options > Spin-Spin Coupling

 

Toggle Implicit Hydrogen Mode: Options > Implicit Hydrogen Mode
 Change default setting to: View > Spectrum Labels > Atom Numbers; Zoom in on the certain spectrum
 region.

 

Switch between Realistic and Line Spectrum display: View > Spectrum Display >

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmr_files/proton_coupling.png
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmr_files/implicith.png
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Select Individual Multiplets:

References

Gottlieb, H.E.; Kotlyar, V.; Nudelman, A. J. Org. Chem., 1997, 62, 7612-7515; doi

Back to top
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NMR Spectrum Viewer - ChemAxon's tool to view Nuclear Magnetic Resonance
 spectra

Version 6.1.7

Contents

NMR Spectrum Viewer
NMR Spectrum Viewer Menu
NMR Spectrum Viewer Toolbar
NMR Spectrum Viewer Panels
NMR Spectrum Viewer Pop-up Menu
NMR Spectrum Viewer Statusbar

NMR Calculation main page

 

NMR Spectrum Viewer

 NMR Spectrum Viewer is part of the NMR Calculation group. It is able to display Nuclear Magnetic Resonance spectra
 saved in JCAMP-DX format (*.jdx). The opened spectrum can be zoomed in, exported to PDF files, or simply copy-
pasted as image.

The NMR Spectrum Viewer window consists of a menu, toolbar, two panels, and a status bar.

NMR Spectrum Viewer Menu

 The menu contains File, View, and Help elements.



NMR Spectrum Viewer - ChemAxon's tool to view Nuclear Magnetic Resonance spectra

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/nmrview.html[11/4/2015 9:59:13 PM]

File menu

File >  Import from JCAMP-DX...: Open an NMR Spectrum in JCAMP-DX format to display it in NMR
 Spectrum Viewer. Clicking on this menu item will launch the Open dialog window. Select an NMR spectrum in
 JCAMP-DX format and click on Open.
File > Exit: Close application.

View menu

View > Measurement Unit: Display NMR spectrum in one of the following units:

 Hz or;
 ppm.

View >  Display Local Maximum Places: NMR Spectrum Viewer can display local maximum places as
 spectrum labels when the JCAMP-DX file contains PEAKTABLE information.

View >  Horizontal Zoom In: Zoom in on NMR Spectrum along the X-axis.

View >  Horizontal Zoom Out: Zoom out on NMR Spectrum along the X-axis.

View >  Vertical Zoom In: Zoom in on NMR Spectrum along the Y-axis.

View >  Vertical Zoom Out: Zoom out on NMR Spectrum along the Y-axis.

View >  Reset Zoom: Restore spectrum zooming to full spectrum view.

Help

Help > Help Contents: Open this help page in your browser.

Back to top

 

NMR Spectrum Viewer Toolbar

You can use toolbar elements to access selected NMR Spectrum Viewer menu items.

Import from JCAMP-DX...

Display Local Maximum Places

Measurement Unit

Horizontal Zoom In

Horizontal Zoom Out

Vertical Zoom In

Vertical Zoom Out

Reset Zoom

Back to top

 

NMR Spectrum Viewer Panels

Panels can be copied separately as images by right-clicking on the appropriate panel and selecting Copy to clipboard
 action.

Spectrum View Panel
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Displays the whole imported spectrum.

If you want to zoom in on specific region of the spectrum, use left-click and drag or ctrl + left-click and drag on
 NMR Spectrum Preview Panel. The background of the selected region will be highlighted in white, while
 unselected region of the spectrum will turn to grey.
You can move the selection window by left-clicking into the middle of the selection; hold mouse button while
 moving the selection, and release button to place it.
You can resize the selection window if you grab-and-drag the yellow side frame around the highlighted area.

Spectrum Display Panel

Displays the appropriate zoom region of the spectrum. Move your mouse pointer over the NMR Spectrum Display
 Panel and use mouse-wheel to zoom in and out horizontally, ctrl+mouse-wheel to zoom in and out verically on the
 NMR spectrum.

Back to top

 

NMR Spectrum Viewer Pop-up Menu

Right-clicking on any panel pops up a menu with the following element:

Copy to clipboard: The panel in question will be copied to the clipboard.

Back to top
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NMR Spectrum Viewer Status Bar

 The status bar of NMR Spectrum Viewer displays the X and Y coordinates of mouse cursor position, and the following
 data stored in the opened JCAMP-DX file:

Nucleus;
Frequency,
Owner;
File.

Back to top
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Isomers

Tautomer Generator Plugin

Tautomers are organic compounds that are interconvertible by tautomerization. Tautomerization reaction results
 in the formal migration of a hydrogen atom or proton, accompanied by a switch of a single bond and adjacent
 double bond. Commonly, the catalysts of these reactions are acids or bases. In solution a chemical equilibrium of
 the tautomers will be reached. Some types of tautomers: ketone-enol, amid-imidic acid, lactam-lactim, enamine-
imine. Learn more about tautomerization and tautomers.

Tautomers of a compound can be determined with the help of Tautomer Generator Plugin.
Note: Tautomer Generator Plugin does not consider the three dimensional structure of molecules during
 tautomer generation, and symmetric structures are filtered out from the generated tautomer set.

Following options can be adjusted in the Tools > Isomers > Tautomers, Tautomers Options panel:

General options

Calculation:
Dominant tautomer distribution: displays the percentage of different tautomers present at the
 given pH.
Canonical tautomer: calculates only the canonical tautomer of the structure. Rational tautomer
 generation mode can be activated.
Generic tautomer: used for the identification of tautomers in JChem databases. It is calculated
 according to these rules:

Tautomeric regions are identified.
All bond types in the tautomeric regions will be changed to ANY.
Each region will be assigned a data S-group with Sum(bonding electrons).
Explicit hydrogens are removed.
Isotope hydrogen:

outside of tautomer regions is kept as is
inside tautomer regions:

Non-mobilizable isotope hydrogen (attached to an atom which is neither donor nor

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/tautomers.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/tautomers.html#rational
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 acceptor, so does not lose or gain H during tautomerization): the isotope is kept
 as is.
Mobilizable isotope hydrogen (attached to a donor or acceptor atom in the
 tautomer region):
 the mobilizable isotopic hydrogens are removed, and the number of each type is
 included in the data sgroup description. For example: "36 e 2 D 3 T" (meaning 36
 bonding electrons, 2 tautomerizable Deuterium and 3 Tritium atoms in the region).

Only the protection or deprotection of tetrahedral stereo centers is taken into consideration.
Major tautomer: gives the first species from the dominant tautomer distribution.
All tautomers: calculates all possible tautomers. If any deuterium or tritium is involved in the
 tautomerization, it moves during enumeration. Rational tautomer generation mode can be activated.

Max. number of structures: maximize the number of structures to display. This number is the sum of
 unique tautomeric count and degenerated tautomeric count; however, only unique tautormers are
 displayed their degenerated tautomeric pairs are not.
Consider pH effect: takes into account the protonation states at given pH. Applicable for Major tautomer
 and Dominant tautomer distribution calculations.
Rational tautomer generation: the tautomerization products are generated according to empirical rules.
 Rational tautomer generation narrows down the possible tautomerization paths and leads to chemically
 more feasible products.
Single fragment mode: if checked (default), the results are displayed in separate windows; if unchecked,
 the calculation handles unlinked molecules together and results are in the same window.

Advanced options

Note: the number of generated tautomers strongly depends on the options chosen.

Decimal places: setting the number of decimal places with which the tautomer distribution values are
 given.
Set max. allowed length of the tautomerization path; Path length: sets the number of bonds which
 are considered by displacing a double bond.
Protect aromaticity: if checked (default), the aromaticity will be maintained.
Protect charge: if checked (default), defined charged atoms maintain their charge during calculation.
Exclude antiaromatic compounds: if checked (default), any tautomer structure having an antiaromatic
 ring system will be discarded.
Protect double bond stereo: if checked, all double bonds with stereo information remain intact. If
 unchecked (default), tautomer regions will lose the double bond stereo information, any other stereo
 information in the molecule is kept intact.
Protect all tetrahedral stereo centers: if checked, stereocenters are not included in the tautomerization.
 If unchecked (default), tautomer regions will lose the tetrahedral stereo information, any other stereo
 information in the molecule is kept intact.
Protect labeled tetrahedral stereo centers only: if checked, stereocenters labeled with chiral flag or
 MDL Enhanced Stereo Representation flags will not be included in tautomerization, other stereocenters will.
Single fragment mode: if checked (default), the results are displayed in separate windows, if unchecked,
 the calculation handles unlinked molecules together and results are in the same window.
Protect ester groups: if checked, ester is not taking part in tautomerization.
Ring-chain tautomerization is allowed: this option can be activated when "All tautomers" function is
 selected. If it is checked, tautomer generation will take into account the possibility of ring closure.

For example, the following structures are the calculated tautomers of 4-amino-6-ethoxypyrimidin-2-ol:
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Dominant tautomer
 distribution

Canonical tautomer

Generic tautomer
 and an isotope
 labeled example

Major tautomer
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All tautomers

Stereoisomers Generator Plugin

The Stereoisomers Generator Plugin produces all possible stereoisomers of a given compound. The plugin handles
 both tetrahedral and double bond stereo centers.
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Generate
Tetrahedral stereo isomers: only the R/S isomers are generated.
double bond stereo isomers: only E/Z isomers are generated.
both: both R/S and E/Z isomers are generated.

Generate all stereoisomers: all isomers are generated
Generate maximum: only the given number of structures are generated.
Protect tetrahedral stereo centers: if checked, preset stereocenters are not included in the
 stereoisomer generation.
Protect double bond stereo: if checked, all double bonds with preset stereo information remain intact.
Filter invalid 3D structures: sterically restricted isomers are discarded.
Display in 3D: results are displayed in a 3D viewer.

Results are displayed in a 2D viewer by default:
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To replace your drawn molecule in the sketcher with any of the isomers shown, click on the structure then press
 "Select" at the bottom of the cells (the result window will be closed).

If "Filter invalid 3D structures" option is switched on in the Stereoisomers Options panel, the stereoisomers can
 also be displayed in 3D.
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Conformation

Conformer Plugin

Conformational isomerism is a form of isomerism that describes the phenomenon of molecules with the same structural
 formula having different shapes due to rotations about one or more bonds. Different conformations might have different
 energies, can usually interconvert, and are very rarely isolatable. 
Conformer plugin generates selected number of conformers or the lowest energy conformer of a molecule. For conformer
 calculation Dreiding force field is used.

Different calculation parameters can be set in the Conformers Options panel:

Display options
Display conformers: conformers are displayed in a MarivnView window.
Store conformer information in property field: the conformer data are calculated and stored with the
 structures. This option provides the calculations needed to select a specific conformer when using 3D
 cleaning (menu item Structure > Clean 3D > Display Stored Conformers). The conformers will only be stored
 if you select one result and click on "Select".

Force field: force field used for calculation.
Energy unit: giving results in kcal/mol or kJ/mol.
Optimization limit: set the optimization to loose, normal, strict very strict (in this order increasing calculation
 times and precisity).
Calculate lowest energy conformer: calculates and displays only the lowest energy conformer structure. When
 checking this option, max. number if conformers and diversity limit are disabled.
Maximum numbers of conformers: limiting the number of calculated structures.
Diversity limit: conformers within diversity limit will be considered the same and doubles removed.
Timelimit (s): no conformers will be displayed if the calculation is stopped at the time limit set (e.g. there are too
 many conformers to calculate, the operation is cancelled after the given time had elapsed).
Prehydrogenize: if checked, converts all implicit hydrogens to explicit hydrogens without removing them after the
 calculation. If unchecked, no explicit hydrogens will be added.
Hyperfine: inserts more itineration steps in the calculations, gives more precision in results but the needed time
 becomes longer.
Multi-fragment optimization: multi-fragment optimization with MMFF94.
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Visualize H bonds: marks intramolecular hydrogen bonds in the conformer where it is likely to occur.

The results appear in a new window, containing all calculated conformers with their energy indicated:

Molecular Dynamics Plugin

The molecular dynamics plugin calculates the configurations of the system by integrating Newton's laws of motion.

The calculation and the display options can be set in the Molecular Dynamics Options panel:

Display: display mode
Animation: trajectory is displayed as an animation.
Frames: trajectory frames are displayed individually (see above).

Force field: force field used for calculation.
Integrator: integrator type used for solving Newton's laws of motion.
Simulation steps: number of simulation steps.
Step time (fs): time between simulation steps in femtoseconds.
Initial temperature (K): initial temperature of the system in kelvin.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/images/mdanim.gif
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Start time of display (fs): the time of the first simulation frame to be displayed in femtoseconds.
Frame interval (fs): time between displayed simulation frames in femtoseconds.

The result is shown in a new window:

The window is a MarvinView window, with all its funcionalities to reach.

3D Alignment Plugin

3D Alignment overlays drug sized molecules onto each other in the 3D space.

Input can be two or more molecules in 2D or in 3D. If 2D molecules are used their 3D structure is automatically
 generated by generate3D.

The conformation of the molecules can be treated flexible or the input conformation can be preserved. To preserve the
 input conformation simply select the molecule.

Usage: Molecules to align shoud be placed into the same MarvinSketch canvas by reading multiple molecules from a file.
 Alternatively, copy & paste or drag molecules from another sketch window.

Output is the aligned molecules in 3D. To save the aligned orientation use the popup menu: Click on the molecules with
 the second mouse button.

Following options can be set in the 3D Alignment Options panel:
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Alignment options

Align by extended atom types: Extended atom types are assigned to each atom to enable chemically relevant
 atomic overlay. During the alignment process the overlap of the atoms of the same type is maximized. Types
 differentiate atomic number, hybridization state and aromaticity, e.g. aromatic nitrogen atom is not matched
 against a tertiary amine. These extended atom types correspond to the ones used in Dreiding force field.
Align by MCS: The atom-atom pairing is obtained from the 2D maximum common substructure of the molecules.
 Alignment by extended atom types is applied on the non MCS atoms.

Detailed options

Initial conformation size: Number of diverse conformations to generate as an input for the alignment.
Accuracy: low, normal, high, very high: If lower selected the calcualtion is faster. The default is normal.

Display in MarvinSpace: the result window is a MarvinSpace 3D viewer. Molecules are visualized in different colors for
 better distinction of structures.
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The aligned molecules are shown in a MarvinSpace window. Click and drag to rotate.

An example of usage

 Suppose you have an SDfile contaning some molecules (called wish.sdf) that you wish to align. This must be converted
 for the alignment to a single molecule multi-fragment file where each fragment is a molecule from wish.sdf:

Create an empty file in MarvinSketch called empty.mol
Type at command prompt: molconvert mol empty.mol -R wish.sdf -o wish_fused.mol

Open wish_fused.mol in MarvinSketch

If you know which atoms to overlap use the Reaction arrow tool to connect them. This can improve the alignment. If you
 have only 3D molecules as input and you select one of them, its original conformation will be preserved during the
 alignment, while others remain flexible.

Select Tools > Conformation > 3D Alignment
Untick the Display in MarvinSpace option
Alignment process can take a while, around a minute for 4 drugsize molecules
Click on the result window with the right mouse button and select "Save As" from the pop menu.
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Geometry

Topology Analysis Plugin

The Topology Analysis plugin provides characteristic values related to the topological structure of a molecule. These options
 can be set in the Topology Analysis Options panel, here shown with the Atom/bond tab opened:

Atom/bond

Aliphatic atom count: number of atoms in the molecule having no aromatic bond (excluding hydrogens).
Aliphatic bond count: number of non-aromatic bonds in the molecule (excluding bonds of hydrogen atoms).
Aromatic atom count: number of atoms in the molecule having aromatic bonds.
Aromatic bond count: number of aromatic bonds in the molecule.
Asymmetric atom count: the number of asymmetric atoms (having four different ligands).
Atom count: number of atoms in the molecule including hydrogens.
Bond count: number of bonds in the molecule includingbonds of hydrogen atoms.
Chain atom count: number of chain atoms (non-ring atoms excluding hydrogens).
Chain bond count: number of chain bonds (non-ring bonds excluding bonds of hydrogen atoms).
Chiral center count: the number of tetrahedral stereogenic centers. This function identifies two chiral centers in 1,4-
dimethylcyclohexane, which does not contain asymmetric atoms.
Ring atom count: number of ring atoms.
Ring bond count: number of ring bonds.
Rotatable bond count: number of rotatable bonds in the molecule. Unsaturated bonds, and single bonds connected
 to hydrogens or terminal atoms, single bonds of amides, sulphonamides and those connecting two hindered aromatic
 rings (having at least three ortho substituents) are considered non-rotatable.
Stereo double bond count: number of double bonds with defined stereochemistry.

Ring

Aliphatic ring count: number of those rings in the molecule that have non-aromatic bonds (SSSR based).
Aromatic ring count: number of aromatic rings in the molecule. This number is calculated from the smallest set of
 smallest aromatic rings (SSSAR), which might contain rings which are not part of the standard SSSR ring set. As a
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 consequence, the sum of the aliphatic ring count and the aromatic ring count can sometimes be greater than the ring
 count value. The difference is the signal of a macroaromatic ring system.
Carbo ring count: number of rings containing only carbon atoms.
Carboaliphatic ring count: number of aliphatic rings containing only carbon atoms.
Carbooaromatic ring count: number of aromatic rings containing only carbon atoms (SSSAR based).
Fused aliphatic ring count: number of aliphatic rings having common bonds with other rings.
Fused aromatic ring count: number of aromatic rings having common bonds with other rings.
Fused ring count: number of fused rings in the molecule (having common bonds).
Hetero ring count: number of rings containing hetero atom(s).
Heteroaromatic ring count: number of aromatic heterocycles in the molecule.
Largest ring size: size of the largest ring in the molecule.
Largest ring system size: number of rings in the largest ring system.
Ring count: number of rings in the molecule. This calculation is based on SSSR (Smallest Set of Smallest Rings).
Ring system count: number of disjunct ring systems.
Smallest ring size: size of the smallest ring in the molecule.
Smallest ring system size: number of rings in the smallest ring system.

Path based

Platt index: sum of the edge degrees of a molecular graph.
Randic index: harmonic sum of the geometric means of the node degrees for each edge.

Distance based

Balaban index: the Balaban distance connectivity of the molecule, which is the average distance sum connectivity.
Distance degree: the sum of the corresponding row values in the distance matrix for each atom.
Eccentricity: the greatest value in the corresponding row of the distance matrix for each atom.
Harary index: half-sum of the off-diagonal elements of the reciprocal molecular distance matrix of the molecule.
Hyper Wiener index: a variant of the Wiener index.
Szeged index: The Szeged index extends the Wiener index for cyclic graphs by counting the number of atoms on
 both sides of each bond (those atoms only which are nearer to the given side of the bond than to the other), and
 sum these counts.
Wiener index: the average topological atom distance (half of the sum of all atom distances) in the molecule.
Wiener polarity: the number of 3 bond length distances in the molecule.

Other

Cyclomatic number: the smallest number of bonds which must be removed so that no circuit remains. Also known
 as circuit rank.
Fragment count: number of fragments in the sketch.
Steric effect index: topological steric effect index (TSEI) of an atom calculated from the covalent radii values and
 topological distances. The stericEffectIndex is related to the steric hindrance of the given atom.

Fsp3: number of sp3 hybridized carbons diveded by the total carbon count

The result is shown in a separate window:
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The contents of text field can be copied to the clipboard as text, the structure fields offers a MarvinView context menu.

Geometrical Descriptors Plugin

The Geometrical Descriptors plugin provides characteristic values related to the geometrical structure of a molecule. It can
 calculate steric hindrance and Dreiding energy. The calculation can predict and use the lowest energy conformer of the
 input structure.

The calculation and the display options can be set in the Geometrical Descriptors Options panel:
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Type
Dreiding energy: calculates the energy related to the 3D structure (conformation) of the molecule using
 dreiding force field.
MMFF94 energy: calculates the energy related to the 3D structure (conformation) of the molecule using
 MMFF94 force field.
Steric hindrance: steric hindrance of an atom calculated from the covalent radii values and geometrical
 distances.
Minimal projection area: calculates the minimum of projection areas of the conformer, based on the van der
 Waals radius (in Å2).
Maximal projection area: calculates the maximum of projection areas of the conformer, based on the van der
 Waals radius (in Å2).
Minimal projection radius: calculates the radius for the minimal projection area of the conformer (in Å).
Maximal projection radius: calculates the radius for the maximal projection area of the conformer (in Å).
Maximal distance perpendicular to the min projection: calculates the maximal extension of the conformer
 perpendicular to the minimal projection area (in Å).
Maximal distance perpendicular to the max projection: calculates the maximal extension of the conformer
 perpendicular to the maximal projection area (in Å).

van der Waals volume: calculates the van der Waals volume of the conformer (in Å3).
Energy unit: gives dreiding energy in kcal/mol or kJ/mol.
Decimal places:setting the number of decimal places with which the result value is given.
Radius scale factor: atom radii from the periodic system are multiplied by this number.
Set MMFF94 optimalization: The structure is optimized before MMFF94 energy calculation.
Set projection optimalization The structure is optimized before projection area and projection radius calculation(s).
Calculate for lowest energy conformer:

If molecule is in 2D: the lowest energy conformer of the 2D molecule is generated, and its parameters
 calculated. 3D input molecules are considered in the given conformation.
Never: the input molecule is used for calculation.
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Always: the lowest energy conformer is generated (3D and 2D molecules as well), and its geometry parameters
 calculated.

Optimization limit:
Very loose
Normal
Strict
Very strict

Polar Surface Area Plugin (2D)

Polar surface area (PSA) is formed by polar atoms of a molecule. It is a descriptor that shows good correlation with passive
 molecular transport through membranes, and so allows estimation of transport properties of drugs. Estimation of topoligical
 polar surface area (TPSA) is based on the method given in this paper. The method provides results which are practically
 identical with the 3D PSA, while calculation time of TPSA is approximately 100-times faster. This method is more suitable
 for fast bioavailability screening of large virtual libraries. The TPSA value can be calculated both for the neutral form and
 the major microspecies.

The calculation and the display options can be set in the Polar Surface Area (2D) Options panel:



Geometry

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/geometrygroup.html[11/4/2015 9:59:24 PM]

Decimal places:setting the number of decimal places with which the result values are given.
Exclude sulfur atoms from calculation
Exclude phosphorus atoms from calculation
Take major microspecies at pH: calculates the polar surface area for the major microspecies present at the given
 pH.

The result appears in a separate window, if several structures were drawn navigation is possible with a scroll bar:

The contents of the text field can be copied to the clipboard by Ctrl+C, the structure field offers a context menu from
 MarvinView.

Molecular Surface Area Plugin (3D)

There are two types of available molecular surface area calculations, van der Waals and solvent accessible. Calculation
 method is based on the publication of Ferrara et al.

The calculation and the display options can be set in the Molecular Surface Area (3D) Options panel:
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Decimal places:setting the number of decimal places with which the result values are given.
Surface Area

Van der Waals: calculates the van der Waals surface of the molecule (in Å2).

Solvent Accessible: calculates the solvent accessible surface of the molecule (in Å2).
Solvent radius: setting here the radius of the solvent molecule (by default water, 1.4 Å).
Show surface area increments: the increment by each atom is displayed.
Take major microspecies at pH: the surface area of the major microspecies present at the given pH is calculated.

The result window contains the area values and the molecule in 3D view. The left picture shows the van der Waals surface
 and the right window the solvent accessible surface area:

 The values indicated in the text field of the result window of the solvent accessible surface area calculations are the

 following (all in Å2):

ASA: solvent accessible surface area calculated using the radius of the solvent (1.4 Å for the water molecule).
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ASA+: solvent accessible surface area of all atoms with positive partial charge (strictly greater than 0).
ASA-: solvent accessible surface area of all atoms with negative partial charge (strictly less than 0).
ASA_H: solvent accessible surface area of all hydrophobic (|qi|<0.125) atoms (|qi| is the absolute value of the partial

 charge of the atom).
ASA_P: solvent accessible surface area of all polar (|qi|>0.125) atoms (|qi| is the absolute value of the partial charge

 of the atom).
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Markush Enumerator Plugin

 A Markush structure is a description of a compound class by generic notations, primarily used in patent claims and the description of
 combinatorial libraries. The library of a Markush structure is the total set of specific molecules that are described by the Markush structure.

 The Markush enumeration plugin can be used to generate a whole or a subset of the library of a generic Markush structure. It is also capable
 of calculating the total number of specific structures present in a Markush library. The plugin is accessible from the followings:

Marvin GUI (Structure > Markush Enumeration)
Instant JChem
Markush viewer
cxcalc command-line program (see this link for the detailed usage of the plugin in command line)
via API
Markush search example JSP web application
Chemical Terms functions in JChem

Markush features Functionality of the plugin

R-groups
Atom lists
Bond lists
Link nodes
Repeating units
Position variation bond
Homology groups

Sequential enumeration
Random enumeration
Calculate library size
Selected part enumeration
Valence filter
Homology group enumeration
Scaffold alignment and coloring
Markush code generation

Markush features

 Currently, the Markush enumeration plugin supports the following features that describe Markush structures in combinatorial libraries:

R-groups

 R-groups (also referred to as "substituent variation") are the most widely known Markush generic features. The variable part of
 the structure is denoted by an R-atom (eg. R1), and the definitions are given separately. In each definition the connection points
 must be defined to show where the bonds of the R-atom are linked. R-atoms can appear in both rings and chains, and can have
 one or more than one attachments point. The same R-atom can appear multiple times, and the different occurrences are
 handled as different cases. (So they can be substituted with different definitions.) R-group nesting in R-group definitions is
 allowed to any depth, but without recursion. (An R-group definition cannot use the R-atom it is defining, not even through the
 use of other embedding R-atom(s).) R-groups up to number R32767 can be used.

Example Example Markush library member

 R-group drawing in Marvin Sketch is described in the Marvin Sketch User's Guide.

Atom lists

 Atom lists are another example of substituent variation. They define lists of atom types at a given position. There is no
 restriction for the length of the list and for bond count of atom lists. Atom list drawing in Marvin Sketch is described here.

Example Example Markush library member

Bond lists

http://www.chemaxon.com/instantjchem/ijc_latest/docs/user/help/htmlfiles/chemistry_functions/markush_enumeration.html
http://www.chemaxon.com/jchem/doc/user/markush_viewer.html#nesting
http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/calc.html
http://onlinelibrarystatic.wiley.com/marvin/help/applications/cxcalc-calculations.html#Enumerations
http://onlinelibrarystatic.wiley.com/marvin/help/applications/cxcalc-calculations.html#Enumerations
http://www.chemaxon.com/marvin/help/developer/beans/api/chemaxon/marvin/calculations/MarkushEnumerationPlugin.html
http://www.chemaxon.com/jchem/examples/db_search/index.jsp
http://onlinelibrarystatic.wiley.com/marvin/help/chemicalterms/EvaluatorFunctions.html


Markush Enumerator Plugin

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/markush.html[11/4/2015 10:00:21 PM]

The following bond lists (generic bond types) are supported by the plugin: single or double, any(single, double or triple), single
 or aromatic, double or aromatic. In Marvin Sketch, bond lists are accessible amongst query bond types in the bonds pop-up
 menu.

Example Example Markush library member

Link nodes

Link nodes are atoms that may repeat between two of their designated bonds (called outer bonds, denoted by brackets). All
 other substituents (if exist) repeat together with the atom. In the results, the new bonds between the repeating atoms will have
 the bond type of the lower order outer bond. Link nodes can be drawn in Marvin Sketch using the popup menu.

Example Example Markush library member

Repeating units

Repeating units represent structural parts that can be repeated several times. The repeating unit is enclosed in brackets with one
 or two head and the same number of tail crossing bonds. (Head crossing bonds go through the left bracket.) Two bond pairs
 represent ladder type repeating units. The repetition range is a comma-separated list of possible repetitions or repetition
 intervals, e.g. "1,3,5-9". The repetition pattern specifies the way how the subsequent repeated units are linked together: it can
 be head-to-head(hh), head-to-tail(ht) or either/unknown(eu) (the either/unknown case is not handled by the search software).
 In case of ladder type polymers there is also a flip(f) option that defines that the top and bottom crossing bonds are flipped
 during each connection. repeating groups with specified repetition ranges.

 Repeating unit drawing is described in the Marvin Sketch Help here, and ladder-type bracket drawing is described at the polymer
 drawing section.

Example Example Markush library member

Position variation bonds

Position variation bonds are bonds attached to variable atoms at one or both end positions. The set of variable atoms is drawn as
 a multicenter group. A position variation bond connects one atom from one end position to one atom from the other end
 position. If the end position is a single atom then the bond is attached to this atom, if the end position is a multicenter group
 then the bond is attached to an arbitrary member of the group. Position variation drawing in Marvin Sketch is described in Help.

Limitations:

Substructure search is not yet prepared to handle the case when both end positions are multicenter groups.
A multicenter end position is not allowed to contain R-atoms.
A multicenter end position is not allowed to contain another position variation bond (ie, position variation bonds cannot be
 nested).

 If a link node is a member of a multicenter group then the group will include the repeated atoms as well in case when the
 original multicenter group contains no more atoms from the link fragment, otherwise the position variation bond is part of the
 link fragment and repeated together with the link node. Although an R-atom is not allowed to take part in position variation, it
 can be the single-atom end position of a position variation bond, in which case its attachment point is connected to the bond.

Example Example Markush library members
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Homology Groups

Homology groups stand for sets of homologous molecular parts (e.g. functional groups). These are represented by pseudo atoms
 labelled with the common chemical annotation of the groups (alkyl, aryl, heterocycle etc.). See the detailed definition of these
 groups in a separate document. The pseudo atoms can be most easily drawn in Marvin Sketch using the Homology Groups
 template group.

Example Example Markush library member

There are two major types of homology groups regarding their way of definition:

1. Built-in groups are defined by specific structural properties of the group. These groups are not enumerated during
 searching, but the query structure is recognized as fulfilling the requirements for such a structure. The possible number of
 covered structures is usually infinite, unless the number of atoms is limited. Examples of built-in groups are alkyl, aryl,
 heterocycle, etc.

2. User-defined groups are explicitly defined and only the listed structures can match on these homology groups. The
 definition is given in the form of an R-group definition, and any of the generic features discussed in this chapter can be
 used in the definition. These definitions can be customized by the user, and may be context-specific. (E.g. protecting
 group definition depends on which functional group it is protecting.)

Read more about homology groups.

Functionality of the plugin

 The plugin allows the following functionality. Examples are given using Marvin GUI.

Sequential enumeration
Enumerates members of the Markush library in a sequential manner (by substituting the first definition of the first variable, etc).
 The results are specific structures. The plugin user interface allows the enumeration of all library members, or a specified
 number.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html#definition
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html#definition
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html
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Random enumeration
This mode generates a random subset of the Markush library to give a quick sampling. It is especially helpful for huge libraries,
 where full enumeration is impossible. In random mode variable parts are chosen randomly, and the substitution probability of
 each definition is proportionate with the fragment library size that the given definition generates. This ensures the generation of
 uniform distribution of representatives over the Markush library space.
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Calculate library size
The size of the Markush library can be calculated by arbitrary precision. On the user interface, the exact value is displayed until
 20 digits, above that only the magnitude is shown (for example, 10^28). The calculated number is the size of the whole library,
 and does not consider the valence check filter. (See below.)

If the 'Enumerate homology groups' option is enabled, the number of enumerated molecules increases accordingly, multiplied by
 the number of built-in species.
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Selected part enumeration
If part of the Markush structure is selected, only the generic features in the selected part are considered for
 enumeration/calculation. This allows focusing on a particular area of the Markush structure. Enumeration of selected parts only
 may result in generating (more specific) Markush structures.
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Valence filter
If the Markush structure is not properly (or too generally) formulated, it is possible that it describes structures with valence
 errors. In this case, the valence filter setting is useful to filter out the offending result structures. The default value is off (no
 filtering).



Markush Enumerator Plugin

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/markush.html[11/4/2015 10:00:21 PM]

Homology group enumeration
Version 5.2 introduced the enumeration of homology groups. Homology groups are R-groups, represented as pseudo atoms -
 with the names covering a set of R-groups either built-in or user-defined. For detailed information on homology groups click
 here.

http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/homologygroups.html
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Scaffold alignment and coloring
Coloring the scaffold (part of the structure containg no Markush features) and/or the R-groups in enumerated structures can help
 visual recognition of parts of the molecules. Differentiation of the structures is aided by alignment of all structures to the original
 scaffold. These options are available in sequential and random enumeration.
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Markush code generation
A special ID number can be generated for the library members: every structure gets its own unique tag (molecule property),
 which can be saved in the structure file (in .mrv and .sdf formats) named as 'Markush Code'. This ID is visible in the plugin
 result window as well. It gives the following information:

Ri(n):x R-group number i (at atom nr. n) is the ligand containing the atom numbered x (which is the smallest number in
 that fragment but not neccessarily the attachment point) 
Custom reagent codes: instead of atom index numbers, custom reagent codes (e.g. company identifiers) can also be
 used. Add attached data to R-group members with name 'reagent'. These reagent codes will appear in the enumerated
 structures both in the Markush code and in the generated molecule structures. (See example below)
ID tag name the name you specified in the options panel (in this example Test1). If a tag with this name is attached to
 the Markush molecule, its value will be used.
Ln:x link node on atom nr. n in the variation nr. x (in this example 1 or two methylene groups are inserted).
Bn-m:x bond between atoms n and m is nr. x in the bond list (referring to the bond type)
PVn-m:x-y position variation bond between n and m (multicenter numbered) occured between atoms x and y
An:x atom nr. n is nr. x from the atom list
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Other Plugins

Hydrogen Bond Donor-Acceptor Plugin

Hydrogen Bond Donor-Acceptor calculates atomic hydrogen bond donor and acceptor inclination. Atomic data and overall hydrogen bond donor and acceptor multiplicity are
 displayed for the input molecule (or its microspecies at a given pH). The weighted average hydrogen bond donor and acceptor multiplicities taken over the microspecies
 and the proportions of their occurrences are computed for different pHs and displayed in a chart.

Different calculation parameters can be set in the H Bond Donor/Acceptor Options panel:

Decimal places: setting the number of decimal places with which the result value is given.
Type:

donor, acceptor: specifying search for donor or acceptor characteristics.
Exclude sulfur atoms from acceptors
Exclude halogens from acceptors
Show microspecies data by pH: the number of donor or acceptor sites vs. pH chart is displayed.
Microspecies:

pH lower limit; pH upper limit; pH step size: the pH window of the chart is set here, with data points in the step size marks.
Display major mecrospecies: the structure of the major form at the given pH is displayed.
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Hückel Analysis Plugin

Localization energies L(+) and L(-) for electrophilic and nucleophilic attack at an aromatic center are calculated by the Hückel method. The smaller L(+) or L(-) means more
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 reactive atomic location. Order of atoms in E(+) or in Nu(-) attack are adjusted according to their localization energies. The total pi energy, the pi electron density and the
 total electron density are also calculated by the Hückel method. Depending on the chemical environment the following atoms have optimal Coulomb and resonance integral
 parameters: B, C, N, O, S, F, Cl, Br, I. All other atoms have a default, not optimized parameter.

Theoretical background is taken from Isaacs' book. Additional literature for the Hückel's parameters is Streitwieser's book.

Following calculation parameters can be set in the Huckel Analysis Options panel:

Decimal places: setting the number of decimal places with which the result value is given.
Type

E(+)/Nu(-) order: numbers the aromatic atoms according to their likeliness of being attacked by electrophiles or nucleophiles.
Localization energy L(+)/L(-): gives the localization energies of the aromatic center (dimension β).
Pi energy: calculates the pi energy of the aromatic ring(s) (dimension β).
Electron density: calculates the pi electron density.
Charge density: calculates total charge density on the ring atoms.

Subtype: E(+); Nu(-): for E(+)/Nu(-)order and Localization energy L(+)/L(-), the electrophilicity and nucleophilicity approaches can be selected (at least one fo
 them). Results for E(+) are coloured red, and Nu(-) blue.
Take major microspecies at pH: calculates the values for the major microspecies at the given pH.

 The results appear in a new window, indicating all values at the corresponding atoms in the aromatic ring. The picture on the left is the result of Aromatic E(+)/Nu(-)
 order, the picture on the right the pi energy calculation:
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Refractivity Plugin

Our calculation is based on the atomic method proposed by Viswanadhan et al. Molar refractivity is strongly related to the volume of the molecules and to London
 dispersive forces that has important effect in drug-receptor interaction.

Different calculation parameters can be set in the Refractivity Options panel:
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Decimal places: setting the number of decimal places with which the result value is given.
Type

Increments: displays the increments given by atoms.
Refractivity: calculates the value of the molar refractivity

Increments of hydrogens: displays the increments given by hydrogens.
Display in MarvinSpace: the result window opens as 3D MarvinSpace viewer. If unchecked, the results will be shown on a 2D picture.

The result appears in a new window, containing a text field with the value of refractivity (dimension: 106 [m3 mol-1] and the molecule in 2D or 3D view:

The numbers in brackets refer to the refractivity sums of the implicit hydrogen atoms.

Resonance Plugin

The Resonance plugin generates all resonance structures of a molecule. The major contributors of the resonance structures can be calculated separately. Following options
 can be adjusted in the Resonance Options panel:
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Max. number of structure: maximize the number of structures to display (decrease calculation time).
Take canonical form: displays the canonical structure of the molecule.
Take major contributors: select the most relevant structures.
Single fragment mode : if checked (default), the results are displayed in separate windows; if unchecked, the calculation handles unlinked molecules together and
 results are in the same window.

For example the two structures below, on the left are the major resonance contributors of diazomethane, while the structure on the right is the canonical form:

Structural Frameworks Plugin

 The plugin calculates Bemis and Murcko frameworks and other structure based reduced representations of the input structures.

The required calculation can be selected on the Framework type tab of the Structural frameworks Options panel:
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Bemis-Murcko framework is calculated by removing side chains from the input and generalizing atom/bond types. If Keep single atom for non- empty acyclic
 structures selected then acyclic inputs will not be erased completely; they will be represented by a single node.
Maximum common substructure calculates MCS for every pairs of input fragments. The input must contain at least two disconnected fragments.
Largest ring returns the largest SSSR ring of the input.
All fused ring systems returns the fused ring systems of the input
Largest fused ring system returns the largest the fused ring systems of the input
Smallest set of the smallest rings (SSSR) returns the SSSR rings of the input.
Complete set of the smallest rings (CSSR) returns the CSSR rings of the input.
Only pre/post process, no framework reduction can be used to examine the optional preprocess and postprocess functionality. Selecting this option will skip any
 framework reduction/fragmentation.

The Advanced settings tab allows options to fine tune the execution:
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 Note that redundant or not applicable options will be dinamically disabled based on the selected framework type or other calculations. (For example Bemis-Murcko
 framework calculation will generalize the input, so prune input/output will be disabled when it is selected.)

Input preprocess steps are executed before the framework calculation.
Process only the largest fragment of the input structure: if selected then the largest fragment will be processed in the following steps
Prune input the input structure will be generalized by changing all atom types to carbon, all bond types to single and removing all stereo/wedge bond flags
Add explicit hydrogens will invoke hydrogenize on the input
Remove explicit hydrogens will invoke dehydrogenize on the input

Output postprocess steps are executed after the framework calculation.
Prune results will generalize the resulting framework after the calculations
Return only the largest fragment of the result will keep only the largest resulting fragment
Remove topologically equivalent output fragments will remove duplicated result fragments

The result window contains the framework:
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Marvin Services

Calculation integration as service

Services is a handy module of Marvin that helps to integrate third-party calculations* via the MarvinSketch GUI.
 The linked services will appear under the Tools > Services menu. The menu contains the names of the services
 in a formerly set order.

Figure 1. The location of the set services

Note: When no Services are set in MarvinSketch, the Tools > Services menu will be disabled.

How to use

 Select the desired third-party calculation under Tools > Services. The opening new window — right of
 MarvinSketch — has the same title as the service name.

Figure 2. MarvinSketch window (left) with the new service window (right)

The collapsible panels of the window are the following:

Structure: The upper panel will show the structure in question. The structure can only be edited in the
 MarvinSketch window.

Update button: If the structure is changed in MarvinSketch, press this button to refresh the

http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/setting_services.html
http://onlinelibrarystatic.wiley.com/marvin/help/sketch/gui/setting_services.html
http://onlinelibrarystatic.wiley.com/marvin/help/calculations/services_files/services02.png
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 structure for the calculation. Note: The button will be disabled if Calculate automatically is
 checked;

Arguments: The middle panel shows the calculation parameters. Unless the parameter is bold, it can be
 modified;
Result: The lower panel will show the result of the calculation. The panel can present different output
 formats, e.g., string, structure, web page;

Calculate automatically check box: If the structure is changed in MarvinSketch, the update of the
 structure and the calculation will run automatically. Note: In case it is checked, the Calculate and
 Update buttons will be inactive;
Calculate button: Calculates and retrieves the result.

Figure 3. Different output type examples

String Structure Web page

 
*All calculations not provided in ChemAxon's Marvin Beans or in its JChem package are referred to third-party
 calculations.
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Test results of prediction tools

1. Test of pKa prediction

pKa predicted vs. pKa experimental

Distribution of pKa estimation error

2. Test of logP prediction
logP predicted vs. logP experimental
Distribution of logP estimation error

3. Test of average molecular polarizability prediction
Experimental vs. predicted molecular polarizability
Experimental and predicted data

4. Test of 3D molecular polarizability prediction
Predicted vs. experimental molecular polarizability
Experimental and predicted data

5. References
6. Notes

1. Test of pKa prediction

pKa predicted vs. pKa experimental1

 

Distribution of pKa estimation error
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2. Test of logP prediction

logP predicted vs. logP experimental2

 

Distribution of logP estimation error
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3. Test of average molecular polarizability prediction

Experimental3 vs. predicted molecular polarizability

 

Experimental3 and predicted data
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4. Test of 3D1 molecular polarizability prediction

Predicted vs. experimental4molecular polarizability

 

Experimental4 and predicted data
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5. Comparative evaluation of pKa estimation methods

A study comparing various pKa calculation results versus the measured pKa values of compounds was published

 by John Manchester et al. Read the article here. 

6. References

1. PHYSPROP© DATABASE
2. Klopman, G.; Li, Ju-Yun.; Wang, S.; Dimayuga, M.: J.Chem.Inf.Comput.Sci., 1994, 34, 752; doi
3. Miller, K. J.; Savchik, J. A.: J.Am.Chem.Soc., 1979, 101, 7206-7213; doi
4. Piet Th. van Duijnen.; Swart, M.: J.Phys.Chem. A, 1998, 102, 2399-2407; doi

7. Notes

1. 3D geometries of molecules were generated with Marvin.

Return to Top
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Name to Structure Conversion

 ChemAxon’s naming toolkit capabilities allow you to generate chemical structures from IUPAC, trivial, drug, CAS
 names and from CAS numbers.

Supported names include

IUPAC names, CAS names and generally systematic names
Common names (e.g. Toluene)
Drug names (e.g. Paracetamol, Doliprane)
Acronyms (e.g. ATP for "Adenosine Triphosphate")
CAS numbers (Note, this feature uses a Web service.)
For systematic names:

Chains
Monocycles
Retained/traditional names for ring systems with and without heteroatoms
Spiro ring systems
All cases of von Baeyer nomenclature for bridged ring systems
Fused ring systems
Ethers, esters, oximes, ...
Common characteristic groups
Ionic compounds
Compounds with one radical
Unlimited number of atoms and rings
All atom types
Substitutive and multiplicative nomenclatures
Isotopes
Stereochemistry

Current limitations

Molecules containing multiple radicals (e.g. ethane-1,2-diyl) are not supported yet.

Supporting corporate IDs and custom dictionaries

It is possible to extend the name to structure conversion, for instance to support corporate IDs such as
 ABC0001234, or to make use of common name dictionaries in addition to the default one. This can be
 done by connecting to a webservice or by creating a custom dictionary file.

Name to Structure Conversion in MarvinSketch

There are different ways how you can import a name directly into MarvinSketch and convert it to a chemical
 structure.

A simple method is to select the name in the text of any page and drag&drop or copy&paste it to
 MarvinSketch.
 OR
Select the "Import Name" (Ctrl+Shift+N) option from the File menu, and write the name into the text field
 and click the "Import" button (Ctrl+I).

http://onlinelibrarystatic.wiley.com/marvin/help/naming/n2s_webservice.html
http://onlinelibrarystatic.wiley.com/marvin/help/naming/naming_customdic.html
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Name to Structure Conversion in MarvinView

Open a text file (.name) containing IUPAC names (one per row). MarvinView will open all the structures. Opening
 the same file in MarvinSketch, the program will ask you to select one structure (by its index number).

Name to structure conversion from command line

 As a commandline tool, you can use MolConverter for name to structure conversion. Examples:

1. Converting "test.name" name file to MOL file:

 molconvert mol test.name -o test.mol

2. Converting "test.name" name file to "test.smi" SMILES file which also contains the name of the structures:

molconvert smiles:n test.name>test.smi

 The behavior of name to structure can be controlled using format options.

Marvin can also convert structures to names.

See also

name format options
Developer documentation for naming
Document to Structure is used to find names in documents and free text

License information

Name import is only available for a single molecule with the free MarvinSketch desktop application. For batch

http://onlinelibrarystatic.wiley.com/marvin/help/applications/molconvert.html
http://onlinelibrarystatic.wiley.com/marvin/help/formats/name-doc.html#import
http://onlinelibrarystatic.wiley.com/marvin/help/formats/name-doc.html#import
http://onlinelibrarystatic.wiley.com/marvin/help/developer/naming.html
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 conversion (with MarvinView, MolConverter, API, ...) you need the "Name to Structure" licence.



Document to structure

http://onlinelibrarystatic.wiley.com/marvin/help/d2s/d2s.html[11/4/2015 10:00:35 PM]

Document to Structure (d2s) Conversion

 Document to Structure processes PDF, HTML, XML, text files and office file formats: DOC, DOCX, PPT, PPTX, XLS,
 XLSX, ODT. It recognizes and converts the chemical names (IUPAC, CAS, common and drug names), SMILES
 and InChI found in the document into chemical structures.

 d2s conversion uses the name-to-structure converter. For the supported names and current limitation, see
 "Name to Structure Conversion" webpage. You can extend the document to structure conversion by creating a
 custom dictionary file.

 d2s can be used via API, command line application (MolConverter), or MarvinView. Text mining can also be
 automatized by using d2s integrated into Knime or into Pipeline Pilot.

OCR and syntax correction

 Chemaxon's d2s toolkit is able to correct several simple OCR and syntax error. For instance, given the incorrect
 name "3-rnethyl-l-me-thoxynaphthalene", it automatically corrects the name to "3-methyl-1-
methoxynaphthalene" and generates the corresponding structure.

Document to Structure Conversion in MarvinView

Open a PDF file containing chemical names. MarvinView will display all the structures corresponding to the
 recognized names. The structures can then be saved, copy-pasted, opened in the MarvinSketch editor, ...

Document to structure conversion from command line

 As a commandline tool, you can use MolConverter for d2s conversion. Example:

1. Converting "test.pdf" name file to MOL file:

 molconvert mol test.pdf -o test.mol

Structure conversion from OLE objects

 D2s converts the chemical structures from OLE objects – created by various chemical sketchers such as Marvin,
 ChemDraw, ISIS/DRAW, SYMYX DRAW, and Accelrys Draw – embedded in office documents.

Chemical image recognition

 For structures represented as images in PDF or Office documents, d2s can make use of several Image to
 Structure tools (also called Optical Structrure Recognition or Chemical OCR). When such a tool is installed
 and successfully recognizes the image, the chemical structure become part of the output of d2s; it can be
 visualized, edited, indexed and search just like any other structure.

 Currently the supported Image to Structure tools are:

Keymodule CLiDE;
NIH OSRA; and
GGA Imago.

 See configuration instructions to know how to make those tools recognized by d2s.

 Note that structures present as vector graphics rather than bitmap are not converted, unless the osraRendered
 format option is used.

See also

Developer documentation for d2s
d2s code examples

http://onlinelibrarystatic.wiley.com/marvin/help/naming/naming_customdic.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/d2s.html
http://www.chemaxon.com/products/workflow-tools/#knime
http://www.chemaxon.com/products/workflow-tools/#pipelinepilot
http://onlinelibrarystatic.wiley.com/marvin/help/applications/molconvert.html
http://www.keymodule.co.uk/products/clide/clide-batch.html
http://cactus.nci.nih.gov/osra/
http://ggasoftware.com/opensource/imago
http://onlinelibrarystatic.wiley.com/marvin/help/d2s/d2s-osr.html
http://onlinelibrarystatic.wiley.com/marvin/help/developer/d2s.html
http://www.chemaxon.com/marvin/examples/d2s/index.html
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License informations

You need the "Document to Structure" licence.
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 Marvin uses software developed by:

Aloe Swing Extension Package: cb.aloe.swing.tools having LGPL license

JGoodies Forms is a free library.
JGoodies Looks is a free library.
EasyCharts.
Jep - Java Math Expression Parser, see license.
Jacob Java - Com Bridge.
IKVM, see license.

InChITM Material by IUPAC 2005©
JNI-InChI is Copyright © 2006-2010, Sam Adams. JNI-InChI is free software: you can redistribute it and/or
 modify it under the terms of the GNU Lesser General Public License e as published by the Free Software
 Foundation, either version 3 of the License, or (at your option) any later version. (See GPL, LGPL licence.)
Image formats:

Apache SVG Toolkit, see license
JPEG Encoder by James R. Weeks and BioElectroMech©, Independent JPEG Group
PNG encoder by J. David Eisenberg is under LGPL license
PPM encoder by Jef Poskanzer©, see license
VectorGraphics package of FreeHEP Java Library is under LGPL license.
OSRA software by CADD Group Chemoinformatics Tools and User Services
Apache PDFBox -Java PDF Library

MarvinSpace is based on JOGL, a Java interface to OpenGL under Berkeley Software Distribution (BSD)
 License
MarvinSpace uses the DualThumbSlider component of Genomics Institute of the Novartis Research
 Foundation (GNF)
Name to structure and Structure to name use names from the DrugBank database.

http://www.gnu.org/licenses/lgpl.html
http://www.jgoodies.com/freeware/forms/
http://www.jgoodies.com/freeware/looks/index.html
http://www.objectplanet.com/easycharts/
http://www.singularsys.com/jep/
http://www.singularsys.com/order/license.html
http://sourceforge.net/projects/jacob-project
http://www.ikvm.net/
http://weblog.ikvm.net/story.aspx/license
http://www.chemaxon.com/marvin/help/license/IUPACInChI.license.txt
http://jni-inchi.sourceforge.net/
http://www.gnu.org/licenses/gpl.html
http://www.gnu.org/licenses/lgpl.html
http://xmlgraphics.apache.org/batik/
http://www.chemaxon.com/marvin/help/license/LICENSE.batik.txt
http://www.chemaxon.com/marvin/help/license/JpegEncoder.license.txt
http://www.chemaxon.com/marvin/help/license/JpegEncoder.IJGreadme.txt
http://www.chemaxon.com/marvin/help/formats/PngEncoder.java.txt
http://www.gnu.org/licenses/lgpl.html
http://www.chemaxon.com/marvin/help/license/PpmEncoder.license.txt
http://java.freehep.org/vectorgraphics/
http://java.freehep.org/
http://www.gnu.org/licenses/lgpl.html
http://osra.sourceforge.net/
http://cactus.nci.nih.gov/osra
http://pdfbox.apache.org/
https://jogl.dev.java.net/
http://www.opensource.org/licenses/bsd-license.html
http://www.opensource.org/licenses/bsd-license.html
http://www.gnf.org/
http://www.gnf.org/
http://www.drugbank.ca/
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